Objectives Routing Protocols Enhanced IGRP (EIGRP ...

woonsocketpoliticalNetworking and Communications

Oct 28, 2013 (3 years and 11 months ago)

61 views

Copyright © 2001, Cisco Systems, Inc. All rights reserved. Printed in USA.
Presentation_ID.scr
1
© 2007 Cisco Systems, Inc. All rights reserved.Cisco Public
ITE PC v4.0
Chapter 1
1
EIGRP
Routing Protocols and
Concepts – Chapter 9
2
Objectives
 Examine the basic EIGRP configuration
commands and identify their purposes.
 Calculate the composite metric used by
EIGRP.
 Describe the concepts and operation of
DUAL.
 Describe the uses of additional configuration
commands in EIGRP.
3
Routing Protocols
4
Enhanced IGRP (EIGRP) Characteristics
 Advanced distance vector routing protocol
 Classless - supports VLSM and CIDR
 Cisco proprietary
 Scalable, Fast network convergence
 Uses composite metric based on:
Bandwidth (used by default)
Delay (used by default)
Reliability (optional)
Load (optional)
 Supports authentication
5
EIGRP Message Format
 EIGRP messages are carried in unicast or multicast
IP packets.
 EIGRP packet header - contains AS number
 Type/Length/Value Field - data portion of EIGRP
message
 Protocol-dependent modules (PDM) provide a
capability for routing several different protocols
including IP, IPX, and AppleTalk
6
EIGRP
 Reliable Transport Protocol (RTP)
Used instead of TCP.
RTP sends multicast or unicast packets,
depending on the message type
Uses multicast address 224.0.0.10.
 EIGRP has 5 packet types
Hello packets – to discover and establish
adjacencies with neighbour EIGRP routers
Update and Acknowledgement (ACK) packets.
Query and Reply packets
Copyright © 2001, Cisco Systems, Inc. All rights reserved. Printed in USA.
Presentation_ID.scr
2
7
Hello Protocol
 Hello packets are sent periodically to
- Discover directly connected neighbors and
form adjacencies.
- Confirm the link is still up
 Hello interval is 5 seconds (multicasts) or 60
seconds (unicast) by default
 Hold time is three times the hello interval
This is how long EIGRP will wait to receive an
Hello before considering the neighbor down
 Hello and Hold time can be configured by the
administrator (fine tuning)
8
EIGRP Updates
 EIGRP sends updates only when there is a
change in the route status
 EIGRP updates are partial and bounded
Partial – only the route information that has
changed is sent
Bounded – only those devices that are
impacted by the change are notified
 EIGRP’s use of partial bounded updates, and
non-use of broadcasts, minimizes the use of
bandwidth
9
EIGRP Tables
 Routing table
The best route to each network based on
Administrative Distance and Metric
 Neighbor table
Details of EIGRP neighbor adjacencies
 Topology table
Details of all routes
All Successor routes
All Feasible Successor (backup) routes
FD, RD
10
EIGRP AD
 Administrative Distance (AD)
–Defined as the trustworthiness of the source
route
 EIGRP default administrative distances
–Summary routes = 5
–Internal routes = 90
–Imported routes = 170
11
Autonomous System
 This is a collection of networks under the control of
a single authority (RFC 1930)
 AS Numbers are assigned by IANA
 Entities needing AS numbers:
 ISPs
 Internet backbone providers
 Large institutions
12
EIGRP Basic Configuration
 EIGRP autonomous system number actually
functions as a process ID
 A process ID represents an instance of the
routing protocol running on a router
 Process ID is a 16-bit number: 1 to 65535
 All routers in an EIGRP domain must use the
same process ID (or AS number)
 We usually just use the number 1
 Note that using 0 is an error
R(config)#router eigrp autonomous-system
Copyright © 2001, Cisco Systems, Inc. All rights reserved. Printed in USA.
Presentation_ID.scr
3
13
The network statement
 This statement has two functions:
- Determines which interfaces will send and
receive EIGRP hellos and updates
- Determines which networks or subnets will
be advertised to other EIGRP neighbors
R(config-router)#network network-address
14
R1(config)#
router eigrp 1
network 172.16.0.0
network 192.168.10.0
R2(config)#
router eigrp 1
network 172.16.0.0
network 192.168.10.0
15
The network statement with Wildcard Mask
 This option is used when you want to configure
EIGRP to advertise specific subnets
R(config-router)#network net-address [wildcard-mask]
R3(config)#
router eigrp 1
network 192.168.1.0
network 192.168.10.4 0.0.0.3
network 192.168.10.8 0.0.0.3
16
Verifying EIGRP
 EIGRP routers must establish adjacencies with
their neighbors before any updates can be sent or
received
 To view neighbor table and verify that EIGRP has
established adjacencies with neighbors is
show ip eigrp neighbors
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.10.10 Ser0/0/1 13 00:00:53 40 500 0 10
1 172.16.3.1 Ser0/0/0 12 00:00:25 40 500 0 14
R2#
17
Examining the Routing Table
 show ip route command is used to verify EIGRP
 EIGRP routes are denoted by the letter “D”
R2# show ip route
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback1
172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D 172.16.0.0/16 is a summary, 00:07:15, Null0
D 172.16.1.0/24 [90/40514560] via 172.16.3.1, 00:07:15, Serial0/0
C 172.16.2.0/24 is directly connected, FastEthernet0/0
C 172.16.3.0/30 is directly connected, Serial0/0/0
D 192.168.1.0/24 [90/3014400] via 192.168.10.10, 00:07:31, Serial0/1
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D 192.168.10.0/24 is a summary, 00:05:29, Null0
D 192.168.10.4/30 [90/3523840] via 192.168.10.10, 00:05:29, Serial0/1
C 192.168.10.8/30 is directly connected, Serial0/0/1
R2#
18
The Null0 Summary Route
 By default, EIGRP uses the Null0 interface to
discard any packets that match the parent route
but do not match any of the child routes
 EIGRP automatically includes a null0 summary
route as a child route whenever both of the
following conditions exist
–One or more subnets exists that was
learned via EIGRP
–Automatic summarization is enabled
 With EIGRP, auto-summary is enabled by
default
Copyright © 2001, Cisco Systems, Inc. All rights reserved. Printed in USA.
Presentation_ID.scr
4
19
Disabling Automatic Summarization
 The default auto-summary command permits
EIGRP to automatically summarize at major
network boundaries
 The no auto-summary command is used to
disable automatic summarization
 This causes all EIGRP neighbors to send updates
that will not be automatically summarized
 This will cause changes to appear in both
-routing tables
-topology tables
20
Default auto-summary on all routers
R3# show ip route
Gateway of last resort is not set
D 172.16.0.0/16 [90/2172416] via 192.168.10.5, 01:09:36, Serial0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D 192.168.10.0/24 is a summary, 01:09:35, Null0
C 192.168.10.4/30 is directly connected, Serial0/0/0
C 192.168.10.8/30 is directly connected, Serial0/0/1
R3#
router eigrp 1
network 192.168.1.0
network 192.168.10.4 0.0.0.3
network 192.168.10.8 0.0.0.3
21
no auto-summary on all routers
R3# show ip route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D 172.16.0.0/16 [90/2172416] via 192.168.10.5, 00:00:01, Serial0/0
D 172.16.1.0/24 [90/2172416] via 192.168.10.5, 00:00:01, Serial0/0
D 172.16.2.0/24 [90/3014400] via 192.168.10.9, 00:00:01, Serial0/1
D 172.16.3.0/30 [90/41024000] via 192.168.10.9, 00:00:01, Serial0/1
[90/41024000] via 192.168.10.5, 00:00:01, Serial0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D 192.168.10.0/24 [90/2681856] via 192.168.10.5, 00:00:01,Serial0/0
C 192.168.10.4/30 is directly connected, Serial0/0/0
C 192.168.10.8/30 is directly connected, Serial0/0/1
R3#
router eigrp 1
network 192.168.1.0
network 192.168.10.4 0.0.0.3
network 192.168.10.8 0.0.0.3
no auto-summary
22
EIGRP Metric Calculation
 EIGRP calculates a composite metric based on
Bandwidth (minimum interface b/w on path)
Delay (sum of link delays on path)
Reliability
Load
 using the formula:
metric = [K1*bandwidth +(K2*bandwidth/(256-load) )
+ K3*delay] * [K5/(reliability + K4)].
23
EIGRP Metric Calculation
 The default K values are:
K1 and K3 = 1
K2, K4 and K5 = 0
 This means that the default metric calculation
is:
metric = bandwidth + delay
 The K values can be configured to include
Reliability and Load in the calculation if
required by the admin.
24
The bandwidth statement
 Bandwidth is a default static value (in kilobits)
which depends on the type of interface
 On serial interfaces it defaults to 1544 kilobits
(this is a standard T1 line)
 If the actual bandwidth is different, the
calculated metric will not be correct
 The admin can configure the bandwidth value
on a serial interface with the statement:
 Note that the bandwidth statement does not
change the link’s physical bandwidth
R(config-if)#bandwidth kilobits
Copyright © 2001, Cisco Systems, Inc. All rights reserved. Printed in USA.
Presentation_ID.scr
5
25
R2
config
int fa0/0
ip address 172.16.2.1 255.255.255.0
int lo1
ip address 10.1.1.1 255.255.255.252
description To ISP
!
int s0/0/0
ip address 172.16.3.2 255.255.255.252
bandwidth 64
!
int s0/0/1
ip address 192.168.10.9 255.255.255.252
clock rate 1024000
bandwidth 1024
!
router eigrp 1
network 172.16.0.0
network 192.168.10.8 0.0.0.3
26
Diffusing Update Algorithm (DUAL)
 DUAL is the algorithm used by EIGRP
 Determines loop-free routes
 Provides for fast convergence by keeping backup
routes, where possible
 Minimum bandwidth usage with bounded updates
 Design is based on a Finite State Machine
27
DUAL Concepts
 Successor
The best route to a destination. Added to the
routing table
 Feasible distance (FD)
The lowest calculated metric along a path to a
destination network
 Feasible Successor
This a loop free backup route to same
destination as the Successor route, i.e. a
backup route
28
DUAL Concepts
 Reported distance (RD)
The metric that a router reports to a neighbor
about its own cost to that network
 Feasibility Condition
Met when a neighbor’s RD is less than the
local router’s FD to the same destination
network
29
Choosing the best route
 After a router has received all updates from
directly connected neighbors, DUAL can
calculate its routes to each network
 1 - metric is calculated for each route
 2 - the route with lowest metric is designated
the successor & is offered to the routing table
 3 - feasible successor is found
–Criteria for feasible successor: it must have lower
reported distance to the destination than the installed
route’s feasible distance
–Feasible routes are maintained in the topology table
30
 R2 has routes to 192.168.1./24 via R3 and R1
 R3 is the successor route. Why?
 Does the route via R1 qualify as a feasible successor?
Copyright © 2001, Cisco Systems, Inc. All rights reserved. Printed in USA.
Presentation_ID.scr
6
31
R2# show ip eigrp topology
IP-EIGRP Topology Table for AS 1
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 172.16.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 192.168.10.8/30, 1 successors, FD is 3011840
via Connected, Serial0/0/1
P 172.16.0.0/16, 1 successors, FD is 28160
via Summary (28160/0), Null0
P 192.168.10.0/24, 1 successors, FD is 3011840
via Summary (3011840/0), Null0
P 192.168.1.0/24, 1 successors, FD is 3014400
via 192.168.10.10 (3014400/28160), Serial0/0/1
via 172.16.3.1 (41026560/2172416), Serial0/0/0
P 172.16.3.0/30, 1 successors, FD is 40512000
via Connected, Serial0/0/0
P 172.16.1.0/24, 1 successors, FD is 40514560
via 172.16.3.1 (40514560/28160), Serial0/0/0
P 192.168.10.4/30, 1 successors, FD is 3523840
via 192.168.10.10 (3523840/2169856), Serial0/0/1
32
EIGRP Topology Table dissected
33
No Feasible Successor?
 A feasible successor may not be present
because the feasibility condition may not be met
 In other words, the reported distance of the
neighbor is greater than or equal to the current
feasible distance
 If the successor route goes down, the route will
change from Passive mode and be placed in
Active mode. A new route will have to be found
 This will involve querying neighbors
 This will take time
34
Manual Summarization
 Manual summarization can include supernets
Reason: EIGRP is a classless routing protocol
& includes subnet masks in updates
 Statement used to configure manual
summarization
 Route 192.168.1.0 / 24
 Route 192.168.2.0 /24
 Route 192.168.3.0 /24
 Summary 192.168.0.0 /22
R(config-if)# ip summary-address eigrp as net-addr subnet-mask
35
Configuring a summary route in EIGRP
interface Serial0/0/0
ip address 192.168.10.6 255.255.255.252
ip summary-address eigrp 1 192.168.0.0 255.255.252.0 5
clock rate 64000
!
interface Serial0/0/1
bandwidth 1024
ip address 192.168.10.10 255.255.255.252
ip summary-address eigrp 1 192.168.0.0 255.255.252.0 5
36
EIGRP Default Routes
 “quad zero” static default route
-Can be used with any currently supported
routing protocol
-Is usually configured on a router that is
connected to a network outside the EIGRP
domain
 EIGRP & the “Quad zero” static default route
–Requires the use of the redistribute static
command to disseminate default route in
EIGRP updates
Copyright © 2001, Cisco Systems, Inc. All rights reserved. Printed in USA.
Presentation_ID.scr
7
37
Redistribute static route from R2 to R1
R2# show run
router eigrp 1
network 172.16.0.0
network 192.168.10.8 0.0.0.3
no auto-summary
redistribute static
!
ip route 0.0.0.0 0.0.0.0 Loopback1
R1# show ip route
Gateway of last resort is 192.168.10.6 to network 0.0.0.0
192.168.10.0/30 is subnetted, 2 subnets
C 192.168.10.4 is directly connected, Serial0/0/1
D 192.168.10.8 [90/3523840] via 192.168.10.6, 00:12:05, Serial0/0/1
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.1.0/24 is directly connected, FastEthernet0/0
D 172.16.2.0/24 [90/3526400] via 192.168.10.6, 00:12:05, Serial0/0/1
C 172.16.3.0/30 is directly connected, Serial0/0/0
D*EX 0.0.0.0/0 [170/3651840] via 192.168.10.6, 00:02:14, Serial0/0/1
D 192.168.0.0/22 [90/2172416] via 192.168.10.6, 00:12:05, Serial0/0/1
38
Fine-Tuning EIGRP
 EIGRP bandwidth utilization
-By default, EIGRP uses only up to 50% of
interface bandwidth for EIGRP information
-The command to change the percentage of
bandwidth used by EIGRP is
R(config-if)#ip bandwidth-percent eigrp as percent
39
Configuring Hello Intervals and Hold Times
 Hello intervals and hold times are configurable on
a per-interface basis
 Changing the hello interval also requires changing
the hold time to a value greater than or equal to the
hello interval
R(config-if)# ip hello-interval eigrp as seconds
R(config-if)# ip hold-time eigrp as seconds
40
Lab 9.6.1: Basic EIGRP Configuration
This lab can be done on Packet Tracer 4.11 by
downloading the activity, with the following
limitations:
 The WAN cable between R1 and R3 is connected
the wrong way round when compared to the
Hands-on Lab. Delete and reconnect it.
 When no auto-summary is configured, the config
needs to be saved and the router reloaded before
the Null0 routes disappear from the routing table.
 The statement to manually summarize routes is
accepted, but it does not appear to have any
effect.
 Redistribute static statement is not implemented.
41
Lab 9.6.1: Basic EIGRP Configuration