CCNA: Cisco Certified

uptightexampleNetworking and Communications

Oct 24, 2013 (4 years and 19 days ago)

87 views

© Wiley Inc. 2006. All Rights Reserved.
1

CCNA: Cisco Certified
Network Associate Study
Guide

CHAPTER 11:

Wide Area Networking
Protocols

© Wiley Inc. 2006. All Rights Reserved.
2

The CCNA exam topics covered in this
chapter include the following:

Planning & Designing


Choose WAN services to meet customer requirements

Implementation &
Operation


Implement simple WAN protocols

Troubleshooting

Perform simple WAN troubleshooting

Technology


Evaluate key characteristics of WANs

© Wiley Inc. 2006. All Rights Reserved.
3

Defining WAN Terms


Customer Premises Equipment (CPE)


Demarcation (demarc)


Local loop


Central Office (CO)


Toll network

© Wiley Inc. 2006. All Rights Reserved.
4

WAN Connection Types

© Wiley Inc. 2006. All Rights Reserved.
5

DTE
-
DCE
-
DTE

© Wiley Inc. 2006. All Rights Reserved.
6

WAN Support


Frame Relay


ISDN


LAPB


LAPD


HDLC


PPP


ATM

© Wiley Inc. 2006. All Rights Reserved.
7

HDLC Protocol


Bit
-
oriented Data Link layer ISO standard
protocol


Specifies a data encapsulation method


No

authentication can be used

© Wiley Inc. 2006. All Rights Reserved.
8

HDLC Frame Format

© Wiley Inc. 2006. All Rights Reserved.
9

Point
-
to
-
Point Protocol (PPP)


Purpose:


Transport layer
-
3 packets across a Data Link layer
point
-
to
-
point link


Can be used over asynchronous serial
(dial
-
up)
or

synchronous serial (ISDN)
media


Uses Link Control Protocol (LCP)


Builds & maintains data
-
link connections

© Wiley Inc. 2006. All Rights Reserved.
10

Point
-
to
-
Point Protocol Stack

© Wiley Inc. 2006. All Rights Reserved.
11

PPP Main Components


EIA/TIA
-
232
-
C


Intl. Std. for serial communications


HDLC


Serial link datagram encapsulation method


LCP


Used in P
-
t
-
P connections:


Establishing


Maintaining


Terminating


NCP


Method of establishing & configuring Network Layer protocols


Allows simultaneous use of multiple Network layer protocols

© Wiley Inc. 2006. All Rights Reserved.
12

LCP Configuration Options


Authentication (optional)


PAP


CHAP


Compression


Stacker


Predictor


Error detection


Quality


Magic Number


Multilink


Splits the load for PPP over 2+ parallel circuits; a bundle

© Wiley Inc. 2006. All Rights Reserved.
13

PPP Session Establishment


Link
-
establishment phase



Authentication phase (optional)



Network
-
layer protocol phase

© Wiley Inc. 2006. All Rights Reserved.
14

PPP Session Establishment

© Wiley Inc. 2006. All Rights Reserved.
15

PPP Authentication Methods


Password Authentication Protocol (PAP)


Passwords sent in clear text


Remote node returns
username

&
password


Challenge Authentication Protocol
(CHAP)


Done at start
-
up & periodically


Challenge & Reply


Remote router sends a one
-
way hash ~ MD5

© Wiley Inc. 2006. All Rights Reserved.
16

Configuring PPP


Step #1: Configure PPP on Router
A

& Router
B
:



Router__#
config t



Router__(config)#
int s0



Router__(config
-
if)#
encapsulation ppp



Router__(config
-
if)#^
Z


Step #2: Define the username & password on
each

router:


RouterA:

RouterA(config)#
username RouterB password cisco


RouterB:

RouterB(config)#
username RouterA password cisco




NOTE: (1) Username
maps

to the
remote

router





(2) Passwords must match


Step #3: Choose Authentication type for
each

router; CHAP/PAP




Router__(Config)#
int s0




Router__(config
-
if)#
ppp authentication chap




Router__(config
-
if)#
ppp authentication pap




Router__(config
-
if)#^Z




© Wiley Inc. 2006. All Rights Reserved.
17

PPP Example 1

© Wiley Inc. 2006. All Rights Reserved.
18

PPP Example 2

© Wiley Inc. 2006. All Rights Reserved.
19

PPP Example 3

© Wiley Inc. 2006. All Rights Reserved.
20

PPP Example 4

© Wiley Inc. 2006. All Rights Reserved.
21

Frame Relay


Background


High
-
performance WAN encapsulation method


OSI Physical & data Link layer


Originally designed for use across ISDN


Supported Protocols


IP, DECnet, AppleTalk, Xerox Network Service
(XNS), Novell IPX, Banyan Vines, Transparent
Bridging, & ISO

© Wiley Inc. 2006. All Rights Reserved.
22

Before Frame Relay

© Wiley Inc. 2006. All Rights Reserved.
23

After Frame Relay

© Wiley Inc. 2006. All Rights Reserved.
24

Frame Relay


Purpose


Provide a communications interface between
DTE & DCE equipment


Connection
-
oriented Data Link layer
communication


Via virtual circuits


Provides a complete path from the source to
destination before sending the first frame

© Wiley Inc. 2006. All Rights Reserved.
25

Frame Relay Terminology

© Wiley Inc. 2006. All Rights Reserved.
26

Frame Relay Encapsulation


Specified on
serial

interfaces


Encapsulation types:


Cisco (default encapsulation type)


IETF (used between Cisco & non
-
Cisco devices)



RouterA(config)#
int s0


RouterA(config
-
if)#
encapsulation frame
-
relay ?


ietf Use RFC1490 encapsulation


<cr>

© Wiley Inc. 2006. All Rights Reserved.
27

Data Link Connection Identifiers (DLCIs)


Frame Relay PVCs are identified by DLCIs


IP end devices are mapped to DLCIs


Mapped dynamically or mapped by IARP


Global Significance:


Advertised to all remote sites as the same PVC


Local Significance:


DLCIs do not need to be unique


Configuration


RouterA(config
-
if)#
frame
-
relay interface
-
dlci ?

<16
-
1007> Define a DLCI as part of the current

subinterface

RouterA(config
-
if)#
frame
-
relay interface
-
dlci 16

© Wiley Inc. 2006. All Rights Reserved.
28

DLCI’s are Locally Significant

© Wiley Inc. 2006. All Rights Reserved.
29

Local Management Interface
(LMI)


Background


Purpose


LMI Messages


Keepalives


Multicasting


Multicast addressing


Status of virtual circuits

© Wiley Inc. 2006. All Rights Reserved.
30

LMI Types


Configuration:

RouterA(config
-
if)#
frame
-
relay lmi
-
type ?


cisco


ansi


q933a


Beginning with IOS ver 11.2+ the LMI type is auto
-
sensed


Default type: cisco


Virtual circuit status:


Active


Inactive


Deleted

© Wiley Inc. 2006. All Rights Reserved.
31

Sub
-
interfaces


Definition


Multiple virtual circuits on a single serial
interface


Enables the assignment of different network
-
layer characteristics to each sub
-
interface


IP routing on one sub
-
interface


IPX routing on another


Mitigates difficulties associated with:


Partial meshed Frame Relay networks


Split Horizon protocols

© Wiley Inc. 2006. All Rights Reserved.
32

Partial Meshed Networks

© Wiley Inc. 2006. All Rights Reserved.
33

Creating Sub
-
interfaces

Configuration:

#1: Set the encapsulation on the serial interface

#2: Define the subinterface

RouterA(config)#
int s0

RouterA(config)#
encapsulation frame
-
relay

RouterA(config)#
int s0.?


<0
-
4294967295> Serial interface number

RouterA(config)#
int s0.16 ?


multipoint Treat as a multipoint link


point
-
to
-
point Treat as a point
-
to
-
point link


© Wiley Inc. 2006. All Rights Reserved.
34

Mapping Frame Relay

Necessary to IP end devices to communicate


Addresses must be mapped to the DLCIs


Methods:


Frame Relay
map

command


Inverse
-
arp

function

© Wiley Inc. 2006. All Rights Reserved.
35

Using the
map

command

RouterA(config)#
int s0

RouterA(config
-
if)#
encap frame

RouterA(config
-
if)#
int s0.16 point
-
to
-
point

RouterA(config
-
if)#
no inverse
-
arp

RouterA(config
-
if)#
ip address 172.16.30.1 255.255.255.0

RouterA(config
-
if)#
frame
-
relay map ip 172.16.30.17 16
ietf broadcast

RouterA(config
-
if)#
frame
-
relay map ip 172.16.30.18 17
broadcast

RouterA(config
-
if)#
frame
-
relay map ip 172.16.30.19 18

© Wiley Inc. 2006. All Rights Reserved.
36

Using the
inverse arp

command

RouterA(config)#
int s0.16 point
-
to
-
point

RouterA(config
-
if)#
encap frame
-
relay ietf

RouterA(config
-
if)#
ip address 172.16.30.1 255.255.255.0


© Wiley Inc. 2006. All Rights Reserved.
37

Congestion Control


Discard Eligibility (DE)



Forward
-
Explicit Congestion Notification
(FECN)



Backward
-
Explicit Congestion Notification
(BECN)

© Wiley Inc. 2006. All Rights Reserved.
38

Committed Information Rate
(CIR)


Definition: Provision allowing customers
to purchase amounts of bandwidth lower
than what they might need


Cost savings


Good for
bursty

traffic


Not good for
constant

amounts of data
transmission

© Wiley Inc. 2006. All Rights Reserved.
39

Monitoring Frame Relay

RouterA>
sho frame ?


ip show frame relay IP statistics


lmi show frame relay lmi statistics


map Frame
-
Relay map table


pvc show frame relay pvc statistics


route show frame relay route


traffic Frame
-
Relay protocol statistics


RouterA#
sho int s0


RouterB#
show frame map


Router#
debug frame
-
relay lmi

© Wiley Inc. 2006. All Rights Reserved.
40

Troubleshooting Frame Relay

Why can’t RouterA talk to RouterB?

© Wiley Inc. 2006. All Rights Reserved.
41

Troubleshooting Frame Relay

Why is RIP not sent across the PVC?

© Wiley Inc. 2006. All Rights Reserved.
42

Integrated Services Digital Network
(ISDN)


Background



Benefits


Can carry voice, video & data simultaneously


Has faster call setup than a modem


Has faster data rates than a modem connection

© Wiley Inc. 2006. All Rights Reserved.
43

ISDN Components

© Wiley Inc. 2006. All Rights Reserved.
44

ISDN BRI Reference Points & Terminal
Equipment

© Wiley Inc. 2006. All Rights Reserved.
45

ISDN Terminals

© Wiley Inc. 2006. All Rights Reserved.
46

ISDN Reference Points

© Wiley Inc. 2006. All Rights Reserved.
47

ISDN Switch Types

© Wiley Inc. 2006. All Rights Reserved.
48

Basic Rate Interface (BRI)


2B+1D:


Two B
-
channels @ 64Kbps


Data


One D
-
channel @ 16Kbps


Control & signaling


Configuration:


SPIDs: one for each B
-
channel


~ telephone number of each B
-
channel

© Wiley Inc. 2006. All Rights Reserved.
49

Primary Rate Interface (PRI)


23B+1D
(North America)


23 B
-
channels @ 64 Kbps



1 D
-
channel @
64 Kbps


Total bit rate: >1.544 Mbps


Europe/Australia/etc….


30 B
-
channels @ 64 Kbps



1 D
-
channel @
64 Kbps


Total bit rate: >2.048 Mbps

© Wiley Inc. 2006. All Rights Reserved.
50

ISDN with Cisco Routers

Accessing ISDN:


Built
-
in NT1 (U reference point)


BRI interface


ISDN modem (TA)


Used with a router’s serial interface


RouterA#
config t

Enter configuration commands, one per line. End with CTNL/Z.

RouterA(config)#
isdn switch
-
type basic
-
ne1

RouterA(config)#
int bri0

RouterA(config
-
if)#
encap ppp

(optional)

RouterA(config
-
if)#
isdn spid1 085506610100 8650661

RouterA(config
-
if)#
isdn spid2 085506620100 8650662


© Wiley Inc. 2006. All Rights Reserved.
51

Dial
-
on
-
Demand Routing
(DDR)

Allows 2 or more routers to dial an ISDN
dial
-
up connection


As
-
needed basis


Low
-
volume/periodic network connections


Reduces WAN costs


Works when packets meet requirements as “interesting
traffic”

© Wiley Inc. 2006. All Rights Reserved.
52

Configuring DDR

Tasks:

#1: Define static routes


How to get to remote networks


What interface to use

#2: Specify “interesting” traffic


Access Control List

#3: Configure the dialer information


Interface / IP address


Encapsulation


Linkage of ‘interesting traffic’


Telephone number

© Wiley Inc. 2006. All Rights Reserved.
53

Configuring DDR (cont.)

Step #1: Configuring Static Routes:


Participating routers must have static routes
defining routes to known networks


RouterA(config)#
ip route 172.16.50.0 255.255.255.0 172.16.60.2

RouterA(config)#
ip route 172.16.60.2 255.255.255.0 bri0

© Wiley Inc. 2006. All Rights Reserved.
54

Configuring DDR (cont.)

Step #2: Specify
Interesting Traffic


What traffic will bring up the ISDN line


804A(config)#
dialer
-
list 1 protocol ip permit

804A(config)#
int bri0

9
-
4A(config)#
dialer
-
group 1

© Wiley Inc. 2006. All Rights Reserved.
55

Configuring DDR (cont.)

Step #3: Configuring the Dialer
Information


804A#
config t

804A(config)#
int bri0

804A(config
-
if)#
ip address 172.16.60.1 255.255.255.0

804A(config
-
if)#
no shut

804A(config
-
if)#
encapsulation ppp

804A(config
-
if)#
dialer
-
group 1

804A(config
-
if)#
dialer
-
string 8350661




or

804A(config
-
if)#
dialer map ip 172.16.60.2 name 804B
8350661


© Wiley Inc. 2006. All Rights Reserved.
56

DDR with Access Lists


Use
extended access lists

to be more
specific about what is
interesting
traffic…


804A(config)#
dialer
-
list 1 list 110

804A(config)#
access
-
list 110 permit tcp any any eq smtp

804A(config)#
access
-
list 110 permit tcp any any eq telnet

804A(config)#
int bri0

804A(config
-
if)#
dialer
-
group 1

© Wiley Inc. 2006. All Rights Reserved.
57

Verifying the ISDN Operation


ping & telnet


show dialer


show isdn active


show isdn status


show ip route


debug isdn q921


debug isdn q931


debug dialer


isdn disconnect int bri0