Cisco_1_2

reekydizzyNetworking and Communications

Oct 28, 2013 (4 years and 13 days ago)

63 views

C
ISCO
_1_5

R
OUTING

B
ETWEEN

VLAN
S

VLAN
-
TO
-
VLAN O
VERVIEW


Network layer devices combine multiple broadcast domains.

D
IVIDING

A

P
HYSICAL

I
NTERFACE

INTO

S
UBINTERFACES


Physical interfaces can be divided into multiple subinterfaces.

R
OUTING

B
ETWEEN

VLAN
S

WITH

802.1Q
T
RUNKS

interface FastEthernet0/0


no ip address


!

interface FastEthernet0/0.1


encapsulation dot1Q 1 native


ip address 10.1.1.1 255.255.255.0

!

interface FastEthernet0/0.2


encapsulation dot1Q 2


ip address 10.2.2.1 255.255.255.0

S
UMMARY


Inter
-
VLAN routing using a router on a stick utilizes
an external router to pass traffic between VLANs.


A router on a stick is configured with a subinterface
for each VLAN and 802.1Q trunk encapsulation.

I
MPLEMENTING

VLSM

Medium
-
Sized Routed Network Construction

S
UBNETTING

R
EVIEW


To identify subnets, you will “borrow” bits from the
host ID portion of the IP address:


The number of subnets available depends on the number
of bits borrowed.


The available number of subnets = 2
s
, in which
s

is the number
of bits borrowed.


The number of hosts per subnet available depends upon
the number of host ID bits
not

borrowed.


The available number of hosts per subnet = 2
h
-
2, in which
h

is
the number of host bits not borrowed.


One address is reserved as the network address.


One address is reserved as the broadcast address.


P
OSSIBLE

S
UBNETS

AND

H
OSTS

FOR

A


C
LASS

C N
ETWORK

P
OSSIBLE

S
UBNETS

AND

H
OSTS

FOR

A


C
LASS

B N
ETWORK

P
OSSIBLE

S
UBNETS

AND

H
OSTS

FOR

A

C
LASS

A
N
ETWORK

S
UBNETTING

R
EVIEW

E
XERCISE


Subnet a network with a private network address
of 172.16.0.0./16 so that it provides 100 subnets
and maximizes the number of host addresses for
each subnet.


How many bits will need to be borrowed?


What is the new subnet mask?


What are the first four subnets?


What are the range of host addresses for the four
subnets?



W
HAT

I
S

A

V
ARIABLE
-
L
ENGTH

S
UBNET

M
ASK
?

Subnet 172.16.14.0/24 is divided into smaller subnets.


Subnet with one mask (/27).


Then further subnet one of the unused /27 subnets into multiple /30 subnets.

A W
ORKING

VLSM E
XAMPLE

A W
ORKING

VLSM E
XAMPLE

(C
ONT
.)

A W
ORKING

VLSM E
XAMPLE

(C
ONT
.)

A W
ORKING

VLSM E
XAMPLE

(C
ONT
.)

U
NDERSTANDING

R
OUTE

S
UMMARIZATION

Routing protocols can summarize addresses

of several networks into one address.

C
LASSFUL

R
OUTING

O
VERVIEW


Classful routing protocols do not include the subnet mask with
the network in the routing advertisement.


Within the same network, consistency of the subnet masks is
assumed, one subnet mask for the entire network.


Summary routes are exchanged between foreign networks.


Examples of classful routing protocols include:


RIPv1


IGRP



Note: Classful routing protocols are legacy routing protocols
typically used to address compatibility issues. RIP version 1 and
Interior Gateway Routing Protocol (IGRP) are introduced to
provide examples
.


C
LASSLESS

R
OUTING

O
VERVIEW


Classless routing protocols include the subnet mask with
the network in the advertisement.


Classless routing protocols support VLSM; one network
can have multiple masks.


Summary routes must be manually controlled within the
network.


Examples of classless routing protocols include:


RIPv2


EIGRP


OSPF


RIPv2 and EIGRP act classful by default, and summary
routes are exchanged between foreign networks.


The
no auto
-
summary

command forces these protocols to behave
as if they are classless.


S
UMMARIZING

W
ITHIN

AN

O
CTET

S
UMMARIZING

A
DDRESSES

IN

A


VLSM
-
D
ESIGNED

N
ETWORK

R
OUTE

S
UMMARIZATION

O
PERATION

IN


C
ISCO

R
OUTERS

192.16.5.33

/32

Host

192.16.5.32

/27

Subnet

192.16.5.0

/24

Network

192.16.0.0

/16

Block of Networks

0.0.0.0


/0

Default


Supports host
-
specific routes, blocks of networks,

and default routes


Routers use longest prefix match

S
UMMARIZING

R
OUTES

IN

A


D
ISCONTIGUOUS

N
ETWORK


Classful RIPv1 and IGRP do not advertise subnets,

and therefore cannot support discontiguous subnets.


Classless OSPF, EIGRP, and RIPv2 can advertise subnets,

and therefore can support discontiguous subnets.

S
UMMARY


Subnetting lets you efficiently allocate addresses by
taking one large broadcast domain and breaking it up
into smaller more manageable broadcast domains.


VLSMs let you more efficiently allocate IP addresses
by adding multiple layers of the addressing
hierarchy.


The benefits of route summarization include smaller
routing tables and the ability to isolate topology
changes.

128.0.0.0/16

R
EVIEWING

R
OUTING

O
PERATIONS


Medium
-
Sized Routed Network Construction


Static Route


Uses a route that a
network
administrator enters
into the router
manually


Dynamic Route


Uses a route that a
network routing
protocol adjusts
automatically for
topology or traffic
changes

S
TATIC

VS
. D
YNAMIC

R
OUTES

W
HAT

I
S

A

D
YNAMIC

R
OUTING

P
ROTOCOL
?


Routing

protocols are

used between routers to

determine paths to remote

networks and maintain

those networks in the

routing tables.


After the path is determined,

a router can route a
routed


protocol to the learned networks.


An autonomous system is a collection of networks within

a common administrative domain.


Interior gateway protocols operate within an autonomous system.


Exterior gateway protocols connect different autonomous systems.

A
UTONOMOUS

S
YSTEMS
: I
NTERIOR

AND

E
XTERIOR

R
OUTING

P
ROTOCOLS

C
LASSES

OF

R
OUTING

P
ROTOCOLS

S
ELECTING

THE

B
EST

R
OUTE

U
SING

M
ETRICS

A
DMINISTRATIVE

D
ISTANCE
:

R
ANKING

R
OUTING

S
OURCES

Routers choose the routing source with the

best administrative distance:


OSPF has an administrative distance of 110.


EIGRP has an administrative distance of 90.

D
ISTANCE

V
ECTOR

R
OUTING

P
ROTOCOLS

Routers pass periodic copies of their routing table to

neighboring routers and accumulate distance vectors.

S
OURCES

OF

I
NFORMATION

AND


D
ISCOVERING

R
OUTES

Routers discover the best path to destinations from each neighbor.

M
AINTAINING

R
OUTING

I
NFORMATION

Updates proceed step by step from router to router.

I
NCONSISTENT

R
OUTING

E
NTRIES
:

C
OUNTING

TO

I
NFINITY

AND

R
OUTING

L
OOPS

Each node maintains the distance from itself

to each possible destination network.

C
OUNTING

TO

I
NFINITY

Slow convergence produces inconsistent routing.

C
OUNTING

TO

I
NFINITY

(C
ONT
.)

Router C concludes that the best path to

network 10.4.0.0 is through router B
.

C
OUNTING

TO

I
NFINITY

(C
ONT
.)

Router A updates its table to reflect

the new but erroneous hop count.

C
OUNTING

TO

I
NFINITY

(C
ONT
.)

The hop count for network 10.4.0.0 counts to infinity.

S
OLUTION

TO

C
OUNTING

TO

I
NFINITY
:

D
EFINING

A

M
AXIMUM

A limit is set on the number of hops to prevent infinite loops.

R
OUTING

L
OOPS

Packets for network 10.4.0.0 bounce

(loop) between routers B and C.

S
OLUTION

TO

R
OUTING

L
OOPS
: S
PLIT

H
ORIZON

It is never useful to send information about a route back

in the direction from which the original information came.

S
OLUTION

TO

R
OUTING

L
OOPS
:

R
OUTE

P
OISONING

AND

P
OISON

R
EVERSE

Routers advertise the distance of routes

that have gone down to infinity.

S
OLUTION

TO

R
OUTING

L
OOPS
:

R
OUTE

P
OISONING

AND

P
OISON

R
EVERSE

(C
ONT
.)

Poison reverse overrides split horizon.

S
OLUTION

TO

R
OUTING

L
OOPS
:

H
OLD
-
D
OWN

T
IMERS

The router keeps an entry for the “possibly down”

state in the network,

allowing time for other routers to recompute for this topology change.

T
RIGGERED

U
PDATES

The router sends updates when a change in its routing table occurs.

E
LIMINATING

R
OUTING

L
OOPS

E
LIMINATING

R
OUTING

L
OOPS

(C
ONT
.)

E
LIMINATING

R
OUTING

L
OOPS

(C
ONT
.)

L
INK
-
S
TATE

R
OUTING

P
ROTOCOLS

After an initial flood of LSAs, link
-
state routers pass small,

event
-
triggered link
-
state updates to all other routers.

OSPF H
IERARCHICAL

R
OUTING


Consists of areas and autonomous systems


Minimizes routing update traffic


Benefits of link
-
state routing:


Fast convergence
:


Changes are reported immediately by the affected source


Robustness against routing loops:


Routers know the topology


Link
-
state

packets

are sequenced

and acknowledged


Hierarchical network design

enables optimization of

resources.



Drawbacks of link
-
state routing:


Significant demands for resources:


Memory (three tables: adjacency, topology, forwarding)


CPU (Dijkstra’s algorithm
can be

intensive, especially when there are
many

instabilities)


Requires very strict network design


Configuration can be complex when tuning various parameters
and when design is complex

B
ENEFITS

AND

D
RAWBACKS

OF

L
INK
-
S
TATE

R
OUTING


S
UMMARY


Dynamic routing requires administrators to configure
either a distance vector or link
-
state routing protocol.


Distance vector routing protocols incorporate
solutions such as split horizon, route poisoning, and
hold
-
down timers to prevent routing loops.


Link
-
state routing protocols scale to large network
infrastructures better than distance vector routing
protocols, but they require more planning to
implement.