Tutorial para configuração de equipamentos do tipo switch Cisco L3 ...

maidtweetNetworking and Communications

Oct 29, 2013 (3 years and 7 months ago)

84 views

Tutorial para configuração de equipamentos do tipo switch Cisco L3


O objetivo deste tutorial é fornecer meios para um administrador de redes, que já possui
conhecimentos consolidados de redes TCP/IP, configurar um switch Cisco L3 para executar
operações b
ásicas de camadas 2 e 3.

Este material possui várias simplificações que visam a melhor compreensão e facilidade de
implementação por parte do administrador de redes, para maior aprofundamento no assunto,
recomendo os livros da cisco press (
www.ciscopress.com
).

Este tutorial está dividido em três partes: configurações básicas, configurações avançadas e
exemplo de configuração.

Na primeira parte, abordaremos algumas características do equipamento, bem como algumas
co
nfigurações comuns a qualquer switch da rede.

Na segunda parte vamos apresentar as configurações de uma forma genérica, a fim de serem
implementadas em qualquer ponto da rede.

Na terceira parte, teremos um exemplo de configuração que buscará apresentar um
exemplo bem
completo das configurações apresentadas.


Parte I


Configurações Básicas


IOS

O IOS (
Internetwork Operating System
) é o sistema operacional do switch. Cada equipamento pode
ter vários IOS disponíveis, a diferença está nas funcionalidades habil
itadas. O arquivo do IOS fica
armazenado na memória flash e é carregado durante a inicialização do equipamento.


Login no Switch


Quando o switch for ligado pela primeira vez será apresentado as opções de auto
-
instalação, não
aceite esta opção.

Como não t
em senha configurada, o switch já entrará no modo usuário sem pedir senha.


Would you like to terminate autoinstall? [yes]:
no




---

System Configuration Dialog
---


Would you like to enter the initial configuration dialog? [yes/no]:
no


Would you

like to terminate autoinstall?
[yes]:

Switch>


Modos de utilização


O Switch Cisco tem vários modos de utilização.

O primeiro deles é o modo de usuário, que é representado pelo sinal de maior “>”.

Switch>

O segundo é o modo privilegiado, que é representa
do pelo sinal tralha “#”. para passarmos do modo
de usuário para o modo privilegiado, precisamos utilizar o comando
enable
.

Switch>enable

Switch#

Como não tem senha configurada, o switch entrará no modo privilegiado sem pedir senha.

O terceiro modo é o de
configuração global, representado pela palavra “config” no prompt de
comando. A partir deste modo é que são feitas todas as configurações no switch.

Switch#
configure terminal


Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#

Ex
istem também os modos de configuração de interface que serão abordados mais a frente.


Apagar configuração


Entrar no modo privilegiado


Switch#
delete flash:vlan.dat

Delete filename [vlan.dat]?

Delete flash:vlan.dat? [confirm]

Switch#
erase startup
-
config

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

[OK]

Erase of nvram: complete

Switch#
reload

Proceed with reload?
[confirm]


Salvar as configurações do switch


Para salvar as configurações, partimos do modo de configur
ação global e podemos utilizar uma das
opções abaixo.


Switch#
wr

Building configuration...

Configured from console by console[OK]

ou

Switch#
copy running
-
config startup
-
config

Destination filename [startup
-
config]?

Building configuration...

[OK]


As duas o
pções surtem o mesmo efeito, porém a mais fácil é “
wr




Trocar o nome do switch


A partir do modo de configuração global, utilizar o comando “
hostname nome
”, imediatamente o
nome será trocado.

Switch(config)#
hostname Brasil

Brasil(config)#



Configurar se
nha de usuário


Existem, por padrão, duas formas de se conectar no switch, uma através da porta de console e outra
através de telnet. Com o switch sendo ligado pela primeira vez, não existem senhas configuradas e o
login e a alternância entre os modos é fe
ita sem a solicitação de senhas.

Primeiro vamos configurar a senha da porta de console. O primeiro comando
line console 0
, serve
para entrarmos no modo de configuração da console. Agora vamos definir a senha propriamente
dita com o comando
password senha
,
onde a palavra senha é a senha propriamente dita. Por último
precisamos do comando login para que a senha seja solicitada quando entrarmos no switch.

Switch(config)#
line console 0

Switch(config
-
line)#
password cisco senha

Switch(config
-
line)#
login

Switch(co
nfig
-
line)#
exit

Switch(config)#

Uma vez configurada a senha na console, vamos configurar a senha de telnet. A senha de telnet tem
uma particularidade em relação a senha de console, pois é possível realizar mais de uma seção de
telnet ao mesmo tempo, por is
so existem 16 interfaces para telnet. A configuração é realizada como
se segue da mesma forma que a console.

Switch(config)#line vty 0 15

Switch(config
-
line)#password senha

Switch(config
-
line)#login

Switch(config
-
line)#exit

Switch(config)#


Tipos de memóri
a do switch


Nos equipamentos Cisco, temos quatro tipos de memória: ROM, NVRAM, RAM e FLASH.

Memória ROM: ROM quer dizer
Read Only Memory

ou memória apenas de leitura, nesta parte da
mamória estão salvas as configurações necessárias para que o equipamento
inicie o seu
funcionamento. Esta memória não pode ser alterada pelo usuário e nem perde os dados nela
gravados quando desligamos o switch.

Memória NVRAM: NVRAM quer dizer Non Volatil Random Access Memory ou memória de
acesso aleatório não volátil, nesta pa
rte da memória fica salvo o arquivo com as configurações do
switch que serão carregadas sempre que o mesmo iniciar o seu funcionamento, este arquivo de
configuração também é chamado de
startup
-
config.
Esta memória não perde os dados quando o
equipamento é
desligado.

Memória RAM: RAM quer dizer Random Access Memory ou memória de acesso aleatório, nesta
parte ficam armazenadas as informações referentes ao funcionamento do switch, tais como tabelas
de roteamento, tabelas com endereço MAC e o arquivo de configu
ração que está sendo utilizado, o
running
-
config
. Todas as alterações de configuração são realizadas no arquivo
running
-
config,
por
isso que o procedimento de salvar as configurações consiste em gravar este arquivo da memória
RAM para a memória NVRAM. To
da vez que o equipamento é desligado, as informações contidas
na RAM são apagadas.


Visualizar a versão do IOS e modelo do switch

Através do comando show version, podemos verificar as informações referentes ao hardware do
equipamento e da versão do IOS.

Sw
itch#
show version


Cisco IOS Software, C3560 Software (C3560
-
IPBASE
-
M), Version 12.2(35)SE5, RELEASE
SOFTWARE (fc1)

Copyright (c) 1986
-
2007 by Cisco Systems, Inc.

Compiled Thu 19
-
Jul
-
07 18:15 by nachen

Image text
-
base: 0x00003000, data
-
base: 0x01100000


RO
M: Bootstrap program is C3560 boot loader

BOOTLDR: C3560 Boot Loader (C3560
-
HBOOT
-
M) Version 12.2(25r)SEC, RELEASE
SOFTWARE (fc4)


Switch uptime is 57 minutes

System returned to ROM by power
-
on

System image file is "flash:c3560
-
ipbase
-
mz.122
-
35.SE5/c3560
-
i
pbase
-
mz.122
-
35.SE5.bin"


cisco WS
-
C3560
-
24TS

(PowerPC405) processor (revision E0) with 122880K/8184K bytes of
memory.

Processor board ID FDO1146Z8LV

Last reset from power
-
on

1 Virtual Ethernet interface

24 FastEthernet interfaces

2 Gigabit Ethernet interf
aces

The password
-
recovery mechanism is enabled.


--
More
--


512K bytes of flash
-
simulated non
-
volatile configuration memory.

Base ethernet MAC Address : 00:1E:7A:44:97:80

Motherboard assembly number : 73
-
9897
-
06

Power supply part number :
341
-
0097
-
02

Motherboard serial number : FDO11460MRE

Power supply serial number : AZS114203T3

Model revision number : E0

Motherboard revision number : B0

Model number : WS
-
C3560
-
24TS
-
S

System serial number

: FDO1146Z8LV

Top Assembly Part Number : 800
-
26160
-
02

Top Assembly Revision Number : E0

Version ID : V02

CLEI Code Number : COMMG00ARB

Hardware Board Revision Number : 0x01



Switch Ports Model

SW Version SW Image

------

-----

-----

----------

----------


* 1 26 WS
-
C3560
-
24TS 12.2(35)SE5 C3560
-
IPBASE
-
M




--
More
--


Configuration register is 0xF


Sw
itch#


Duas informações importantes estão destacadas, a versão do IOS e o modelo do switch.


Visualizar as configurações do switch

Agora que já aprendemos um pouco sobre as memórias e arquivo de configuração, vamos verificar
as configurações correntes no s
witch.

Para verificar o conteúdo do arquivo de configuração que está sendo utilizado, vamos fazer uso do
comando show running
-
config a partir do modo privilegiado.


Switch#
sh running
-
config


Building configuration...


Current configuration : 1270 bytes

!

v
ersion 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password
-
encryption

!

hostname Switch

!

!

no aaa new
-
model

system mtu routing 1500

ip subnet
-
zero

!

!

!

!

no file verify auto

spanning
-
tree mode pvst

spanni
ng
-
tree extend system
-
id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEth
ernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastE
thernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface
GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1


no ip address


shutdown

!

ip classless

ip http server

!

!

control
-
plane

!

!

line con 0


password senha


login

line vty 0 4

password senha


login

line vty 5 15

password senha


login

!

end


Switch#


Vamos atentar para alguns detalhes sublinhados no arquivo de configuração.

a) Logo no início podemos ver a configuração referente ao nome do equipamento;

b) Podemos verificar que este switch possui 24 portas fastethernet e duas portas gigabitethe
rnet;

c) Neste ponto ainda não iremos introduzir o conceito de Vlan, mas, por hora, cabe ressaltar a
existência da Vlan 1 que é default em todo switch e não pode ser apagada, somente desabilitada;

d) Temos também a configuração ip http server, que habilita

um servidor web para configurar o
switch, este servidor pode ser desabilitado através do comando
no ip http server
. É uma boa pr[ática
de segurança desabilitar este servidor;

e) Repare que as senhas de console e de telnet aparecem em texto claro e precisa
m ser
criptografadas.


Criptografar as senhas de console e telnet


Para criptografas as senhas, vamos utilizar o serviço de criptografia do switch, através do comando
service password
-
encryption.


Switch(config)#
service password
-
encryption

Switch(config)#
end

Switch#
show runnning
-
config

###

Saída omitida

###

line con 0


password 7 03175E050E0E


login

line vty 0 4


password 7 03175E050E0E


login

line vty 5 15


password 7 15010E020C2B


login


Agora a senha não aparece mais em texto claro.


Configuração da sen
ha de modo privilegiado (enable)


A senha de enable pode ser do tipo password, que possui uma criptografia fraca, ou do tipo secret
que possui uma criptografia melhor. Vamos demonstrar somente o modo secret.


Switch(config)#
enable secret senha

Switch(confi
g)#end

Switch#wr

Building configuration...

[OK]

Switch#
show runnning
-
config

###

Saída omitida

###

!

enable secret 5 $1$OEJ7$CubpRMlCGH.7M9NONRSWh.

!

###

Saída omitida

###


Parte II


Configurações avançadas


Até este ponto foi possível fazer as configuraçõ
es básicas que devem ser realizadas em todos os
switches. A partir deste ponto vamos abordar as configurações mais específicas do equipamento.


Configurações de camada 2


O que é o CDP?

CDP é o Cisco Discovery Protocol ou protocolo de descobrimento Cisco,
este protocolo indica a
conectividade de camada 2 existentes entre switches Cisco diretamente conectados.

Switch#sh cdp neighbors

Capability Codes: R
-

Router, T
-

Trans Bridge, B
-

Source Route Bridge


S
-

Switch, H
-

Host, I
-

IGMP, r
-

Repeater, P
-

Phone


Device ID

Local Intrfce Holdtme Capability

Platform

Port ID

CENTRO



Fas 1/0/21 151

R


2621

Fas 0/0

BARRA

Fas 1/0/19 141

R S I

WS
-
C3560
-
2

Fas 0/
1

LAGOA

Fas 1/0/1 127

R S I

WS
-
C3750
-
2

Fas 2/0/3

NITEROI

Fas 1/0/17 168

R S I

WS
-
C3560
-
2

Fas 0/1

IPANEMA

Fas 1/0/24 130

R S I

WS
-
C3560
-
8

Fas 0/8


Através do CD
P, podemos verificar o nome dos equipamentos diretamente conectados, a interface
local onde o equipamento remoto está conectada, o tempo de conexão, as capacidades, a plataforma
do equipamento conectado e a porta no equipamento conectado.

Este protocolo é
muito importante, pois podemos verificar se existe conectividade de camada 2
entre os equipamentos.

Cabe ressaltar que o CDP só funciona com equipamentos Cisco e diretamente conectados.

Para desabilitar o CDP, basta utilizar o comando
no cdp enable
.


Criar

uma Vlan

Vlan quer dizer
virtual local area network

ou rede local virtual. Uma Vlan, como o próprio nome já
diz é uma rede local virtual, ou seja, a vlan não se prende a um único switch ou espaço físico, uma
vlan pode existir em todos os switches da rede,

basta apenas que os mesmos sejam configurados
adequadamente. No nosso caso, vamos configurar uma vlan para cada grupo específico de usuários,
que podem estar no mesmo espaço físico, ou separados físicamente.

Para criar uma Vlan existe mais de um método, m
as neste texto será apresentado apenas um.

Switch(config)#
vlan 100

Switch(config
-
vlan)#
name BACKBONE

Com estes comandos criamaos a Vlan de número 100 com o nome BACKBONE. Para verificar a
configuração vamo utilizar o comando
show vlan
.

Switch#sh vlan


VLAN

Name Status Ports

----

--------------------------------

---------

-------------------------------

1

default


active

Fa0/1, Fa0/2, Fa0/3, Fa0/4






Fa0/5, Fa0/6, Fa0/7, Fa0/8




Fa0/9, Fa0/10, Fa0/11, Fa0/12





Fa0/13, Fa0/14, Fa0/15, Fa0/16




Fa0/17, Fa0/1
8, Fa0/19, Fa0/20




Fa0/21, Fa0/22, Fa0/23, Fa0/24




Gi0/1, Gi0/2

100

BACKBONE active

###

Saída omitida

###


Reparem que a Vlan foi criad
a corretamente, porém não existente nenhuma porta associada a ela.


Configurar uma interface do tipo Vlan

A interface do tipo Vlan recebe configuração de IP/Máscara (ip address), descrição (description) e
ativação (no shutdown).

Switch(config)#interface vl
an 100

Switch(config
-
if)#description Vlan Rede Backbone

Switch(config
-
if)#ip address 10.1.0.254 255.255.255.0

Switch(config
-
if)#no shutdown

Switch(config
-
if)#end

Switch#show runnig
-
config

###

Saída omitida

###

interface Vlan100


description Vlan Rede Backb
one


ip address 10.1.0.254 255.255.255.0

###

Saída omitida

###


Tipos de portas associadas a Vlans

Existem duas formas de associar portas a uma Vlan, o modo acesso e modo Trunk.

No modo acesso qualquer equipamento pode ser conectado a porta e todos os equi
pamentos
cascateados naquela porta pertenceram a mesma Vlan.

No modo trunk a porta do switch deverá necessariamente estar conectada a outro equipamento com
configuração de trunk de Vlan. No trunk de Vlan, o enlace é dividido lógicamente formando vários
enl
aces distintos onde os dados permanecerão separados.


Associando portas a uma Vlan no modo de acesso

O modo de acesso deverá ser utilizado quando todos os equipamentos conectados a porta
pertencerem a mesma Vlan. Para associar uma porta a uma Vlan no modo
de acesso, precisamos
entrar no modo de configuração de interface e associar a inteface a Vlan.

Um bom procedimento quando lidamos com Vlans e temos portas sobrando no Switch é associar
duas portas a mesma Vlan, mesmo que tenhamos apenas um equipamento con
ectado a Vlan.

Após criarmos a Vlan 100, vamos adicionar as portas FastEthernet 0/1 e 0/2 a Vlan 100.

Switch(config)#
interface FastEthernet 0/1

Switch(config
-
if)#
switchport mode access


Switch(config
-
if)#
switchport access vlan 100

Switch(config
-
if)#
descrip
tion Interface Vlan 100

Switch(config
-
if)#
no shutdown

Switch(config)#
interface FastEthernet 0/2

Switch(config
-
if)#
switchport mode access

Switch(config
-
if)#
switchport access vlan 100

Switch(config
-
if)#
description Interface Vlan 100

Switch(config
-
if)#
no shu
tdown

Para verificar as configurações nas interfaces, vamos utilizar o comando
show ruuning
-
config
.

Switch#
show running
-
config

###

Saída omitida

###

interface FastEthernet0/1


description Interface Vlan 100


switchport access vlan 100


switchport mode acc
ess

!

interface FastEthernet0/2


description Interface Vlan 100


switchport access vlan 100


switchport mode access

###

Saída omitida

###


Outra forma de verificar que as portas foram corretamente associadas a Vlan é através do comando
show vlan
.

Switch#sh
ow vlan


VLAN

Name

Status

Ports

----

--------------------------------

---------

-------------------------------

1


default

active

Fa0/3, Fa0/4, Fa0/5, Fa0/6







Fa0/7, Fa0/8, Fa0/9, Fa0/10






Fa0/11, Fa0/12, Fa0/13, Fa0/14






Fa0/15, Fa0/16, Fa0/17, Fa0/18







Fa0/19, Fa0/20, Fa0/21, Fa0/22






Fa0/23, Fa0/24, Gi0/1, Gi0/2

100


BACKBONE active

Fa0/1, Fa0/2

###

Saída omitida

###


Associando portas a uma Vlan no modo Trunk

Apó
s a criação das Vlans, configurar uma porta no modo trunk é bem paracido com o modo de
acesso, porém a porta não é associada a nenhuma Vlan específica, permitindo que todas as Vlans
configuradas no switch possam trafegar através da porta. Uma observação im
portante é que as vlans
devem estar configuradas normalmente nos dois switches com portas no modo acesso e a porta no
modo trunk será apenas para ligação entre os switches. Vamos configurar as portas FastEthernet
0/23 e 0/24 com o modo trunk.

Switch(config
-
if)#
interface FastEthernet 0/23

Switch(config
-
if)#
switchport trunk encapsulation dot1q

Switch(config
-
if)#
switchport mode trunk

Switch(config
-
if)#
description Interface Trunk

Switch(config
-
if)#
no shutdown

Switch(config
-
if)#
interface FastEthernet 0/24

Swit
ch(config
-
if)#
switchport trunk encapsulation dot1q

Switch(config
-
if)#
switchport mode trunk

Switch(config
-
if)#
description Interface Trunk

Switch(config
-
if)#
no shutdown


Uma observação importante é que no comando show vlan as portas 0/23 e 0/24 não vão apa
recer
associadas a nenhuma Vlan.

Switch#
show running
-
config

###

Saída omitida

###

interface FastEthernet0/23


description Interface Trunk


switchport trunk encapsulation dot1q


switchport mode trunk

!

interface FastEthernet0/24


description Interface Trun
k


switchport trunk encapsulation dot1q


switchport mode trunk

###

Saída omitida

###


Configurações de camada 3


Habilitado o roteamento

As configurações de camada 3 ficam caracterizadas pela utilização de roteamento IP no switch. Para
habilitarmos o rotea
mento utilizamos o comando
ip routing
.

Switch(config)#
ip routing


Tipos de rotas

Existem vários tipos de rotas referentes aos vários tipos de protocolos de roteamento disponíveis
nos switches L3. Através do comando show ip route podemos ver as rotas e os

seus respectivos
tipos.

Switch#
show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2



E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static

route


Gateway of last resort is not set

###

Saída omitida

###


Cabe ressaltar que os tipos de rotas que podem ser configuradas dependem do IOS que está em uso.

Rotas diretamente conectadas dizem respeito as Vlans ativas que estão configuradas no switch e

são
configuradas automaticamente. As rotas estáticas são as de maior prioridade, seguido das rotas
estáticas e depois das rotas aprendidas dinamicamente.


Configurando rotas estáticas

As rotas no switch representam os caminhos percorridos pelos pacotes na

rede. Cada switch da rede
deve conhecer todas as redes, ou então possuir um default gateway e este por sua vez deve conhecer
as redes.

Para incluir uma rota estática, utilizamos o comando
ip route

<ip rede destino> <máscara da rede
destino> <gateway>

Swit
ch(config)#ip route 10.2.2.0 255.255.255.0 10.1.1.254

Para configurar um default gateway utilizamos o comando
ip default
-
gateway

<ip gateway>.

Switch(config)#
ip default
-
gateway

10.1.1.254