Distance Vector Protocols

hardsweetlipsNetworking and Communications

Oct 28, 2013 (4 years and 16 days ago)

72 views

Perrine
modified by Brierley

Page
1

Chapter 7

CCNA2 Chapter 7

Distance Vector Protocols

Perrine
modified by Brierley

Page
2

Chapter 7

Dynamic Routing


Avoids
configuration of static routes


Routers react

to changes in the network


Routers adjust

their
routing tables

accordingly,
without the intervention of the network administrator


There are problems associated with dynamic
distance vector routing

Perrine
modified by Brierley

Page
3

Chapter 7

Distance Vector Routing Protocols


RIP is a distance vector routing protocol that is used in
thousands of networks throughout the world


RIP is
based on open standards

and is easy to
implement

makes it attractive to some network administrators


RIP is a good
basic protocol for networking students



IGRP is another distance vector routing protocol.


Unlike RIP, IGRP is a Cisco
-
proprietary protocol rather than a
standards
-
based protocol.


IGRP is simple to implement


IGRP is a more complex routing protocol than RIP and can use
many factors to determine the best route to a destination
network.


NOTE: for our PacketTracer labs, we’ll use EIGRP
)

Perrine
modified by Brierley

Page
4

Chapter 7

Distance vector routing protocols


Require routers to forward their entire routing table when passing along
updates


Routing table information is forwarded to neighbor routers, which continue to
forward the information to their neighbors..


These routing tables include information about the total cost of a route

and
the logical address of the first router on the path to each network contained
in the table.


Routers need to update the information in their routing tables to make good
path determination decisions.


Updates may be initiated when topology changes occur


Changes in a network affect the decisions made by a router.


A router may be taken off line for upgrades or repairs or an
interface on a router may go down.


If not aware of the changes that have occurred in a network,
routers may switch packets to interfaces that are no longer
connected to the best route.


Distance vector routing protocols
typically send out updates

at certain time
intervals


Every 30 seconds for RIP..


Every 90 seconds for IGRP

Perrine
modified by Brierley

Page
5

Chapter 7

A Network

converges

when all the routers in the network have the

same
routing information.

If a link goes down, it is possible that invalid updates will continue to loop
through out the network. This is called the

count to infinity
.

RIP routing protocol counts the count to infinity by

hop count.

RIPs
maximum hop count is 15.

After 15 hops the packet is discarded by RIP.

Routing Loops

Perrine
modified by Brierley

Page
6

Chapter 7

A packet arrives at Router 1 at time t1. Router 1 has already been updated and knows
that the optimal route to the destination calls for Router 2 to be the next stop

Router 1 therefore forwards the packet to Router 2. Router 2 has not yet been updated
and believes that the optimal next hop is Router 1. Router 2 therefore forwards the
packet back to Router 1

The packet will continue to bounce back and forth between the two routers until Router
2 receives its routing update or until the packet has been switched the maximum
number of times allowed

This process illustrates the
count to infinity problem

-

there are several solutions to this
problem:


Perrine
modified by Brierley

Page
7

Chapter 7

Split Horizon




Disables the router from sending information about a ‘failed’ route in the
routing table. This is done by

not

sending the information through the same
interface that it learned about the failed route

That is, it would prevent
Router A
from sending the updated information if
received from
Router B

back to Router B



A

B

171.10.0.0

Network 171.10.0.0 is down

Get to network 171.10.0.0 via B

Is Down!

Split Horizon

Perrine
modified by Brierley

Page
8

Chapter 7


Poison Reverse




A route that is not ‘good’ is sent a

poison reverse

which removes the
route

Network 4

Network 5

C

E

When Network 5 goes down, Router E initiates route poisoning by
entering a table entry for Network 5 as 16, for RIP,

unreachable
.


By this poisoning of the route to Network 5, Router C is not susceptible to
incorrect updates about the route to Network 5.

When Router C receives a router poisoning from Router E, it sends an
update, called a

poison reverse
, back to Router E.


This makes sure all routes on the segment have received the poisoned
route information.

Poison Reverse

Perrine
modified by Brierley

Page
9

Chapter 7

Holddown




Is used to prevent regular update messages from reinstating a route that
may have gone bad

When a router receives an update from a neighbor indicating that a

previously accessible network is not working
-

is inaccessible
, the
holddown timer will start


If a new update arrives from a different neighbor with a

better metric

than
the original network entry, the holddown is removed and data is passed

However, if an update is received from the same neighbor router

before
the holddown timer expires, and it has a lower metric than the
previous route
,
the update is ignored and the holddown timer keeps
ticking


One Solution to Count to Infinitive

Perrine
modified by Brierley

Page
10

Chapter 7

RouterA#
config t

RouterA(config)#
router rip

RouterA(config
-
router)#
network 192.10.10.0

RouterA(config
-
router)#
network 172.120.0.0

RouterA(config
-
router)#
network 210.45.20.0

RouterA(config)#
int s0

RouterA(config
-
if)#
ip rip triggered

s0

s1

e0

192.10.10.0 net

172.120.0.0 net

210.45.20.0 net

If topology changes, this
command will ‘triggered’ those
updates to the next router.

Only
applied to a
serial interface
.

Configure RIP

Perrine
modified by Brierley

Page
11

Chapter 7

RIP

uses the following techniques to reduce

routing loops

and

count
to infinity
.
In some cases, configuration is required:



count
-
to
-
infinity



split horizon



poison reverse



holddown counters



triggered updates

To

disable

split horizon do:

RouterA(config
-
if)#
no ip split
-
horizon

RIP Configuration Issues

Perrine
modified by Brierley

Page
12

Chapter 7

To change RIP’s update interval do:


RouterA(config
-
router)#
update
-
timer

<
seconds>

To disable sending RIP updates do:


RouterA(config
-
router
)# passive
-
interface

<
interface
>

Command to receive either version of RIP, do

RouterA(config
-
if)#
ip rip receive version 1

RouterA(config
-
if)#
ip rip receive version 2

RouterA(config
-
if)#
ip rip receive version 1 2

RIP Configuration Issues

Perrine
modified by Brierley

Page
13

Chapter 7

Router#
config term

Router(config)#
router rip

Router(config
-
router)#

timers basic

update

Intervals between updates

invalid

route is invalid after receiving no
updates in secs

holddown

holddown time

flush

when route is flushed from table

update


30 seconds

holddown
-

180 seconds

Administrative Distance
-

120

RIP Configuration Issues

Perrine
modified by Brierley

Page
14

Chapter 7

NOTE

for RIP:

Its metric to determine a route to a destination is the

hop count
.


As a packet goes from router to router, RIP

increments

a counter
called hop count.

RIP Configuration Issues

Perrine
modified by Brierley

Page
15

Chapter 7

Use the following commands to make RIP verifications:

show ip route

The routing table will have “R” by the routes determined by the RIP
routing protocol

show ip protocols

This will verify:



RIP routing is configured (which protocol is configured)



Which interfaces are sending & receiving RIP updates



Which network it is sending information to

RIP Configuration Verification

Perrine
modified by Brierley

Page
16

Chapter 7

Some RIP debugging commands are:

debug ip rip

show ip rip database

show ip interface brief

Debugging Commands for RIP

Perrine
modified by Brierley

Page
17

Chapter 7

NOTE:

Router Rip cannot handle Classless Routing, but
Rip ver2

can.

A supernet route (classless route) is a route that covers a greater range
of subnets with a single entry. An example a supernet of 172.16.0.0/16
could be 172.16.0.0/13.

However, a router by default assumes that all subnets of a directly
connected network should be present in the routing table.

If a packet is received with an unknown destination address within an
unknown subnet of a directly attached network, the router assumes
that the subnet does not exist, and will drop this packet.

To get around this problem, use a global command:

ip classless.

Classless Routing

Perrine
modified by Brierley

Page
18

Chapter 7

Load
-
balancing

describes the ability of a router to transmit packets to a
destination IP address over more than one path

When a router learns multiple routes to a specific network, the route with the

lowest administrative

distance is entered into the routing table

To set maximum number of parallel paths:

RouterA(config
-
router)#
maximum
-
paths [
number
]

RIP


Load Balancing

Perrine
modified by Brierley

Page
19

Chapter 7

Route Source

Default Distance

Connected interface


0

Static route


1

EIGRP summary route


5

External BGP


20

Internal EIGRP


90

External EIGRP

170

IGRP

100

OSPF

110

IS
-
IS

115

RIP

120

EGP

140

Internal BGP

200

Unknown

255

Administrative Distance

Perrine
modified by Brierley

Page
20

Chapter 7

Floating static routes

are static routes configured with an
administrative
distance value that is greater

than

that of the
primary route

(or routes).

Essentially, floating static routes are

fallback routes
,
or
backup routes
, that do
not appear in the routing table until another route fails.

Example:

RouterA(config)#ip route 200.10.10.0 255.255.255.0 192.16.10.1


30

Floating Static Routes

Perrine
modified by Brierley

Page
21

Chapter 7

RTA(config)#
ip route 0.0.0.0 0.0.0.0 s0


RTA(config)#
router rip

RTA(config
-
router)#
default
-
information originate


For RIP, if a static route is assigned to an interface that is not one of the
networks defined in a
network

command, no dynamic routing protocols
advertise the route. Use
redistribute static

command.


To redistribute static default route, must use the
default
-
information
originate

command.


Example:

RIP


Redistribute Static Routes

Perrine
modified by Brierley

Page
22

Chapter 7

IGRP
:



must be assigned an “AS”

(autonomous system #
-

16 bit number)



Cisco proprietary



distance
-
vector



metrics



delay



bandwidth (1200 bps
-

10 Gbps)



reliability (1
-
224) (higher the number, more reliable)



load (1
-
244) (higher the number, more it is under load)



sends updates

every
90 seconds



maximum hop count is 255

(default 100)

IGRP

Perrine
modified by Brierley

Page
23

Chapter 7

IGRP has number of features that are designed to enhance its stability:



holddowns



split horizons



poison reverse updates

IGRP

Perrine
modified by Brierley

Page
24

Chapter 7

Router#
config term

Router(config)#
router igrp 100

Router(config
-
router)#
timers basic 90 270 280 630

[Default settings]

Intervals between updates

route is invalid after receiving no
updates in secs

holddown time

when route is flushed from table

update

invalid

holddown

flush

Router(config
-
router)#
timers basic

Setting IGRP Basic Timers

Perrine
modified by Brierley

Page
25

Chapter 7

RouterA#
config t

s0

s1

e0

192.10.10.0

network address

172.120.0.0
network address

210.45.20.0

network address

RouterA(config)#
router igrp 101

RouterA(config
-
router)#
network

192.10.10.0

RouterA(config
-
router)#
network

172.120.0.0

RouterA(config
-
router)#
network
210.45.20.0


Configure IGRP

Perrine
modified by Brierley

Page
26

Chapter 7

Helpful commands for troubleshooting IGRP:



show ip protocols



show ip route



debug ip igrp events



debug ip igrp transactions



ping



traceroute

Troubleshooting IGRP