Chapter 4 - YSU Computer Science & Information Systems

greydullNetworking and Communications

Oct 30, 2013 (3 years and 7 months ago)

67 views

Semester 6


Chapter 4

ISDN

ISDN Uses


Used primarily as a WAN backup
technology


to provide remote access to
telecommuters and small offices


to support large numbers of POTS
(analog modem) and/or ISDN Basic
Rate Interface (BRI) calls.


DSL vs ISDN


offers much higher throughput at a lower
cost.


However, ISDN still used because


ISDN is more widely available than DSL or cable.


Many companies and service providers have
made a significant investment in ISDN equipment
and training, and plan to continue leveraging that
investment.


Remote offices using ISDN can connect to central
offices directly, without traversing the public
Internet. Most DSL and cable implementations
require the remote host communicate with the
central site using a VPN over the Internet.



ISDN Advantages Over Analog
(Asychronous)


Higher Speed


Faster Call Setup


Cheaper than leased lines


Can run voice and data simultaneously

BRI Characteristics


Two 64
-
kbps bearer channels


One 16
-
kbps delta channel


48 kbps of framing and synchronization
information


Total speed of 192 kbps


Although not commonly done, you may
reference the total bandwidth of an ISDN BRI,
including framing and synchronization, which
is 192 kbps.


PRI over T1


23 64
-
kbps bearer channels


One 64
-
kbps D channel, carried in
timeslot 24


8 kbps of framing and synchronization
information


Total speed of 1.544 Mbps


PRI Over E1


30 64
-
kbps bearer channels


One 64
-
kbps D channel, carried in
timeslot 16


64 kbps of framing and synchronization
information


Total speed of 2.048 Mbps


ISDN Call Processing


Signaling System 7 (SS7) protocols
used to set up a path inside the public
switched telephone network (PSTN)


931.q is used between end user and
ISDN switch


D channel is used for signaling


Designations


E

Telephone network standards


I

Concepts, terminology, and methods


Q

Signaling and switching

PRI


a channel service unit/data service unit
(CSU/DSU) is required to connect a router
(the TE) to the carrier network. Internal
CSU/DSUs are common among modular
routers.


PRI's primary application is modem
aggregation


not point
-
to
-
point connectivity


Can provide both analog and digital dial
solutions


ISDN and OSI Model


Operates at layers 1 2, and 3


Layer 1


.430 for BRI, .431 For PRI, ANSI T1.601 for BRI


Layer 2


As specified by Q.921, the D channel typically
frames data using Link Access Protocol on the D
channel (LAPD)


Layer 3


the B channel can carry datagrams using a variety
of Layer 3 protocols, including IP, IPX, and
AppleTalk.



TE1 Addresses


0
-
63 for non
-
automatic TEI assignment


64
-
126 for automatic TEI assignment


127 for group assignment, or broadcast


TEI works together with the service access
point identifier (SAPI) to complete the Layer 2
address


SAPI

is a 6
-
bit number used to identify and
manage


TEI represents the specific ISDN device, while the
SAPI represents the specific process running on
that device


ISDN Call Termination


disconnect


release


release complete


It issues a disconnect message to the calling
party.


It starts a timer to ensure receipt of a released
message.


It disconnects the switched path.


When a released message is received from the
preceding exchange, it returns a release complete
message to the preceding exchange.


ISDN Addressing Tasks


Assign the IP address


Assign dialer group (for DDR),


Assign ISDN service profile statements (SPID
numbers


Include a
dialer map

command that
associates a statically mapped destination to
a destination IP address, hostname, and
ISDN dial number.


ISDN switch type can be set in global mode
or assigned to individual interfaces


BRI Interface Commands


RTA(config)#
interface bri 0

RTA(config
-
if)#
isdn switch
-
type basic
-
5ess



Router(config
-
if)#encapsulation ppp


Router(config
-
if)#ppp authentication chap


Other encapsulations


encapsulation [ppp | labp | hdlc | x25 | cpp]

DDR Configuration


1.Define what constitutes interesting traffic by
using the dialer
-
list command.


2.Assign this traffic definition to an interface by



using the dialer
-
group command.


3.Define the destination address, hostname, and



telephone number to dial by using the dialer



map command.


4.(Optional) Define call parameters by using other



dialer commands such as dialer idle
-
timeout,
dialer fast
-
idle, and dialer load
-
threshold.

Dial
-
on
-
Demand Commands



Router(config)#dialer
-
list dialer
-
group
-
number
protocol protocol
-
name {permit | deny}


RTA(config)#dialer
-
list 1


Router(config)#access
-
list access
-
list
-
number
[permit |deny] {protocol | protocol
-

keyword}{source source
-
wildcard |
any}{destination destination
-
wildcard |
any}[protocol
-
specific
-
options] [log]protocol ip
permit


Attach Dialer List to Interface



Router(config)#dialer
-
list 1 protocol ip
permit



Router(config)#interface bri0



Router(config
-
if)#dialer
-
group 1




Note: For a given protocol and a given
dialer group, only one access
-
list can be
specified in the dialer
-
list command.

Dialer Map Command


Identifies destination router information, such as
the phone number to dial:



Router(config
-
if)#dialer map protocol next
-
hop
-
address [name hostname] [broadcast] dial
-
string


Cisco IOS commands often contain the word
"map," which is used to statically map Layer 2
addresses to Layer 3 addresses


Dialer maps for inbound calls are maps between
protocol addresses and authenticated user names

Call Parameters


Router(config
-
if)#dialer idle
-
timeout seconds


Router(config
-
if)#dialer fast
-
idle seconds


Router(config
-
if)#dialer load
-
threshold load
[outbound | inbound |


To manually set the idle timeout value, use the
dialer idle
-
timeout command


By default, the idle
-
timeout is set to 120 seconds either]



The dialer load
-
threshold command is used to
specify the interface load at which the router will
initiate another call to the destination

DDR Environment


In a DDR environment, dynamic routing
can be a source of problems.


Routing protocols such as RIP and OSPF
rely on regular communication between link
partners.


If routers are connected via a dial
-
up link,
active connections are usually intermittent.

Routing Solutions


WAN core and remote sites run different
protocols, route redistribution may be necessary to
"share" routing information between the different
protocols.


use static and default routing to address the
challenge of routing in a DDR network



use dynamic routing, including route
redistribution, to propagate routes


Use snapshot routing for serial connections


Static routes are entered manually


no need
for routing tables


Central(config)#ip route 172.24.2.0
255.255.255.010.2.3.2


At least one static route pointing to the
next
-
hop IP address is necessary for DDR to
work


Router(config)#ip route 0.0.0.0 0.0.0.0 {next
-
hop
-
address | exit
-
interface}

Redistributing EIGRP/Static


RTA(config)#ip route 123.22.1.1
255.255.255.0 bri0


RTA(config)#router eigrp 100


RTA (config
-
router)# redistribute static

Passive Interface


R(config)#IP route 10.0.0.1 255.255.0.0
192.16.3.0


R(config)#router rip


R(config)#version 2


R(config)#network 10.0.0.0


R(config)#redistribute static


R(config)#passive
-
interface bri0/0


To avoid routing updates initiating a call



Snapshot Routing



RIP for IP, IGRP for IP, Novell RIP and SAP
for Novell IPX, Routing Table Maintenance
Protocol (RTMP) for AppleTalk, Routing Table
Protocol (RTP) for Banyan VINES


When distance vector router updates are not considered
interesting traffic, router drops call and route will drop
from table


The hellos from OSPF will keep initiating calls


Redistribute routes and using RIP between serial
connections

Snapshot Routing


Uses the client
-
server design model


one router is designated as the snapshot server and one
or more routers are designated as snapshot clients


At the end of the active period, the router takes a
snapshot of the entries in its routing table. These
entries remain frozen during what is called the
quiet period


client router determines the frequency at which it calls
the server router. The quiet period can be as long as
100,000 minutes (over 69 days)

Snapshot Commands


Router(config
-
if)#snapshot server active
-
time
[dialer]


Router(config
-
if)#snapshot client active
-
time
quiet
-
time [suppress
-
statechange
-
updates]
[dialer]


Router(config
-
if)#dialer map snapshot sequence
-
number dial
-
string


The value of the active
-
time argument must be the same
for the client and server routers


make sure your active time is long enough to allow any
routing updates to be sent

Suppress
-
Statechange


suppress
-
statechange
-
update option disables
the exchange of routing updates each time
the line protocol goes from "down" to
"up"or from "dialer spoofing" to "fully up.


The dialer map snapshot command specifies
which router to call as the snapshot
server.spoofing" to "fully up.

Aggregation


Cisco Proprietary BOD



triggered by outgoing traffic levels only



load value is a number from 1 to 255


1 IS 0%; 255 IS 100%





Multilink PPP (MLP)


Triggers by outgoing or incoming traffic



Both of these methods require the dialer load
-
threshold
command


Router(config
-
if)#dialer load
-
threshold [inbound | outbound |
either ]


only one end of a link should be configured with the dialer
load
-
threshold command.


Use PPP Multilink


Asynchronous serial interfaces in dialer
rotary groups


Synchronous serial BRI


Multiple BRIs in dialer rotary groups


Multiple BRIs using dialer profiles


PRI B channels in dialer rotary groups

Accepting Calls


You can ensure that only a single device answers
an incoming call by verifying the number or
subaddress in the incoming call against the device
configured number, subaddress, or both.


ISDN routers can be configured to screen
incoming calls by using calling line identification
(CLID)


Router(config
-
if)#isdn caller phone
-
number

ISDN Rate Adaptation


Router(config
-
if)#dialer map protocol next
-
hop
-
address [name name] [speed speed]
[broadcast] dial
-
string


Assigned on per destination basis


Lower speed is accepted

Debugging Commands


Show ip int bri0/0


Show ip int brief


Show isdn status


Show isdn history


Show dialer


Show ppp multilink


Debug dialer


Debug ppp multilink





Debug isdn events


Debug ppp authentication | negotiation

D Channel Debugging


debug isdn q921 at Layer 2


debug isdn q931 at Layer 3.


display information about call setup and
teardown of ISDN network connections at
Layer 3 on the D channel.


includes a call setup message, indicated by
"SETUP" in the first line.


In the second line, the Bearer Capability value of
0x8890 indicates that the coding standard used is
ITU
-
T and the circuit mode is 64kbps.


PRI Configuration


.Specify the correct PRI switch type that the
router interfaces with at the provider's Central
Office (CO).


Specify the T1/E1 controller, framing type, and
line coding for the provider's facility.


Set a PRI group timeslot for the T1/E1 facility and
indicate the speed used.


Identify the interface that you will configure to act
with DDR.

T1/E1 Configuration


Router(config)#controller {t1 | e1}{slot/port | unit
number}


Router(config)#controller t1


Router(config
-
controller)#framing {sf | esf}


Router(config
-
controller)#framing{crc4 | no
-
crc4}
[australia]


Router(config)#controller e1


Router(config
-
controller)#framing crc4


Router(config
-
controller)#linecode hdb3