What is Routing

ginglyformweekNetworking and Communications

Oct 29, 2013 (3 years and 7 months ago)

74 views

What is
Routing

Routing is the process of moving data from one
network

to another by forwarding
packets

via
gateways
. With
IP

based
networks
, the routing decision is based on the
destination address in the
IPpacket's

header


Routing Protocol

A routing protocol is a standardized process by which
routers

learn and
communicate connectivity information, called
routes
, each of which which
describes how to reach a destination host and
network
.
Routers

that wish to
exchange routing information must u
se the same routing protocol to
communicate
routing

information.

Routing

is the process of learning all the paths through the
network

(
routes
) and
using routes to forward data from one
network

to another. A
protocol

is a
standardized way to perform a task. So, a
routing protocol
would be a standardized
way of learning routes and moving data from one network to another.

Routing protocols are used by routers to dynamically learn all paths through a set
of networks and

forward data between the networks. Routers are specialized
computer

devices designed to perform routing.

Examples of Routing Protocols



EIGRP



OSPF



RIP, RIP II



IS
-
IS



BGP





Terminology


Autonomous Systems(AS)



Each AS is a group of networks &

routers administered by single

authority using a common routing protocol.


Interior Gateway Protocol(IGP)



Routers within single AS communicate using one of several dynamic

routing protocols, known generically as an IGP.

Open Shortest Path First(OSPF)

is an Interior Gateway Protocol(IGP) IP routing protocol.


Exterior Gateway Protocols(EGP)



Communication between routers belonging to different AS requires

additional protocol, so
-
called EGP.



Introduction to Open Shortest Path First (OSPF)

Open
Shortest Path First (OSPF)

is a
routing protocol
. It is used to allow
route
rs

to dynamically learn
routes

from other
routers

and to advertise
routes

to other
routers
. Advertisements containing
routes

are referred to as Link State
Advertisements (LSAs) in OSPF. OSPF
uses A
reas

to organize a
network

into a
hierarchal structu
re; it summarizes
route

information to reduce the number of
advertised routes and thereby reduce network load and uses a designated router
(elected via a process that is pa
rt of OSPF) to reduce the quantity and frequency of
Link State Advertisements. OSPF does require the
router

have a more powerful
processor

and more memory than other routingprotocols.OSPF selects the best
routes by finding the lowest cost paths to a destination. All router interfaces (links)
are given a cost.

Metrics of OSPF



OSPF Metric

= Cost



Cost is Inversely Proportional to Bandwidth



Cost = k / B.W in bps where k = 100 Mbps

For example for 100 Mpbs

Cost = 1

100 Mbps / 100 Mbps

OSPF Topology
to

configure OSPF, we need
Process ID
,
Area ID
,
Wildcard Mask (Inverse of
Subnet Mask)

Configure OSPF


Assign IP Address to all interfaces

R1(config)# router ospf 1

R1(config
-
router)# network 200.100.50.0 0.0.0.255 area 0

R1(config
-
router)# network 10.0.0.0
0.255.255.255

area 0


R2(config)# router ospf 1

R2(config
-
router)# network 200.100.100.0 0.0.0.255 area 0

R2(config
-
router)# network 10.0.0.0
0.255.255.255
area 0

R2(config
-
router)# network 11.0.0.0
0.255.255.255

area 0


R3(config)# router ospf 1

R3(config
-
router)# network 200.100.150.0
0
.0.0.255 area 0

R3(co
nfig
-
router)# network
11
.0.0.0
0.255.255.255
area 0

OSPF Packet


Version

OSPF version 2 & 3

V2 => IP V4

V3 => IP V6

Type

There are 5 Packet Types

o

Hello

o

DBD (Database Descriptor)

o

LSR (Link state Request)

o

LSU (Link state Update)

o

LSAck

(Link State Acknowledgment)

Packet Length

Variable size of Packets in bytes


Router ID

Identify the source of the packet


Area ID

Area 0 (Backbone Area)

Area 1,2,3… etc (Regular Area)


Checksum

Only Error detection


Authentication Type

It
is use to encrypt data, we use algorithm use encrypt data

NULL (No Authentication)

Clear Text (No Encryption of data)

MD5 (Encrypt data)




Authentication

It is use to secure neighbor ship, Password on Hello packets.


Data (Variable
length)


Router ID



Router ID is an IP Address



Identify the source of the packet



ROUTER ID
is used, for the completion of
Neighbor Table.


Method to select Router ID

There are 3 methods to select Router ID

Election of Router ID with

o

Highest Physical
Interface ID

o

Virtual Interface

o

Hard
-
Coded










Router Types &
Area Types

Internal Routers

An internal router connects only to one OSPF area. All of its interfaces connect to the
area in which it is located and does not connect to any other area.


Backbone Routers

If one or more interface is in Backbone area, then that router is known as Back
bone
Router




Area Border Router (ABR)

A router that connects more than one area is called an area border router or ABR. Usually
an ABR is used to connect non
-
backbone areas to the backbone. If OSPF virtual links are
used an ABR will also be used to connect the area using the virtual link to an
other non
-
backbone area.



Autonomous System Boundary Router (ASBR)

If the router connects the OSPF Autonomous System to another Autonomous System, it
is called an Autonomous System Boundary Router (ASBR).



OSPF elects two or more routers to mana
ge t
he Link State Advertisements

Designated Router (DR)

Every OSPF area will have a designated router and a backup designated router. The
Designated Router (DR) is the router to which all other routers within an area send their
Link State Advertisements. The
Designated Router will keep track of all link state
updates and make sure the LSAs are flooded to the rest of the
network

using Reliable
Multicast transport.


Backup Designated Router (BDR)

The election process which determines the Designated Router will also elect a Backup
Designated Router (BDR). The BDR takes over from the DR when the DR fails.







Election based on


1 Priority

2 Max Router ID




Link
State Advertisement (LSA)


Different LSA in OSPF




LSA 1 (Router LSA) O




LSA 2 (Network LSA) O




LSA 3 & 4 (Summary LSA) OIA




LSA 5 (External LSA) 0E1, 0E2




LSA 7 (Encapsulate LSA 5)

ON2