Chapter 13 - test

flutteringevergreenNetworking and Communications

Oct 29, 2013 (3 years and 10 months ago)

83 views

Chapter
13


Internet Protocol

Version
6
(IPv
6
)



IPv4 offers 2^32 IP address

or
4,294,967,296
IP address



IPv6 offers 2^128 (3.4x10^38) IP address

or
340,282,366,920,938,463,463,374,607,431,768,211,456

therefore it supplies (6.65x10^23) or
665,570,793,348,866,943,898,599

for each
square meter on earth.



IPv6 has built
-
in security



IPv6 uses ICMPv6 or NDP (Neighbors Discovery Protocol) on multicast address
of FF02:0:0:0:0:1:FF/104



IPv6
DOES NOT USE BROADCAST!

IPv6
vs.

IPv4

IPv6 Expression

Ex1:



2001:0db8:3c4d:0012:0000:0000:1234:56ab



http://[2001:0db8:3c4d:0012:0000:0000:1234:56ab]/default.html



Shortened expression of
2001:0db8:3c4d:0012:0000:0000:1234:56ab
is



2001:
db8
:3c4d:12:
0
:
0
:1234:56ab
or



2001:db8:3c4d:12::1234:56ab



Ex2:



2001:0000:0000:0012:0000:0000:1234:56ab



2001::12::1234:56ab



2001::12:0:0:1234:56ab


Address Types


Unicast (may use load balancing)



Global unicast addresses



Link
-
local addresses



Unique local addresses


Multicast


Anycast



Special Addresses


0:0:0:0:0:0:0:0



0.0.0.0


0:0:0:0:0:0:0:1



127.0.0.1


0:0:0:0:0:0:192.168.100.1

IPv4 in mixed IPv4/IPv6 network


2000::/3



Global unicast


FC00::/7



Unique local unicast


FE80::/10



Link local unicast


FF00::/8



Multicast


3FFF:FFFF::/32


Reserved for examples and documentation


2001:0DB8::/32


Reserved for examples and documentation


2002::/16



6to4 transition system

Configuring Cisco Routers with IPv6

Router(config)#ipv
6
unicast
-
routing

Router(config)#int f
0
/
0

Router(config
-
if)#ipv
6
enable

{link local address}


Router(config
-
if)#ipv
6
address
2001
:db
8
:
3
c
4
d:
1
:
0
2
60
.d
6
FF.FE
73.1987
/
64

OR

Router(config
-
if)#ipv
6
address
2001
:db
8
:
3
c
4
d:
1
::/
64
eui
-
64

MAC is

00
60
.
d
6
73
.
19
87
or

0000 00
0
0

0110 0000

.
1101 0110

0111 0011

.
0001 1001

1000 0111

Autoconfiguration

Stateless x Stateful Addressing


Stateless:

Router or stateless DHCP is needed to provide prefix ID of link
-
local
address to the host, otherwise, the default prefix
FE
80
::/
64

is used

Stateful:
Stateful DHCP is required to provide addressing to the hosts.

Configuring DHCP for IPv4

Router(config)#ip dhcp ?

excluded
-
address


Prevent DHCP from assigning certain addresses

Pool



Configure DHCP address pools

Relay



DHCP relay agent parameters


Router(config)#ip dhcp pool
Sales_Network

Router(dhcp
-
config)#?

default
-
router


Default routers

dns
-
server


DNS servers

domain
-
name


Domain name

Exit



Exit from DHCP pool configuration mode

netbios
-
name
-
server

NetBIOS (WINS) name servers

Network



Network number and mask

next
-
server


Next server in boot process


Router(dhcp
-
config)#network 192.168.10.0 255.255.255.0

Router(dhcp
-
config)#default
-
router 192.168.10.1

Router(dhcp
-
config)#exit

Router(config)#ip dhcp excluded
-
address 192.168.10.1

Configuring DHCP for IPv
6
or DHCPv
6

Router(config)#ipv6 dhcp pool ?

WORD


DHCP pool name


Router(config)#ipv6 dhcp pool test

Router(config
-
dhcp)#?

IPv6 DHCP configuration commands:

Default



Set a command to its defaults

dns
-
server


DNS servers

domain
-
name


Domain name to complete unqualified host names

exit



Exit from DHCPv6 configuration mode

no



Negate a command or set its defaults

prefix
-
delegation IPv6

Prefix delegation


Router(config
-
dhcp)#dns
-
server ?

Hostname or X:X:X:X::X

Server’s name or IPv6 address


Router(config
-
dhcp)#domain
-
name yahoo.com

Router(config
-
dhcp)#prefix
-
delegation ?

X:X:X:X::X/<0
-
128>


IPv6 x:x::y/<z>

aaa



Acquire prefix from AAA

pool



IPv6 prefix pool


Router(config
-
dhcp)#prefix
-
delegation pool ?

WORD



IPv6 prefix pool


Router(config
-
dhcp)#prefix
-
delegation pool test ?

lifetime



Configure prefix lifetimes

<cr>


Router(config
-
dhcp)#prefix
-
delegation pool test lifetime 3600 3600


For both valid and preferred lifetime is in the range of <60
-
4294967295> or infinite



Router(config)#int fa 0/0

Router(config
-
if)#ipv6 dhcp server ?

WORD



Name of IPv6 DHCP pool


Router(config
-
if)#ipv6 dhcp server test

IPv
6
Routing Protocols

1
-

RIPng (FF
02
::
9
)

Router(config
-
if)#ipv
6
rip
1
enable

Router(config
-
if)#exit

Router(config)#ipv
6
router rip
1

Router(config
-
rtr)#


2
-

EIGRPv
6
(FF
02
::A)

Router(config)#ipv
6
router eigrp
10

Router(config
-
rtr)#
no shutdown

Router(config
-
rtr)#exit

Router(config)#int f
0
/
0

Router(config
-
if)#ipv
6
eigrp
10


3
-

OSPFv
3
(FF
02
::
5
for OSPF routers and FF
02
::
6
for OSPF
-
designated routers)

Router(config)#ipv
6
router osfp
10

Router(config
-
rtr)#router
-
id
10.1.1.1

Router(config
-
rtr)#exit

Router(config)#int f
0
/
0

Router(config
-
if)#ipv
6
ospf
10
area
0.0.0.0


Viewing IPv
6
Routing Protocols

Router#show ipv
6
route

Router#sh ipv
6
protocols

Router#sh ipv
6
rip

Router#sh ipv
6
ospf neighbor

Router#debug ipv
6
ospf packet

Router#debug ipv
6
ospf hello

Migrating to IPv6

1
-

NAT Protocol Translation (NAT
-
PT)



Static IPv
6
to IPv
4
mapping


Dynamic IPv
6
to IPv
4
mapping


Dynamic
(one to many)

or Network Address Port Translation (NAPT
-
PT)




2
-

Dual Stacking


Router(config)#ipv
6
unicast
-
routing

Router(config)#interface f
0
/
0

Router(config
-
if)#ipv
6
address
2001
:db
8
:
3
c
4
d:
1
::/
64
eui
-
64

Router(config
-
if)#ip address
192.168.30.1 255.255.255.0


3
-

6to4 tunneling


Router(config
-
if)#exit

Router(config)#int tunnel 0

Router(config
-
if)#ipv6 address 2001:db8:1:1::1/64

Router(config
-
if)#tunnel source 192.168.30.1

Router(config
-
if)#tunnel destination 192.168.40.1

Router(config
-
if)#tunnel mode ipv6ip