CCNA 3 v3.1 Module 2

flutteringevergreenNetworking and Communications

Oct 29, 2013 (4 years and 11 days ago)

72 views

1

CCNA
3

v3.
1

Module 2

2

CCNA 3 Module 2

Single Area OSPF

3

3

3

Distance Vector Routing


RIPv1, RIPv2, IGRP, EIGRP


Interior gateway routing protocol


Sends copies of routing tables to neighbors

View network from neighbors perspective


Updates at specified times (30 secs,90 secs)

Slow convergence

High bandwidth usage


4

4

4

Link State Protocols


Examples

OSPF (Open Shortest Path First)

IS
-
IS(Intermediate System to Intermediate System


Also known as Shortest Path First (SPF)

Dijkstra algorithm calculates loop free topology


Interior gateway protocol

Sends routing updates to all routers within the autonomous
systems


All routers have a complete view of the network topology

Routers maintain a complex database of the topology

Link state database is identical on all routers

Routers have full knowledge of distant routers and how they
interconnect

Require more memory and processing

5

5

5


Triggered updates

Contain changes only

Occur when topology change occurs

Updates sent to all routers


Triggered updates result in

Fast convergence

Efficient use of bandwidth


OSPF configuration

OSPF routing process must be enabled

Networks must be identified


6

6

6

Link State Protocol


Send triggered updates

when a network change has occurred

periodic updates known as link
-
state refreshes


Each router keeps track of

the state or condition of its directly connected
neighbors

by multicasting hello packets

all the routers

in its network using link
-
state
advertisements (LSAs)


Builds database about the network using

hello information and LSAs


Calculates shortest route to each network using

shortest path first (SPF) algorithm


Stores this route information in its routing table

7

7

7

Topological Database


Every router advertises directly connected networks

via Link State Advertisements


Every router has it’s own view of the network

it builds a ‘topological database’


Router A is aware of 2 paths to 192.168.157.0

this provides redundancy should one of the routers fail

8

8

8

Advantages of Link State Protocols


Use cost metrics to choose paths

Cost metric reflects the capacity of the links


Fast convergence because

Triggers flooded updates


No routing loops
-

router knows network topology


Routing decision based on up to date of
information

LSAs are sequenced and aged


Minimised Link
-
state database sizes

because of Dijkstra calculations and faster convergence


Supports

Classless interdomain routing (CIDR)

Variable
-
length subnet masking (VLSM)

9

9

9

Disadvantages of LSP


More memory and processing power required

In particular during initial setup


Require strict hierarchical network design

to reduce the size of the topology tables


Administrator must have a good understanding
of link
-
state routing


Flooding of LSAs during the initial discovery
process

decrease network transport capability

Uses the available bandwidth

10

10

10

Compare Distance Vector and Link State

11

11

11

OSPF


Non
-
Proprietary protocol


Preferred to RIP because it is scalable


Open Standard
-

IETF RFC 2328


Link State routing protocol


Interior Gateway Protocol for Autonomous systems


Metric based on bandwidth


Supports VLSM


OSFP can use ‘areas’ for hierarchical design

Multiple areas connect to a distribution area, area 0, also called
the backbone

12

12

12

OSPF Terminology


Link

an interface on the router


Link State

Status of a link

Relationship to neighbouring router


Flooding

sends information out all ports, except the port the
information was received


Link State Database


topological database

List of information about all other routers

Shows the internetwork topology

13

13

13


Area

A collection of networks and routers

Each router in the area has the same link
-
state information

A router within an area is an internal router

Area 0
-

Backbone








Cost

Based on bandwidth

Transmission speed


Routing table

Generated when SPF algorithm is run on link
-
state dbase

Unique to each router
14

14

14


Adjacent database

List of all directly connected routers


Designated Router (DR) / Backup Designated Router
(BDR)

a router elected by all others to represent the network area

All LSA sent to DR/BDR instead of to every single router

Multicast address 224.0.0.6

Reduces overhead of LSA updates

Standard on multi
-
access networks

DR is single point of failure


solution is BDR

15

15

15

OSPF Network Types

Multi
-
access

Number of routers is unknown

Info sent to DR and BDR

Point
-
to
-
Point

2 routers

DR and BDR not elected

NBMA

Info sent to DR and BDR


16

16

16

OSPF Hello Protocol


Hello protocol sends hello packets at

Router starts up

To initiate new adjacency

Regular intervals

ensure neighbor still functioning

Every 10 seconds
on broadcast multi
-
access and point
-
to
-
point networks

Every 30 seconds to NBMA such as frame relay


Hello packets have a L3 multicast address

224.0.0.5
-

This address is all OSPF routers


Hello packet has OSPF packet header

with a type field of 1

17

17

17

18

18

18

19

19

19

20

20

20

21

21

21

22

22

22

23

23

23

24

24

24

25

25

25

26

26

26

Configuring OSPF


Only 1 area

Number is 0


Multiple areas

Number between 0 to 65,535

Must connect to area 0


Router(config)#
router ospf process
-
id (1 to 65,535)


Router(config
-
router)#
network network
-
address
wildcard
-
mask area
-
id


Router(config)#
router ospf 1


Router(config
-
router)#
network 10.2.1.2 0.0.0.0 area 0

27

27

27

Configure OSPF loopback address


OSPF must have an active interface at all times

Not always possible if ethernet / serial interface are down

Create a loopback interface (logical interface) to overcome this


OSPF uses the loopback interface address as the router ID
(this overrides local IP address values)


If there is more than one loopback interface

highest loopback IP address is taken as router ID


Loopback configuration Commands

router(config)#
interface loopback

number

Router(config
-
if)#
ip address

ip
-
address subnet
-
mask

Subnet mask is always 255.255.255.255


To turn off a loopback address

Router(config)#
no

interface loopback
number

28

28

28

Setting OSPF Priority

Priorities can be set from 0 to 255

0 prevents that router from being elected

Highest OSPF priority will win the election
for DR

Configuring OSPF priority

Router(config)#interface fa0/0

Router(config
-
if)#ip ospf priority 50

Router(config0if)#end

29

29

29

OSPF Cost Metric


OSPF uses Cost metric for path selection


Cost is based on bandwidth


Default bandwidth is 1.544Mbps


cost is 64


Cost can be 1 (100Mbps) to 65535


Cost is 10
8

÷

bandwidth


Configuration

Router(config)#
interface serial 0/0

Router(config
-
if)#
bandwidth 64


Router(config
-
if)#
ip ospf cost

number


30

30

30

OSPF Authentication


To guarantee trust OSPF uses authenticatication


Authentication key shared between routers

password can be up to eight characters

Router(config
-
if)#
ip ospf authentication
-
key

password


After password is configured, enable authentication

Router(config
-
router)#
area

area
-
number

authentication

This is sent in plain text


easy to decode


To send encrypted authentication

Router(config
-
if)#
ip ospf message
-
digest
-
key

key
-
id

md5

encryption
-
type key

MD5 keyword is the message
-
digest hashing algorithm to use

Encryption type is the type of encryption

where 0 means none and 7 means proprietary.

key
-
id 1 through 255

key is an alphanumeric password up to sixteen characters

Neighbor routers must use the same key identifier with the same key value

Router(config
-
router)#
area

area
-
id

authentication message
-
digest


31

31

31

OSPF Default Route


Used to reach networks outside the domain

gateway of last resort


Command

Router(config)#
ip route 0.0.0.0 0.0.0.0

[
interface

|








next
-
hop address
]


referred to as the quad
-
zero route

32

32

32

What Causes a failure to establish a
neighbor relationship


Hellos are not sent from both neighbors.


Hello and dead interval timers are not the same.


Interfaces are on different network types.


Authentication passwords or keys are different.


Other possibilities

All interfaces haven’t correct addresses or subnet mask

network area

statements hasn’t correct wildcard masks

network area

statements interfaces not in correct area

33

33

33

Verifying OSPF


Show ip protocol

Displays, times, filters, metrics, networks


Show ip route

Displays routes known and how they were learned


Show ip ospf interfaces

Verifies interfaces configured in an area


Show ip ospf

Displays how many times SPF has been executed


Show ip ospf neighbor details

Displays a list of neighbors, priorities and states


Show ip ospf database

Displays the contents of the topological database