Expanded Router Configuration

elbowshelmetNetworking and Communications

Oct 30, 2013 (3 years and 11 months ago)

98 views

Expanded

Router Configuration




Router>
enable

Router#
config

t

Router(config)#
hostname Lab_A

Lab_A(config)#
enable secret class

Lab_A(config)#
enable password class

Lab_A(config)#
ip

routing

Lab_A(config)
# banner motd #This is the message of the day#


Lab_A(config)#
int e0

Lab_A(config
-
if)
# description connected to hub

Lab_A(config
-
if)#
ip address 192.5.5.1 255.255.255.0

Lab_A(config
-
if)#
no shutdown

Lab_A(config
-
if)#
exit


Lab_A(co
nfig)#
int e1

Lab_A(config
-
if)
# description connected to switch

Lab_A(config
-
if)#
ip address 205.7.5.1 255.255.255.0

Lab_A(config
-
if)#
no shutdown

Lab_A(config
-
if)#
exit


Lab_A(config)#
int S0

Lab_A(config
-
if)
# description connected to Lab_B router

Lab_A(config
-
if)#
ip address 201.100.11.1 255.255.255.0

Lab_A(config
-
if)#
no shutdown

Lab_A(config
-
if)#
clock rate 56000

Lab_A(config
-
if)#
exit


Lab_A(config)#
int

s1

Lab_A(config
-
if)
# description connected to a router somewhere

Lab_A(config
-
if)#
no shutd
own

Lab_A(config
-
if)#
ip address X.X.X.X 255.255.255.0

Lab_A(config
-
if)#
exit


Lab_A(config)#
router rip

Lab_A(config
-
router)#
network 192.5.5.0

Lab_A(config
-
router)#
network 205.7.5.0

Lab_A(config
-
router)#
network 201.100.11.0

Lab_A(config
-
router)#
exit




RIP version 2”

Lab_A(config)#
router rip

Lab_A(config)#version 2

Lab_A(config
-
router)#
network 192.5.5.0

Lab_A(config
-
router)#
network 205.7.5.0

Lab_A(config
-
router)#
network 201.100.11.0

Lab_A(config
-
router)#
exit




OSPF”

Lab_A(config)#
router ospf 1

Lab_A(config
-
router)#
network 192.5.5.0 0.0.0.255 area 0

Lab_A(config
-
router)#
network 205.7.5.0 0.0.0.255 area 0

Lab_A(config
-
router)#
network 201.100.11.0 0.0.0.255 area 0

Lab_A(config
-
router)#
default
-
informati on
-
ori ginat e

Lab_A(config
-
router)#
exit

Lab_
A(config
-
router)#
ip route 0.0.0.0 0.0.0.0 s1







EIGRP”

Lab_A(config)#
router eigrp 101

Lab_A(config
-
router)#
network 192.5.5.0

Lab_A(config
-
router)#
network 205.7.5.0

Lab_A(config
-
router)#
network 201.100.11.0

Lab_A(config
-
router)#
exit



Lab_A(config)#
ip host Lab_A 201.100.11.1 192.5.5.1 205.7.5.1

Lab_A(config)#
ip host Lab_B 201.100.11.2 219.17.100.1 199.6.13.1

Lab_A(config)#
ip host Lab_C 204.204.7.1 223.8.151.1 199.6.13.2

Lab_A(config)#
ip host Lab_D 204.204.7.2 210.93.105.1

Lab
_A(config)#
ip host Lab_E 210.93.105.2


Lab_A(config)#
line con 0

Lab_A(config
-
line)#
password cisco

Lab_A(config
-
line)#
login

Lab_A(config
-
line)#
exit


Lab_A(config)#
line vty 0 4

Lab_A(config
-
line)#
password cisco

Lab_A(config
-
line)#
login

Lab_A(config
-
line)#
exit

Lab_A(config)#
exit


Lab_A#
copy run start


“Trunking to Switches”

Lab_A(config)#
int fa0/0

Lab_A(config
-
if)
# no shut

Lab_A(config
-
if)#
int fa0/0.1

Lab_A(config
-
subif)# encapsulation dot1q 1

Lab_A(config
-
subif)# ip address
192.168.1.1 255.255.255.0

Lab_A(config
-
subif)# end





“Switches


Switch>
enable

Switch r#
config

t

Switch (config)#
hostname Switch_A

Switch_A(config)#
enable secret class

Switch_A (config)#
enable password class

Switch_A (config)
# banner motd #This is
the message of the day#


Switch_A (config)#
line con 0

Switch_A (config
-
line)#
password cisco

Switch_A (config
-
line)#
login

Switch_A (config
-
line)#
exit


Switch_A (config)#
line vty 0 4

Switch_A (config
-
line)#
password cisco

Switch_A (config
-
line)#
login

Switch_A (config
-
line)#
exit

Switch_A (config)#
exit


Switch_A (config)#interface VLAN 1

Switch_A (config
-
if)#ip address 192.168.1.2 255.255.255.0

Switch_A (config
-
if)#exit



Switch_A (config)#ip default
-
gateway 192.168.1.1 255.255.255.0

Switch_A (config
-
i
f)#exit


Switch_A (config)#interface VLAN 1

Switch_A (config
-
if)#no shut

Switch_A (config
-
if)#exit


Switch_A (config)#interface fa0/1

Switch_A (config
-
if)#speed 100

Switch_A (config
-
if)#duplex full


Switch_A (config)#interface fa0/1

Switch_A
(config
-
if)#switchport port
-
security

Switch_A (config
-
if)#switchport
port
-
security mac
-
address


Switch_A (config
-
if)#switchport port
-
security maximum 1


Switch_A #vlan database

Switch_A (vlan)#vlan 2 name VLAN2

Switch_A (vlan)#vlan 3 name VLAN3


Switch_A
#config t

Switch_A (config)#interface fa0/4

Switch_A (config
-
if)#switchport mode access

Switch_A (config
-
if)#switchport access vlan2

Switch_A (config
-
if)#end


Switch_A #config t

Switch_A (config)#interface fa0/10

Switch_A (config
-
if)#switchport mode access

Switch_A (config
-
if)#switchport access vlan3

Switch_A (config
-
if)#end


“TRUNKING”

Switch_A (config)#interface fa0/1

Switch_A
(config
-
if)#switchport mode trunk

Switch_A (config
-
if)#switchport trunk encapsulation dot1q

Switch_A (config
-
if)#end


“DHCP”

Router(config)#ip dhcp pool academy

Router(dhcp
-
config)#network 172.16.20.0 255.255.255.0

Router(dhcp
-
config)#default
-
router 172.16.10.1

Router(dhcp
-
config)#dns
-
server 172.16.10.10

Router(dhcp
-
config)#netbi os
-
name
-
server 172.16.10.10

Router(dhcp
-
config)#do
main
-
name empson.ca

Router(dhcp
-
config)#l ease 14 12 23

Router(dhcp
-
config)#l ease infinite

Router(dhcp
-
config)#exit

Router(config)#ip dhcp excluded
-
address 172.16.10.1 172.16.10.9

Router(config)#no service dhcp

Router(config)#service dhcp


“NAT”

Router(config)#ip route 199.99.9.32 255.255.255.224 200.2.2.18 s0/0

Router(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.17

Router(config)#ip nat pool public_access 199.99.9.40 199.99.9.62 netmask 255.255.255.224

Router(config)#access
-
list 1 permit 10.10.10.0 0
.0.0.255

Router(config)#ip nat inside source list 1 pool public_access

Router(config)#int fa0/0

Router(config
-
if)#ip nat inside

Router(config
-
if)#int s0/0

Router(config
-
if)#ip nat outside


“PAT”

Router(config)#ip route 199.99.9.32 255.255.255.224
200.2.2.18 s0/0

Router(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.17

Router(config)#ip nat pool public_access 199.99.9.40 199.99.9.62 netmask 255.255.255.224

Router(config)#access
-
list 1 permit 10.10.10.0 0.0.0.255

Router(config)#ip nat inside source list 1
int s0/0 overload

Router(config)#int fa0/0

Router(config
-
if)#ip nat inside

Router(config
-
if)#int s0/0

Router(config
-
if)#ip nat outside


“PPP”

Router(config) #int s0/0

Router(config
-
if)#ip add 192.168.15.1 255.255.255.0

Router(config
-
if)#encapsul ation ppp

R
outer(config
-
if)# no shut

Router(config
-
if)#exit

Router(config)#exit

Router(config)#username tokoyo password cisco

Router(config)#int s0/0

Router(config
-
if)#ppp authentication chap

Router(config
-
if)#ppp authentication pap

Router(config
-
if)#ppp authenticati
on chap pap

Router(config
-
if)# pap
-
sent username tokoyo password cisco


“ISDN”

Router(config)#int bri 0

Router(config
-
if)# isdn spid1 51055510000001 5551000

Router(config
-
if)# isdn spid1 51055510001001 5551001

Router(config)#isdn switch
-
type

Router(config)#cont roller t1 1/0

Router(config
-
controller)#framing {sf | esf}

Router(config
-
controller)#li necode {ami | b8zs | hdb3}

Router(config
-
controller)#pri
-
group timeslots 1
-
24

Router(config
-
controller)#i nt s0/0:23


“Legacy DDR”

Router(config)#ip ro
ute 172.16.30.0 0.0.0.255 172.16.20.2

Router(config)#

dialer
-
lsit 1 protocol ip permit

Router(config)#int bri 0

Router(config)#di aler
-
group 1

Router(config)#di aler
-
list 2 protocol ip list 150

Router(config)#access
-
list 150 deny udp any any eq tftp

Router(c
onfig)#
access
-
list 150 deny tcp any any eq telnet

Router(config)#
access
-
list 150 permit ip any any

Router(config)#
int bri 0

Router(config)#
di aler
-
group 2

Router(config)#
username Calgary password acedemy

Router(config)#
int bri 0

Router(config
-
if)#
encapsul ation ppp

Router(config
-
if)#
ppp authentication chap

Router(config
-
if)#
di aler idle
-
timeout 150

Router(config
-
if)#
di aler map ip 172.16.20.2 name Calgary 5552000


“Frame Relay”

Router(Config
-
i f)#encapsul ation frame
-
relay

Router(Config
-
i f)#encapsul ation frame
-
relay ietf

Router(Config
-
i f)#frame
-
rel ay Imi
-
type {ansi I cisco I q933a}

Router(Config
-
i f)#frame
-
rel ay int
-
dlci 110

Router(Config
-
i f)#exit

Router(Config
-
i f)#frame
-
rel ay map ip 192.168.100.1 110 Broadcast

Router(Config
-
i f)#no frame
-
relay inverse arp

Router(Config
-
i f)#desc connection to the new branch

Router(Config
-
i f)#int s0/0 102 point
-
to
-
point

Router(Config
-
i f)#ip add 192.168.10.1

Router(Config
-
i f)#no shut

Router(Config
-
i f)#frame
-
rel ay interface dlci 102