Inter-VLAN Routing dengan EIGRP dan Static Routing Protocol

cloutedcoughNetworking and Communications

Oct 28, 2013 (3 years and 11 months ago)

215 views

Inter-VLAN Routing dengan EIGRP dan Static Routing
Protocol
Ahmad Fikri Saleh
email: almarzak.tul3n@yahoo.com
UNIVERSITAS SRIWIJAYA
Addressing Table Port Assignments – Switch 0
Port
Assignment
Network
Fa0/1
 Native Vlan 100 (trunk)
 192.168.100.0/24
Fa0/2
 Vlan 10 - Alfa
 192.168.1.0/27
Fa0/3
 Vlan 20 - Beta
 192.168.1.32/27
Fa0/4
 Vlan 30 - Gama
 192.168.1.64/27
Fa0/5
 Vlan 40 - Teta
 192.168.1.96/27
            Interface Configuration Table – R1
Interface
Assignment
IP Address
Fa0/0.10
 Vlan 10
 192.168.1.1/27
Fa0/0.20
 Vlan 20
 192.168.1.33/27
Fa0/0.30
 Vlan 30
 192.168.1.65/27
Fa0/0.40
 Vlan 40
 192.168.1.97/27
Fa0/0.100
 Vlan 100
 192.168.100.1/24
            1. Prepare the network  Step 1 : use anything devices that is similiar to the one of the topology. The output shown in
this experiment is based on 2960 switches and 1841 routers. You can use any current switches or routers as long as they
have required interfaces shown in the topology diagram. Step 2 : Configure the FastEthernet, Serial, and NIC interface to all
devices. Enter interface configuration mode for R0’s interfaces and configure the IP address as specified in the
Topology Diagram. Router>enable
Router#configure terminal
Router(config)#hostname R0
R0(config)#interface serial 0/0/0
R0(config-if)#ip add 203.217.134.17 255.255.255.240
R0(config-if)#clock rate 64000
R0(config-if)#bandwith 128
R0(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R0(config-if)#exit
R0(config)#interface Fastethernet 0/0
R0(config-if)#ip add 203.217.134.1 255.255.255.240
R0(config-if)#no shutdown
R0(config-if)#exit
R0#
 
Enter interface configuration mode for R1’s interfaces and configure the IP address as specified in the Topology
Diagram.
R1(config)#interface serial 0/0/0
R1(config-if)#ip add 203.217.134.18 255.255.255.240
R1(config-if)#bandwith 128
R1(config-if)#no shutdown
R1(config-if)#
 
Enter interface configuration mode for R2’s interfaces and configure the IP address as specified in the Topology
Diagram.
Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface Fastethernet 0/0
R2(config-if)#ip add 192.168.1.2 255.255.255.224
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface Fastethernet 0/1
R2(config-if)#ip add 172.16.0.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
 
Enter interface configuration mode for R3’s interfaces and configure the IP address as specified in the Topology
Diagram.
Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface Fastethernet 0/0
R3(config-if)#ip add 192.168.1.34 255.255.255.224
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface Fastethernet 0/1
R3(config-if)#ip add 172.16.1.1 255.255.255.224
R3(config-if)#no shutdown
R3(config-if)#exit
 
Enter interface configuration mode for R4’s interfaces and configure the IP address as specified in the Topology
Diagram.
Router>enable
Router#configure terminal
Router(config)#hostname R4
R4(config)#interface Fastethernet 0/0
R4(config-if)#ip add 192.168.1.66 255.255.255.224
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface Fastethernet 0/1
R4(config-if)#ip add 172.16.2.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
 
Enter interface configuration mode for R5’s interfaces and configure the IP address as specified in the Topology
Diagram.
Router>enable
Router#configure terminal
Router(config)#hostname R5
R5(config)#
R5(config)#interface Fastethernet 0/0
R5(config-if)#ip add 192.168.1.98 255.255.255.224
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#interface Fastethernet 0/1
R5(config-if)#ip add 172.16.3.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit   2. Configure Vlans on Switch S0
Step 1 : Clear any existing configurations on the switch which it’s port will used in Vlan. Or you can initialize all ports in
the shutdown state.
Switch>enable
Switch#configure terminal
Switch(config)#hostname S0
S0(config)#interface range fastEthernet 0/1 - fastethernet 0/5
S0(config-if-range)#shut
S0(config-if-range)#exit
 
If you want intialize all
S0(config)#interface range fastEthernet 0/1 - fastethernet 0/24
S0(config-if-range)#shut
S0(config-if-range)#exit
 
Step 2 : Re-enable ports (fa 0/2 – fa 0/5), use it to mode access and fa 0/1 as mode trunk.
S0(config)#interface range fastEthernet 0/2 - fastethernet 0/5
S0(config-if-range)#switchport mode access
S0(config-if-range)#no shutdown
S0(config-if-range)#exit
S0(config)#interface Fastethernet 0/1
S0(config-if)#switchport mode trunk
S0(config-if)#switchport trunk native vlan 100
S0(config-if)#no shutdown
S0(config-if)#exit
 
Step 3 : Create Vlans on Switch S0
Use the Vlan vlan-id command in global configuration mode to add a vlan to switch S0. there are five vlans configure for this
experiment: VLAN 100 (manajemen); VLAN 10 (Alfa); VLAN 20 (Beta); VLAN 30 (Gama); VLAN 40 (Teta). After you create
vlan, you can assign a name to that vlan.
S0(config)#vlan 100
S0(config-vlan)#name manajemen
S0(config-vlan)#vlan 10
S0(config-vlan)#name Alfa
S0(config-vlan)#vlan 20
S0(config-vlan)#name Beta
S0(config-vlan)#vlan 30
S0(config-vlan)#name Gama
S0(config-vlan)#vlan 40
S0(config-vlan)#name Teta
S0(config-vlan)#exit
 
Step 4 : Assign switch port to VLAN on S0
S0#configure terminal
S0(config)#int vlan 100
%LINK-5-CHANGED: Interface Vlan100, changed state to upS0(config-if)#ip add 192.168.100.2 255.255.255.0
S0(config-if)#no shutdown
S0(config-if)#exit
S0(config)#interface Fastethernet 0/2
S0(config-if)# switchport access vlan 10
S0(config-if)#interface Fastethernet 0/3
S0(config-if)# switchport access vlan 20
S0(config-if)#interface Fastethernet 0/4
S0(config-if)# switchport access vlan 30
S0(config-if)#interface Fastethernet 0/5
S0(config-if)# switchport access vlan 40
S0(config-if)#end
 
Step 5 : Configure the trunking interface on R1
R1>enable
R1#configure terminal
R1(config)#interface Fastethernet 0/0
R1(config-if)#no shutdown
R1(config-if)#interface Fastethernet 0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip add 192.168.1.1 255.255.255.224
R1(config-subif)#interface Fastethernet 0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip add 192.168.1.33 255.255.255.224
R1(config-subif)#interface Fastethernet 0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip add 192.168.1.65 255.255.255.224
R1(config-subif)#interface Fastethernet 0/0.40
R1(config-subif)#encapsulation dot1Q 40
R1(config-subif)#ip add 192.168.1.97 255.255.255.224
R1(config-subif)#interface Fastethernet 0/0.100
R1(config-subif)#encapsulation dot1Q 100 native 
R1(config-subif)#ip add 192.168.100.1 255.255.255.0
R1(config-subif)#exit
R1(config)#
 
3. Configure the routing protocol for each router
Step 1 : Enable the EIGRP routing protocol on the R1
Enhanced Interior Gateway Routing Protocol - (EIGRP) is a Cisco herdsman routing protocol loosely based on their original
IGRP. EIGRP is an advanced distance-vector routing protocol, with optimizations to minimize both the routing instability
incurred after topology changes, as well as the use of bandwidth and processing power in the router.
 
To enable EIGRP, enter global configuration mode and use the router EIGRP command. 
R1>enable
R1#configure terminal
R1(config)#ro eigrp 16
R1(config-router)#network 192.168.100.0 0.0.0.255
R1(config-router)#network 192.168.1.0 0.0.0.31
R1(config-router)#network 192.168.1.32 0.0.0.31
R1(config-router)#network 192.168.1.64 0.0.0.31
R1(config-router)#network 192.168.1.96 0.0.0.31
R1(config-router)#no auto-summary 
R1(config-router)#redistribute static
R1(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
R1#
 
Step 2 : Enable the EIGRP routing protocol on the R2
R2>enable
R2#configure terminal
R2(config)#ro eigrp 16
R2(config-router)#network 192.168.1.0 0.0.0.31
R2(config-router)#network 172.16.0.0 0.0.0.255
R2(config-router)#end
 
Step 3: Enable the EIGRP routing protocol on the R3
R3>enable
R3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#ro ei
R3(config)#ro eigrp 16
R3(config-router)#network 192.168.1.32 0.0.0.31
R3(config-router)#network 172.16.2.0 0.0.0.255
R3(config-router)#no auto-summary 
R3(config-router)#end
 
Step 4: Enable the EIGRP routing protocol on the R4
R4>enable
R4#configure terminal
R4(config)#ro ei
R4(config)#ro eigrp 16
R4(config-router)# network 192.168.1.64 0.0.0.31
R4(config-router)# network 172.16.2.0 0.0.0.255
R4(config-router)#no auto-summary 
R4(config-router)#
 
Step 5 : Enable the EIGRP routing protocol on the R5
R5>enable
R5#configure terminal
R5(config)#ro eigrp 16
R5(config-router)#network 192.168.1.96 0.0.0.31
R5(config-router)#network 172.16.3.0 0.0.0.255
R5(config-router)#no auto-summary 
R5(config-router)#end
 
Step 6 : Configure Static Routing on R1 and R0
R0(config)#ip route 0.0.0.0 0.0.0.0 203.217.134.18
R1(config)#ip route 203.217.134.0 255.255.255.240 203.217.134.17
 
Last Step : Use the ping command to test connectivity between SERVER to all PCs