Operator Console Client Requirements - System Center Operations ...

aquahellishSoftware and s/w Development

Dec 13, 2013 (3 years and 6 months ago)

155 views

Opalis Requirements


Contents

System Requirements

................................
................................
................................
.............................

2

Management Server

................................
................................
................................
...........................

2

Operating Sy
stem

................................
................................
................................
............................

2

Additional Software

................................
................................
................................
........................

2

Operator Console Client Requirements

................................
................................
..............................

2

Component Requirement

................................
................................
................................
...............

2

Operator Console Installation Requirements

................................
................................
.....................

3

Component Download Links

................................
................................
................................
...........

3




System Requirements

Management Server


Operating System


Windows Server 2003 (32
-
bit) with Service Pack 1 or 2

Additional Software

Windows Installer/MSI version 3.1


This is required to install Opalis Integration Server and
all components, Integration Packs, Hotfixes, and product upgrades. On the Opalis
Integration Server installation splash screen, click
Explore
CD
-
ROM
. Open the
3rdparty
\
MSI
folder.


Oracle Client


If you plan to use Oracle Server as the database the runs your Datastore,
you must install the Oracle Client on each Management Server and Action Server
before
you run the Opalis Integration Server ins
tallation.


Microsoft .NET 2.0


IIS 6


.Net 2


Databases


Microsoft SQL Server 2000, 2005, and 2008

(t
his is required if you want to use Microsoft
SQL Server as your

Datastore database
)
.

Note
: Microsoft SQL Server Desktop Edition
and Express Edition are

not supported.


OR


Oracle Server versions 9.2, 10.x, and 11

(t
his is required if you want to use Oracle
Server as your

Datastore database
)
.


Operator Console Client Requirements

Component Requirement

Browser


Microsoft Internet Explorer 7, Microsoft Inter
net Explorer 8 (IE7 compatibility mode), or
Mozilla Firefox 3


JavaScript must be enabled in the browser



Operator Console Installation Requirements

You must download the following components to install the Operator Console.
Note
:
When using Active Directory authentication, the account running JBoss must be a
domain user.


.Net 2.0


.Net 2.0 SP1

http://www.m
icrosoft.com/downloads/details.aspx?displaylang=en&FamilyID=79bc3b77
-
e02c
-
4ad3
-
aacf
-
a7633f706ba5


Powershell 2.0

http://go.microsoft.com/fwlink/?linkID=151321


Component Download Link
s

Java Development Kit 6 Update 4



http://java.sun.com/products/archive/


JBoss Application Server 4.2.3.GA



http://
jboss.org/jbossas/downloads/



Hibernate Validator 3.0.0.GA
-

http://repo1.maven.org/maven2/org/hibernate/hibernate
-
validator/3.0.0.ga/


Hibernate Commons Annotations

3.3.0.GA
-

http://repo1.maven.org/maven2/org/hibernate/hibernate
-
commons/
-
annotations/3.3.0.ga/


Richfaces
-
API

3.3.1.GA

http://repository.jboss.com/maven2/org/richfaces/framework/richfaces
-
api/3.3.1.GA/


Richfaces
-
UI

3.3.1.GA

http://repository.jboss.com/maven2/org/richfaces/ui/richfaces
-
ui/3.3.1.GA/


Richfaces
-
Implementation 3.3.1.GA

http://repository.jboss.com/maven2/org/richfaces/framework/richfaces
-
impl/3.3.1.GA/


JBoss
-
EL 2.0.1.GA

http://repository.jboss.co
m/maven2/org/jboss/el/jboss
-
el/2.0.1.GA/


JSF
-
Facelets 1.1.14

http://repository.jboss.com/maven2/com/sun/facelets/jsf
-
facelets/1.1.14/


Java Native Access

3.0.9

http://repository.jboss.com/maven2/com/sun/jna/jna/3.0.9/


JAX
-
WS RI

https://jax
-
ws.dev.java.net/2.1.2/


JBoss Seam
-
Core

2.0.2_SP1

http://github.com/svetzal/Seam
-
2.0.2
-
Patched


JBoss

Seam
-
Remoting

2.0.2_SP1

http://repository.jboss.co
m/maven2/org/jboss/seam/jboss
-
seam
-
remoting/2.0.2.SP1/


JBoss Seam
-
UI

2.0.2_SP1

http://repository.jboss.com/maven2/org/jboss/seam/jboss
-
seam
-
ui/2.0.2.SP1/


JBoss

Seam
-
Debug

2.0.2_SP1

http://repository.jboss.com/maven2/org/jboss/seam/jboss
-
seam
-
debug/2.0.2.SP1/


JBoss Seam
-
Mail

2.0.2_SP1

http://repository.jboss.com/maven2/org/jboss/seam/jboss
-
seam
-
mail/2.0.2.SP1/



Service Accounts

Opalis Service Account

Domain User

Local Administrator on the
Management
Server