EIGRP Routing Protocol & Configuration

woonsocketpoliticalΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 3 χρόνια και 9 μήνες)

66 εμφανίσεις

EIGRP Routing Protocol & Configuration
GNU Publ i c Li cense ~ ~
ma D© 2
http:www.oscentre.co.nr//
A)
EI GRP Definition
There is several terms on routing protocol, as we know RIP, IGRP/EIGRP, OSPF, BGP is major routing

protocol. On my last article, I wrote about Routing Internet Protocol (RIP) and its configuration on

Cisco machine (with Bosson Netsim). But in this section, as i've wrote on the title that i'll discuss about

EIGRP and its configuration in Cisco machine. Before we step into configuration section, I want to

explain a bit of EIGRP theory and what the relation with IGRP. As far as I know, EIGRP is a product

development of IGRP basically. Abbreviation of IGRP refer to
Interior Gateway Routing Protocol,
it
is

a routing protocol developed in the mid-1980s by Cisco Systems, Inc. Cisco's principal goal in creating

IGRP was to provide a robust protocol for routing within an
autonomous system
(AS) having arbitrarily

complex topology and consisting of media with diverse bandwidth and delay characteristics
.
Whereas EIGRP is short of
Enhanced Interior Gateway Routing Protocol.
With Software Release 9.21,

Cisco introduced an enhanced version of IGRP that combines the advantages of link state protocols

with the advantages of distance vector protocols. Enhanced IGRP incorporates the Diffusing Update

Algorithm (DUAL) developed at SRI International by Dr. J.J. Garcia-Luna-Aceves. Enhanced IGRP

includes the following features:
·
Fast convergence---Enhanced IGRP uses DUAL to achieve convergence quickly. A router

running Enhanced IGRP stores all of its neighbors' routing tables so that it can quickly adapt to

alternate routes. If no appropriate route exists, Enhanced IGRP queries its neighbors to discover

an alternate route. These queries propagate until an alternate route is found.
·
Variable length subnet masks---Enhanced IGRP includes full support for variable length subnet

masks. Subnet routes are automatically summarized on a network number boundary. In addition,

Enhance IGRP can be configured to summarize on any bit boundary at any interface.
·
Partial, bounded updates---Enhanced IGRP does not make periodic updates. Instead, it sends

partial updates only when the metric for a route changes. Propagation of partial updates is

automatically bounded so that only those routers that need the information are updated. As a

result of these two capabilities, Enhanced IGRP consumes significantly less bandwidth than

IGRP.
·
Multiple network-layer support---Enhanced IGRP includes support for AppleTalk, IP, and

Novell NetWare. The AppleTalk implementation redistributes routes learned from the Routing

Table Maintenance Protocol (RTMP). The IP implementation redistributes routes learned from

OSPF, Routing Information Protocol (RIP), IS-IS, Exterior Gateway Protocol (EGP), or Border

Gateway Protocol (BGP). The Novell implementation redistributes routes learned from Novell

RIP or Service Advertisement Protocol (SAP).
Enhanced IGRP features four new technologies:
·
Neighbor discovery/recovery---
Used by routers to dynamically learn about other routers on their

directly attached networks. Routers must also discover when their neighbors become

unreachable or inoperative. This process is achieved with low overhead by periodically sending

small hello packets. As long as a router receives hello packets from a neighboring router, it

assumes that the neighbor is functioning, and they can exchange routing information.
·
Reliable Transport Protocol
(RTP)
---
Responsible for guaranteed, ordered delivery of Enhanced

IGRP packets to all neighbors. It supports intermixed transmission of multicast or unicast

packets. For efficiency, only certain Enhanced IGRP packets are transmitted reliably. For

example, on a multiaccess network that has multicast capabilities, such as Ethernet, it is not

necessary to send hello packets reliably to all neighbors individually. For that reason, Enhanced

IGRP sends a single multicast hello packet containing an indicator that informs the receivers that

the packet need not be acknowledged. Other types of packets, such as updates, indicate in the

packet that acknowledgment is required. RTP has a provision for sending multicast packets

quickly when unacknowledged packets are pending, which helps ensure that convergence time

remains low in the presence of varying speed links.
·
DUAL finite state machine
---Embodies the decision process for all route computations. It tracks

all routes advertised by all neighbors. DUAL uses distance information to select efficient, loop-
free paths and selects routes for insertion in a routing table based on feasible successors. A

feasible successor
is a neighboring router used for packet forwarding that is a least-cost path to a

destination that is guaranteed not to be part of a routing loop. When a neighbor changes a metric

or when a topology change occurs, DUAL tests for feasible successors. If one is found, DUAL

uses it to avoid recomputing the route unnecessarily. When there are no feasible successors but

there are neighbors advertising the destination, a recomputation (also known as a diffusing

computation) must occur to determine a new successor. Although recomputation is not processor

intensive, it does affect convergence time, so it is advantageous to avoid unnecessary

recomputations.
·
Protocol-dependent modules---
Responsible for network-layer protocol-specific requirements.

For example, the
IP-Enhanced IGRP module
is responsible for sending and receiving Enhanced

IGRP packets that are encapsulated in IP. IP-Enhanced IGRP is also responsible for parsing

Enhanced IGRP packets and informing DUAL of the new information that has been received.

IP-Enhanced IGRP asks DUAL to make routing decisions, the results of which are stored in the

IP routing table. IP-Enhanced IGRP is responsible for redistributing routes learned by other IP

routing protocols.
The consistent and superior performance of Enhanced IGRP relies on several new features:
·
Packet types
·
Neighbor tables
·
Topology tables
·
Route states
·
Route tagging
Perhaps you will find out more article which discuss about IGRP / EIGRP on
Google
,
but I also suggest

you to visit
Cisco's site
. Because this article is related with how to configure EIGRP on Cisco machine,

and Cisco has provide more complete manual guide for all configuration of routing protocol include

EIGRP. On my article, I'll show a basic of EIGRP's configuration to you. As usual, the network

configuration based on my experiment with my favourite Cisco simulator called GNS3...(^_^)
B)
Network Topol ogy & Specification
This is a simple network topology and its specification which I use on my experiment. I hope you enjoy

it !
Specificati on :
1.
Router Cisco
7200
as
Andromeda
router with :

1 serial (s1/0) on network 167.205.44.0/24
1 ethernet (e2/0) on network 10.0.1.0/24
2.
Router Cisco 3600 as
Bimasakti
router with :

1 serial (s1/0) on network 167.205.44.0/24

1 ethernet (e2/0) on network 192.168.7.0/26
3.
1 PC client
4.
1 PC server
Ok..i don't want platitude any more, so let's step on the configuration. I assume that you have familiar

with GNS3, so I don't need to explain how to use and configure its facilities.
C)
Configuration

Andromeda

router

!Press Enter to start exec mode, and type
enable
to privilege mode
Router>
enable
Router#
!Configure hostname & interface
Router#
hostname Andromeda
Andromeda#
configure terminal
Andromeda(config)#
interface s1/0
Andromeda(config-if)#
ip address

167.205.44.2 255.255.255.192
Andromeda(config-if)#
no shutdown
Andromeda(config-if)#
interface e2/0
Andromeda(config-if)#
ip address 10.1.0.1 255.255.0.0
Andromeda(config-if)#
no shutdown
Andromeda(config-if)#
end
!Check your configuration
Andromeda#
show running-config
!Configure routing protocol with EIGRP
Andromeda#
configure terminal
Andromeda(config)#
router eigrp 1
Andromeda(config-router)#
network 10.1.0.0 0.0.255.255
Andromeda(config-router)#
network 167.205.44.0 0.0.0.63
Andromeda(config-router)#
no auto-summary
Andromeda(config-router)#
end
Andromeda#
!Don't forget to check your configuration

In my complete configuration is seem like this :
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Andromeda
!
boot-start-marker
boot-end-marker
!
logging console emergencies
!
ip subnet-zero
ip cef
!
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
no clns route-cache
!
interface Serial1/0
ip address 167.205.44.2 255.255.255.192
serial restart-delay 0
no clns route-cache
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no clns route-cache
!
interface Ethernet2/0
ip address 10.1.0.1 255.255.0.0
duplex half
no clns route-cache
!
interface Ethernet2/1
no ip address
shutdown
duplex half
no clns route-cache
!
interface Ethernet2/2
no ip address
shutdown
duplex half
no clns route-cache
!
interface Ethernet2/3
no ip address
shutdown
duplex half
no clns route-cache
!
router eigrp 1
network 10.1.0.0 0.0.255.255
network 167.205.44.0 0.0.0.63
no auto-summary
!
ip classless
!
no ip http server
!
control-plane
!
dial-peer cor custom
!
!
line con 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
no login
!
end

Bimasakti

router

!Press Enter to start exec mode, and type
enable
to privilege mode
Router>
enable
Router#
!Configure hostname & interface
Router#
hostname Bimasakti
Bimasakti#
configure terminal
Bimasakti(config)#
interface s1/0
Bimasakti(config-if)#
ip address

167.205.44.1 255.255.255.192
Bimasakti(config-if)#
no shutdown
Bimasakti(config-if)#
interface e2/0
Bimasakti(config-if)#
ip address 192.168.1.3 255.255.255.0
Bimasakti(config-if)#
no shutdown
Bimasakti(config-if)#
end
!Check your configuration
Bimasakti#
show running-config
!Configure routing protocol with EIGRP
Bimasakti#
configure terminal
Bimasakti(config)#
router eigrp 1
Bimasakti(config-router)#
network 10.1.0.0 0.0.255.255
Bimasakti(config-router)#
network 167.205.44.0 0.0.0.63
Bimasakti(config-router)#
no auto-summary
Bimasakti(config-router)#
end
Bimasakti#
!Don't forget to check your configuration
In my complete configuration is seem like this :
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Bimasakti
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 167.205.44.1 255.255.255.192
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet2/0
ip address 192.168.1.3 255.255.255.0
half-duplex
!
router eigrp 1
network 167.205.44.0 0.0.0.63
network 192.168.1.0
no auto-summary
!
ip http server
ip classless
!
control-plane
!
gatekeeper
shutdown
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
end

PC and Server

To configure your PC & Server, you can do it as generally how to set your computer IP. If you

choose UNIX machine, may be we can use
ifconfig
command. But in this sample, I use a VPC

(
Virtual PC
) as Server and PC. So, to configure the IP address shown at bellow :
#ip [ip_address] [router_address] [prefix-length]
e.x : #ip 10.0.1.5 10.0.1.1 /24
It is easy, isn't it ?! I wrote this article just to spent my time, and to review my knowledge. So,

when I forget in the next time...I'll just to see this article. It's sounds silly but I enjoy with this !

Fiuhh...finally, I finish this job. Next chapter I want to discuss about OSPF & NAT

configuration.
See ya... !!!