课题:路由器的动态路由配置

maidtweetΔίκτυα και Επικοινωνίες

29 Οκτ 2013 (πριν από 3 χρόνια και 9 μήνες)

99 εμφανίσεις

课题:
路由器的动态路由配置

教学目标:
掌握路由器的
EIGRP

OSPF
动态路由配置

教学重点与难点:
EIGRP

OSPF
动态路由配置过程

教学方法:
实践实训

教学过程:

实训一:
EIGRP
协议配置

拓扑图:


实训要求:各
PC
机之间能相互通信。

命令清单:


Router1
命令清单:

副畴敲⍣潮映R

副畴敲⡣潮晩朩⍩湴敲晡捥⁦〯R

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱㜲⸱㘮〮ㄠ㈵㔮㈵㔮㈵㔮i

副畴敲⡣潮晩R
-
楦⤣湯⁳桵瑤潷渠

副畴敲⡣潮晩R
-
楦⤣數楴

副畴敲⡣潮晩朩⍩湴敲晡捥⁳〯㌯R

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱㤲⸱㘸⸰⸱′㔵⸲㔵⸲㔵⸰

副畴敲⡣潮晩R
-
楦⤣湯⁳桵瑤潷渠

副畴敲⡣潮晩R
-
楦⤣捬潣欠牡瑥‶㐰〰

副畴敲⡣潮晩R
-
楦⤣數楴

副畴敲⡣潮晩朩⍲潵瑥爠敩杲瀠㄰R

副畴敲⡣
潮晩o
-
牯畴敲⤣湥瑷潲欠ㄷ㈮ㄶ⸰⸰

副畴敲⡣潮晩R
-
牯畴敲⤣湥瑷潲欠ㄹ㈮ㄶ㠮〮r

副畴敲⡣潮晩R
-
牯畴敲⤣r


副畴敲⍳桯眠楰⁲潵瑥


Rou瑥t
2
命令清单:

副畴敲⍣潮映R

副畴敲⡣潮晩朩⍩湴敲晡捥⁦〯R

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱㜲⸱㜮〮ㄠ㈵㔮㈵㔮㈵㔮i

副畴敲⡣潮晩R
-
楦⤣湯⁳桵瑤潷渠

副畴敲⡣潮晩R
-
楦⤣數楴

副畴敲⡣潮晩朩⍩湴敲晡捥⁳〯㌯R

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱㤲⸱㘸⸰⸲′㔵⸲㔵⸲㔵⸰

Router(conf
ig
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#interface s0/3/1

Router(config
-
if)#clock rate 64000

Router(config
-
if)#ip address 192.168.1.1 255.255.255.0

Router(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#router eigrp 100

Route
r(config
-
router)#network 192.168.0.0

Router(config
-
router)#network 192.168.1.0

Router(config
-
router)#network 172.17.0.0

Router(config
-
router)#end

Router#show ip route


Router
3
命令清单:

副畴敲⍣潮映R

副畴敲⡣潮晩朩⍩湴敲晡捥⁦〯R

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱㜲⸱㠮〮ㄠ㈵㔮㈵㔮㈵㔮i

副畴敲⡣潮晩R
-
楦⤣湯⁳桵瑤潷渠

副畴敲⡣潮晩R
-
楦⤣數楴

副畴敲⡣潮晩朩⍩湴敲晡捥⁳〯㌯R

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱㤲⸱㘸⸱⸲′㔵⸲㔵⸲㔵⸰

副畴敲⡣潮R

-
楦⤣湯⁳桵瑤潷渠

副畴敲⡣潮晩R
-
楦⤣數楴

副畴敲⡣潮晩朩⍩湴敲晡捥⁳〯㌯R

副畴敲⡣潮晩R
-
楦⤣捬潣欠牡瑥‶㐰〰

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱㤲⸱㘸⸲⸱′㔵⸲㔵⸲㔵⸰

副畴敲⡣潮晩R
-
楦⤣湯⁳桵瑤潷渠

副畴敲⡣潮晩R
-
楦⤣數楴

副畴敲⡣潮晩朩⍲潵瑥爠敩杲瀠㄰R

副畴R
爨捯湦楧
-
牯畴敲⤣湥瑷潲欠ㄹ㈮ㄶ㠮ㄮr

副畴敲⡣潮晩R
-
牯畴敲⤣湥瑷潲欠ㄹ㈮ㄶ㠮㈮r

副畴敲⡣潮晩R
-
牯畴敲⤣湥瑷潲欠ㄷ㈮ㄸ⸰⸰

副畴敲⡣潮晩R
-
牯畴敲⤣敮r

副畴敲⍳桯眠楰⁲潵瑥


Rou瑥t
4
命令清单:

副畴敲⍣潮映R

副畴敲⡣潮晩朩⍩湴敲晡捥⁦〯R

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱〮ㄮㄮㄠ㈵㔮㈵㔮㈵㔮i

副畴敲⡣潮晩R
-
楦⤣湯⁳桵瑤潷渠

副畴敲⡣潮晩R
-
楦⤣數楴

副畴敲⡣潮晩朩⍩湴敲晡捥⁳〯㌯R

副畴敲⡣潮晩R
-
楦⤣楰⁡摤牥獳‱㤲⸱㘸⸲⸲′㔵⸲㔵⸲㔵⸰

副畴敲⡣潮晩R
-
楦⤣湯⁳桵瑤潷渠

副畴敲⡣潮晩R
-
楦⤣數楴

副畴敲⡣潮晩朩⍲潵瑥爠敩杲瀠㄰R

副畴敲⡣潮晩R
-
牯畴敲⤣湥瑷潲欠㄰⸰⸰⸰

副畴敲⡣潮晩R
-
牯畴敲⤣湥瑷潲欠ㄹ㈮ㄶ㠮㈮r

副畴敲⡣潮晩R
-
牯畴敲⤣
敮e

副畴敲⍳桯眠楰⁲潵瑥

实训二:
OSPF
单区域配置

拓扑图:


实训要求:各
PC
机之间能相互通信。

命令清单:


R0


Route
r>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#ip address 172.16.0.1 255.255.255.0

Router(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#interface s0/3/0

Router(config
-
if)#ip address 192.168.0.1 255.255.255.0

Router(confi
g
-
if)#no shutdown

Router(config
-
if)#clock rate 64000

Router(config
-
if)#exit

Router(config)#router ospf 10

Router(config
-
router)#network 192.168.0.0 0.0.0.255 area 0

Router(config
-
router)#network 172.16.0.0 0.0.0.255 area 0


R1


Router>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#ip address 172.17.0.1 255.255.255.0

Router(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#interface s0/3/0

Router(config
-
if)#ip address 192.168.0.2 255.255.255.0

Rou
ter(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#interface s0/3/1

Router(config
-
if)#clock rate 64000

Router(config
-
if)#ip address 192.168.1.1 255.255.255.0

Router(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#router ospf 10

Router(config
-
router)#network 192.168.0.0 0.0.0.255 area 0

Router(config
-
router)#network 192.168.1.0 0.0.0.255 area 0

Router(config
-
router)#network 172.17.0.0 0.0.0.255 area 0


R2


Router>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#ip address 172.1
8
.
0
.1 255.255.255.0

Router(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#interface s0/3/0

Router(config
-
if)#ip address 192.168.1.2 255.255.255.0

Ro
uter(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#router ospf 10

Router(config
-
router)#network 192.168.1.0 0.0.0.255 area 0

Router(config
-
router)#network 172.18.0.0 0.0.0.255 area 0

实训三:
OSPF
多区域配置

拓扑图:


实训要求:各
PC
机之间能相互通信。

命令清单:


R0


Router>
en

Router#config
t

Router(config)#interface f0/0

Router(config
-
if)#ip address 172.16.1
.
1

255.255.255.0

Router(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#interface s0/3/0

Router(config
-
if)#clock rate 64000

Router(config
-
if)#no shutdown

R
outer(config
-
if)#ip address 192.168.1.1 255.255.255.0

Router(config
-
if)#exit

Router(config)#router ospf 1

Router(config
-
router)#network 172.16.1.0 0.0.0.255 area 1

Router(config
-
router)#network 192.168.1.0 0.0.0.255 area 0

Router(config
-
router)#exit

Router
(config)#end


R1


Router>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#ip address 172.17.1.1 255.255.255.0

Router(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#interface s0/3/1

Router(config
-
if)#exit

Router(config)#interf
ace s0/3/0

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.1.2 255.255.255.0

Router(config
-
if)#exit

Router(config)#interface s0/3/1

Router(config
-
if)#clock rate 64000

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.2
.1 255.255.255.0

Router(config
-
if)#exit

Router(config)#router ospf 1

Router(config
-
router)#network 192.168.1.0 0.0.0.255 area 0

Router(config
-
router)#network 192.168.2.0 0.0.0.255 area
0

Router(config
-
router)#network 172.17.1.0 0.0.0.255 area 2

Router(config
-
router)#end


R2


Router>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#ip address 172.18.1.1 255.255.255.0

Router(config
-
if)#no shutdown

Router(config
-
if)#exit

Router(config)#interface s0/3/0

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.2.2 255.255.255.0

Router(config
-
if)#exit

Router(config)#router ospf 1

Router(config
-
router)#network 192.168.2.0 0.0.0.255 area
0

Router(config
-
router)#network 172.18.1.0 0.0.0.255 area 3

Router(config
-
router)#end

实训


OS
PF
多区域配置(虚链路)


实训要求:各
PC
机之间能相互通信。

命令清单:


R1


Router>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.2.1 255.255.255.0

Router(config
-
if)#exit

Router(config)#inte
rface f0/1

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.1.1 255.255.255.0

Router(config
-
if)#exit

Router(config)#router ospf 10

Router(config
-
router)#network 192.168.1.0 0.0.0.255 area 0

Router(config
-
router)#network 192.168.2.0 0.0.0
.255 area 0

Router(config
-
router)#end

R2


Router>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.2.2 255.255.255.0

Router(config
-
if)#exit

Router(config)#interface f0/1

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address

192.168.3.1 255.255.255.0

Router(config
-
if)#exit

Router(config)#router ospf 10

Router(config
-
router)#router
-
id 2.2.2.2

Router(config
-
router)#network 192.168.2.0 0.0.0.255 area 0

Router(config
-
router)#network 192.168.3.0 0.0.0.255 area 1

Router(config
-
rout
er)#area 1 virtual
-
link 3.3.3.3

Router(config
-
router)#end

R3


Router>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.3.2 255.255.255.0

Router(config
-
if)#exit

Router(config)#interface f0/1

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address

192.168.4.1 255.255.255.0

Router(config
-
if)#exit

Router(config)#router ospf 10

Router(config
-
router)#network 192.168.3.0 0.0.0.255 area 1

Router(config
-
router)#network 192.168.4.0 0.0.0.255 area 2

Router(config
-
router)#router
-
id 3.3.3.3

Router(config
-
rout
er)#area 1 virtual
-
link 2.2.2.2

Router(config
-
router)#end

Router#wr

R4


Router>en

Router#conf t

Router(config)#interface f0/0

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.4.2 255.255.255.0

Router(config
-
if)#exit

Router(config)#interf
ace f0/1

Router(config
-
if)#no shutdown

Router(config
-
if)#ip address 192.168.5.1 255.255.255.0

Router(config
-
if)#exit

Router(config)#router ospf 10

Router(config
-
router)#network 192.168.4.0 0.0.0.255 area 2

Router(config
-
router)#network 192.168.5.0 0.0.0.2
55 area 2

Router(config
-
router)#end

Router#wr