Download File - ITC Help

hardsweetlipsΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 3 χρόνια και 11 μήνες)

75 εμφανίσεις

IP Routing

Chapter 8 Objectives


Understanding IP routing


Static routing


Dynamic routing


RIP



RIPv2


OSPF


EIGRP


Verifying routing


Router Security


2

To route a router need to know:


Remote Networks


Neighbor Routers


All Possible routes to remote network


The absolute best route to all remote
networks


Maintain and verify the routing information

What is Routing?

C

B

A

D

To route a router need to know:


Remote Networks


Neighbor Routers


All Possible routes to remote network


The absolute best route to all remote
networks


Maintain and verify the routing information

What is Routing?

C

B

A

D

Basic Path Selection

What interface will the router send out a packet
if it has destination address of 10.10.10.10?

Simple IP Routing

>ping 172.16.20.2

Routing/PDU Example:


3. The destination port number in a segment header will have
a value of __

1. The destination address of a frame will be the
_______________________

2. The destination IP address of a packet will be the IP
address of the________________________________

Host A Web browses to the HTTP
Server….

172.16.3.2

SO

Static Routes

172.16.1.0

B

172.16.3.1

A

B

Stub Network

172.16.2.0

SO

A

Routes must be unidirectional

ip route
remote

network


[
mask
]


{
address
|
interface
}


[
distance
]


[permanent]


Router(config)#ip route
remote
_
network mask
next_hop

Static Route Configuration

ip

route 172.16.1.0 255.255.255.0 172.16.3.2

or

ip

route 172.16.1.0 255.255.255.0 s0

Static Route Example

172.16.3.2

SO

172.16.1.0

B

172.16.3.1

A

B

Stub Network

172.16.2.0

SO

Default Routes

172.16.3.2

SO

172.16.1.0

B

172.16.3.1

A

B

Stub Network

172.16.2.0

SO

ip route 0.0.0.0 0.0.0.0 172.16.3.1

ip classless


Routing protocols are used between
routers to:



Determine the path of a packet through a network


Maintain routing tables


Examples?



Routed protocols are:


Assigned to an interface


Once the path is determined by the Routing
protocol, determines method of delivery


Examples?

Routing vs. Routed

Autonomous System 1

Autonomous System 2

IGPs: RIP, IGRP


EGPs: BGP

Routing Protocols


An autonomous system is a collection of
networks under a common administrative
domain.


IGPs operate within an autonomous system.


EGPs connect different autonomous systems.

Classful Routing Overview

Classful routing protocols do not
include the subnet mask with
the route advertisement.


Within the same network, consistency of the
subnet masks is assumed.


Summary routes are exchanged between
foreign networks.


Examples of classful routing protocols:


RIP Version 1 (RIPv1)


IGRP

Classless Routing Overview

Classless routing protocols
include the subnet mask with
the route advertisement.


Classless routing protocols support
variable
-
length subnet masking (VLSM).


Summary routes can be manually
controlled within the network.


Examples of classless routing protocols:


RIP Version 2 (RIPv2)


EIGRP


OSPF


IS
-
IS

IGRP

Administrative

Distance=100

Router D

Router B

Router A

Router C

RIP

Administrative

Distance=120

Default Administrative Distance


Directly Connected: 0


Static Route: 1


RIP: 120


IGRP: 100


EIGRP: 90


OSPF: 110



Administrative Distance

C

B

A

D

Routing

Table

Routing

Table

Routing

Table

Routing

Table

Distance

How far

Vector

In which direction

Distance vector algorithms do not allow a router to know
the exact topology of an internetwork.

All routers just broadcast their entire routing table out all
active interfaces on periodic time intervals

Distance Vector

Discovering Routes

Discovering Routes

Routing Loops

Router Loop

Prevention


Maximum Hop Count


Split Horizon


Route Poisoning


Holddowns

64kbps

T1

T1

T1


Hop count metric selects the path, 16 is unreachable


Full route table broadcast every 30 seconds


Load balance maximum of 6 equal cost paths (default = 4)


RIPv2 supports VLSM and Discontiguous networks

RIP Overview

Router(config)#router rip


Router(config
-
router)#network
network
-
number*

network 172.16.0.0

network 192.168.10.0



router RIP

network 172.16.0.0

network 10.0.0.0


router RIP

*Network is a
classful

network address.

Every device on network uses the same subnet mask

172.16.10.0

192.168.10.0

10.3.5.0

RIP Routing Configuration

RIP Version 2


Allows the use of variable length subnet
masks (VLSM) by sending subnet mask
information with each route update


Distance Vector


same AD, and timers.


Easy configuration, just add the
command “version 2” under the router
rip configuration

router rip

network 10.0.0.0

version 2

Discontiguous Addressing


Two networks of the same classful networks
are separated by a different network address

192.168.10.0/24

10.1.1.0/24

192.168.10.0/24


RIPv1 and IGRP do not advertise subnet masks, and
therefore cannot support
discontiguous

subnets.


OSPF, EIGRP, and RIPv2 can advertise subnet masks,
and therefore can support
discontiguous

subnets.

Passive Interface

Maybe you don’t want to send RIP updates
out your router interface connected to the
Internet. Use the passive
-
interface
command:

Router(config)#router rip

Router(config
-
router)#passive
-
interface serial0


This allows a router to receive route updates on an
interface,

but not send updates via that interface

S0

Gateway

Internet

Updates

X

Verifying RIP

Router#show ip protocols

Router#show ip route

Router#debug ip rip

Router#undebug all (un all)


Summary


Open your books and go through all the
written labs and the review questions.


Review the answers in class.


28