Download File

hardsweetlipsΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 3 χρόνια και 7 μήνες)

61 εμφανίσεις

1

2


Cisco proprietary protocol


Classful routing protocol


Updates are broadcasted via 255.255.255.255


Works with Bellman ford algorithm


Administrative distance is 100


Metric : Composite Metric
(BW+Delay+Load+MTU+Reliability)


Max Hop count are 255 (100 is default)


Load balancing of 6 equal or unequal paths


Used for large organizations

Interior Gateway Routing Protocol

3


Update timer


time between consecutive updates (90 secs)


Invalid timer


time a router waits to hear updates (270 secs) the
route is marked unreachable if there is no update
during this interval


Flush timer


time before the invalid route is purged from the
routing table (630 secs)


Holddown timer


specifies the amount of time for which information
about poorer routes are ignored. (280 secs)

IGRP Timers

4



A unique number identifying the Routing domain of
the routers.


Ranges from 1
-

65535


Public


1


64512


Private


64513
-

65535

Autonomous System Number

5

IGRP
-

Network Diagram

E0

192.168.1.150/24

HYD

LAN
-

192.168.1.0/24

E0

192.168.2.150/24

CHE

LAN
-

192.168.2.0/24

E0

192.168.3.150/24

BAN

LAN
-

192.168.3.0/24

10.0.0.1/8

S0

S1

10.0.0.2/8

11.0.0.1/8

S0

S1

11.0.0.2/8

6



Only works on Cisco Routers


Slow convergence


Formation of Routing loops

Disadvantages of IGRP

7

8

exit

Hyderabad(config
-
if)#

Hyderabad(config)#

telnet 192.168.1.150

================================

Welcome to Hyderabad Router

================================

User Access Verification

password :

****

****

enable

configure terminal

interface serial 0

ip address 10.0.0.1 255.0.0.0

no shut

clockrate 64000

encapsulation hdlc

Hyderabad>

password :

Hyderabad#

Enter configuration commands, one per line. End with CNTL/Z.

Hyderabad(config)#

Hyderabad(config
-
if)#

Hyderabad(config
-
if)#

Hyderabad(config
-
if)#

Hyderabad(config
-
if)#

Microsoft Windows 2000 [Version 5.00.2195]

(C) Copyright 1985
-
2000 Microsoft Corp.

C:
\
>

Connecting

.....

Directly Connected Networks on
HYDERABAD Router

192.168.1.0

10.0.0.0

9

Hyderabad(config)#

router igrp 5

Hyderabad(config
-
router)#

Hyderabad(config
-
router)#

network 192.168.1.0

Hyderabad(config
-
router)#

network 10.0.0.0

no ip routing

Hyderabad(config)#

Hyderabad(config)#

ip routing

Configuring IGRP

Router(config)#

router

igrp

<as

no>

Router(config
-
router)#

network

<Network

ID>

10

show ip route

Hyderabad#

Codes: C
-

connected, S
-

static, I
-

IGRP, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2, E
-

EGP


i
-

IS
-
IS, L1
-
IS
-
IS level
-
1, L2
-
IS
-
IS level
-
2,*
-

candidate default


U
-

per
-
user static route, o
-

ODR


Gateway of last resort is not set


C 10.0.0.0/8 is directly connected, Serial0

I 11.0.0.0/8 [100/10476] via 10.0.0.2, 00:00:18, Serial0

C 192.168.1.0/24 is directly connected, Ethernet0

I 192.168.2.0/24 [100/8576] via 10.0.0.2, 00:00:18, Serial0

I 192.168.3.0/24 [100/10576] via 10.0.0.2, 00:00:18, Serial0

Hyderabad#


^
Z

Hyderabad(config)#

router igrp 5

Hyderabad(config
-
router)#

Hyderabad(config
-
router)#

network 192.168.1.0

Hyderabad(config
-
router)#

network 10.0.0.0

no ip routing

Hyderabad(config)#

Hyderabad(config)#

ip routing

I


for IGRP routes

100 is nothing but
Administrative Distance

Metric of IGRP

Composite Metric

11

show ip protocols

Hyderabad#

Routing Protocol is "igrp 5"


Sending updates every 90 seconds, next due in 49 seconds


Invalid after 270 seconds, hold down 280, flushed after 630


Outgoing update filter list for all interfaces is not set


Incoming update filter list for all interfaces is not set


Default networks flagged in outgoing updates


Default networks accepted from incoming updates


IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0


IGRP maximum hopcount 100


IGRP maximum metric variance 1


Redistributing: igrp 5


Routing for Networks:


192.168.1.0


10.0.0.0


Routing Information Sources:


Gateway Distance Last Update


10.0.0.2 100 00:01:10


Distance: (default is 100)

Hyderabad#


12

Chennai(config
-
if)#

Chennai(config
-
if)#

================================

Welcome to Chennai Router

================================

User Access Verification

password :

****

****

enable

configure terminal

ip address 10.0.0.2 255.0.0.0

no shut

encapsulation hdlc

interface serial 0

Chennai>

password :

Chennai#

Enter configuration commands, one per line. End with CNTL/Z.

Chennai(config)#

Chennai(config
-
if)#

Chennai(config
-
if)#

Chennai(config
-
if)#

Chennai(config
-
if)#

Microsoft Windows 2000 [Version 5.00.2195]

(C) Copyright 1985
-
2000 Microsoft Corp.

C:
\
>

Connecting

.....

Chennai(config
-
if)#

telnet 192.168.2.150

interface serial 1

ip address 11.0.0.1 255.0.0.0

no shut

encapsulation hdlc

Directly Connected Networks on
CHENNAI Router

192.168.2.0

10.0.0.0

11.0.0.0

13

Chennai(config)#

router igrp 5

Chennai(config
-
router)#

Chennai(config
-
router)#

network 192.168.2.0

Chennai(config
-
router)#

network 10.0.0.0

no ip routing

Chennai(config)#

Chennai(config)#

ip routing

network 11.0.0.0

Chennai(config
-
router)#

Configuring IGRP

Router(config)#

router

igrp

<as

no>

Router(config
-
router)#

network

<Network

ID>

14

show ip route

Chennai#

Codes: C
-

connected, S
-

static, I
-

IGRP, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2, E
-

EGP


i
-

IS
-
IS, L1
-
IS
-
IS level
-
1, L2
-
IS
-
IS level
-
2,*
-

candidate default


U
-

per
-
user static route, o
-

ODR


Gateway of last resort is not set


C 10.0.0.0/8 is directly connected, Serial1

C 11.0.0.0/8 is directly connected, Serial0

I 192.168.1.0/24 [100/8576] via 10.0.0.1, 00:00:28, Serial1

C 192.168.2.0/24 is directly connected, Ethernet0

I 192.168.3.0/24 [100/8576] via 11.0.0.2, 00:00:54, Serial0

Chennai#


^
Z

Chennai(config)#

router igrp 5

Chennai(config
-
router)#

Chennai(config
-
router)#

network 192.168.2.0

Chennai(config
-
router)#

network 10.0.0.0

no ip routing

Chennai(config)#

Chennai(config)#

ip routing

network 11.0.0.0

Chennai(config
-
router)#

I


for IGRP routes

100 is nothing but
Administrative Distance

Metric of IGRP

Composite Metric

15

show ip protocols

Chennai#

Routing Protocol is "igrp 5"


Sending updates every 90 seconds, next due in 56 seconds


Invalid after 270 seconds, hold down 280, flushed after 630


Outgoing update filter list for all interfaces is not set


Incoming update filter list for all interfaces is not set


Default networks flagged in outgoing updates


Default networks accepted from incoming updates


IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0


IGRP maximum hopcount 100


IGRP maximum metric variance 1


Redistributing: igrp 5


Routing for Networks:


10.0.0.0


11.0.0.0


192.168.2.0


Routing Information Sources:


Gateway Distance Last Update


11.0.0.2 100 00:00:22


10.0.0.1 100 00:00:59


Distance: (default is 100)

Chennai#


16

exit

Banglore(config
-
if)#

Banglore(config)#

================================

Welcome to Banglore Router

================================

User Access Verification

password :

****

****

enable

configure terminal

ip address 11.0.0.2 255.0.0.0

no shut

clockrate 64000

encapsulation hdlc

Banglore>

password :

Banglore#

Enter configuration commands, one per line. End with CNTL/Z.

Banglore(config)#

Banglore(config
-
if)#

Banglore(config
-
if)#

Banglore(config
-
if)#

Banglore(config
-
if)#

Microsoft Windows 2000 [Version 5.00.2195]

(C) Copyright 1985
-
2000 Microsoft Corp.

C:
\
>

Connecting

.....

telnet 192.168.3.150

interface serial 1

Directly Connected Networks on
Banglore Router

192.168.3.0

11.0.0.0

17

Banglore(config)#

router igrp 5

Banglore(config
-
router)#

Banglore(config
-
router)#

network 192.168.3.0

Banglore(config
-
router)#

network 11.0.0.0

no ip routing

Banglore(config)#

Banglore(config)#

ip routing

Configuring IGRP

Router(config)#

router

igrp

<as

no>

Router(config
-
router)#

network

<Network

ID>

18

show ip route

Banglore#

Codes: C
-

connected, S
-

static, I
-

IGRP, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2, E
-

EGP


i
-

IS
-
IS, L1
-
IS
-
IS level
-
1, L2
-
IS
-
IS level
-
2,*
-

candidate default


U
-

per
-
user static route, o
-

ODR


Gateway of last resort is not set


I 10.0.0.0/8 [100/10476] via 11.0.0.1, 00:00:01, Serial1

C 11.0.0.0/8 is directly connected, Serial1

I 192.168.1.0/24 [100/10576] via 11.0.0.1, 00:00:01, Serial1

I 192.168.2.0/24 [100/8576] via 11.0.0.1, 00:00:01, Serial1

C 192.168.3.0/24 is directly connected, Ethernet0

Banglore#


^
Z

Banglore(config)#

router igrp 5

Banglore(config
-
router)#

Banglore(config
-
router)#

network 192.168.3.0

Banglore(config
-
router)#

network 11.0.0.0

no ip routing

Banglore(config)#

Banglore(config)#

ip routing

I


for IGRP routes

100 is nothing but
Administrative Distance

Metric of IGRP

Composite Metric

19

show ip protocols

Banglore#


Sending updates every 90 seconds, next due in 11 seconds


Invalid after 270 seconds, hold down 280, flushed after 630


Outgoing update filter list for all interfaces is not set


Incoming update filter list for all interfaces is not set


Default networks flagged in outgoing updates


Default networks accepted from incoming updates


IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0


IGRP maximum hopcount 100


IGRP maximum metric variance 1


Redistributing: igrp 5


Routing for Networks:


192.168.3.0


11.0.0.0


Routing Information Sources:


Gateway Distance Last Update


11.0.0.1 100 00:01:02


Distance: (default is 100)

Banglore#


20

ping 192.168.3.1

Hyderabad#

Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 40/43/44 ms

Hyderabad#

!!!!!

ping 192.168.2.1

Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 40/43/44 ms

Hyderabad#

!!!!!

21

ping 192.168.1.1

Chennai#

Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 40/43/44 ms

Chennai#

!!!!!

ping 192.168.3.1

Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 40/43/44 ms

Chennai#

!!!!!

22

ping 192.168.1.1

Banglore#

Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 40/43/44 ms

Banglore#

!!!!!

ping 192.168.2.1

Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 40/43/44 ms

Banglore#

!!!!!