CCNA: Cisco Certified Network Associate Study Guide

hardsweetlipsΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 3 χρόνια και 9 μήνες)

67 εμφανίσεις

© Wiley Inc. 2006. All Rights Reserved.

CCNA: Cisco Certified
Network Associate Study
Guide

CHAPTER 6:

Enhanced IGRP (EIGRP) and
Open Shortest Path First
(OSPF)

© Wiley Inc. 2006. All Rights Reserved.

The CCNA exam topics covered in this
chapter include the following:

Planning & Designing



Select an appropriate routing protocol based on
user requirements



Design a simple internetwork using Cisco
technology

Implementation & Operation



Configure routing protocols
given user requirements

© Wiley Inc. 2006. All Rights Reserved.

What Is Enhanced IGRP
(EIGRP)?


Enhanced IGRP supports:


Rapid convergence


Reduced bandwidth usage


Multiple network
-
layer support


Uses Diffused Update Algorithm (DUAL) to select loop
-
free routes
and enable fast convergence


Up to six unequal paths to a remote network (4 by default)

Enhanced

IGRP

IPX

Routing

Protocols

AppleTalk

Routing Protocol

IP

Routing

Protocols

IPX

Routing

Protocols

AppleTalk

Routing Protocol

IP

Routing

Protocols

© Wiley Inc. 2006. All Rights Reserved.

Comparing EIGRP and IGRP


Similar metric


Same load balancing


Improved convergence time


Reduced network overhead


Maximum hop count of 255 (100
default)


EIGRP can differentiate between
internal and external routes

© Wiley Inc. 2006. All Rights Reserved.

EIGRP for IP


No updates. Route updates sent only when a
change occurs


multicast on 224.0.0.10


Hello messages sent to neighbors every 5
seconds (60 seconds in most WANs)


Enhanced IGRP

EIGRP

EIGRP

hello

© Wiley Inc. 2006. All Rights Reserved.

EIGRP Terminology

Neighbor Table

IP

Next Hop

Interface


Router

Topology Table

IP

Destination 1 Successor

Destination 1 Feasible Successor


Routing Table

IP

Destination 1 Successor


Note: A feasible successor is a backup route and stored in the Topology
table

© Wiley Inc. 2006. All Rights Reserved.

EIGRP Tables


The neighbor table and topology table are
held in ram and are maintained through
the use of hello and update packets.

Enhanced IGRP

EIGRP

EIGRP

hello

To see all feasible successor routes known to a router, use
the
show ip eigrp topology

command

© Wiley Inc. 2006. All Rights Reserved.

Successor routes


Successor route is used by EIGRP to forward
traffic to a destination


A successor routes may be backed up by a
feasible successor route


Successor routes are stored in both the topology
table and the routing table

Routing Table

IP

Destination 1 Successor


Topology Table

IP

Destination 1 Successor

Destination 1 Feasible Successor


© Wiley Inc. 2006. All Rights Reserved.

Choosing Routes


EIGRP uses a composite metric to pick the best
path: bandwidth and delay of the line


EIGRP (and IGRP) can load balance across six
unequal cost paths to a remote network (4 by
default)

IPX

19.2

T1

T1

T1

IPX

AppleTalk

IP

AppleTalk

IP

A

B

D

C

© Wiley Inc. 2006. All Rights Reserved.

Configuring EIGRP for IP

172.16.10.0

10.110.1.0

192.168.0.0

AS=10

Router(config)#
router eigrp 10

Router(config
-
router)#
network 10.0.0.0

Router(config
-
router)#
network 172.16.0.0

192.168.0.0

A

C

B

Enable EIGRP


Assign networks

If you use the same AS number for EIGRP as IGRP, EIGRP will
automatically redistribute IGRP into EIGRP

© Wiley Inc. 2006. All Rights Reserved.

Redistribution

Redistribution is translating one type of
routing protocol into another.

Router D

Router B

Router A

Router C

EIGRP

IGRP

IGRP and EIGRP translate automatically, as long as they are both using
the same AS number

© Wiley Inc. 2006. All Rights Reserved.

Route Path

Assuming all default parameters, which
route will RIP (v1 and v2) take, and which
route will EIGRP take?

T1

T1

100BaseT

100BaseT

10BaseT

56K

© Wiley Inc. 2006. All Rights Reserved.

Verifying Enhanced IGRP
Operation

show ip protocols

Router#


show ip route eigrp


Router#

show ip eigrp traffic



Router#


show ip eigrp neighbors


Router#


show ip eigrp topology


Router#


Displays the neighbors discovered by
IP Enhanced IGRP



Displays the IP Enhanced IGRP
topology table



Displays current Enhanced IGRP
entries in the routing table



Displays the parameters and current
state of the active routing protocol
process



Displays the number of IP Enhanced
IGRP packets sent and received

© Wiley Inc. 2006. All Rights Reserved.

Show IP Route


-
D is for “Dual”


-
[90/2172] is the administrative distance and cost of the route.
The cost of the route is a composite metric comprised from the
bandwidth and delay of the line

P1R1#
sh ip route

[output cut]

Gateway of last resort is not set

D 192.168.30.0/24 [90/2172] via 192.168.20.2,00:04:36, Serial0/0

C 192.168.10.0/24 is directly connected, FastEthernet0/0

D 192.168.40.0/24 [90/2681] via 192.168.20.2,00:04:36, Serial0/0

C 192.168.20.0/24 is directly connected, Serial0/0

D 192.168.50.0/24 [90/2707] via 192.168.20.2,00:04:35, Serial0/0

P1R1#

© Wiley Inc. 2006. All Rights Reserved.


Open standard


Shortest path first (SPF) algorithm


Link
-
state routing protocol (vs. distance vector)


Can be used to route between AS’s

Introducing OSPF

© Wiley Inc. 2006. All Rights Reserved.

OSPF Hierarchical Routing


Consists of areas and autonomous systems


Minimizes routing update traffic


Supports VLSM


Unlimited hop count

© Wiley Inc. 2006. All Rights Reserved.

Link State Vs. Distance Vector





Link State:


Provides common view of entire topology


Calculates shortest path


Utilizes event
-
triggered updates


Can be used to route between AS’s

Distance Vector:


Exchanges routing tables with neighbors


Utilizes frequent periodic updates

© Wiley Inc. 2006. All Rights Reserved.

Types of OSPF Routers

Internal

Routers

Area 1

Area 2

ASBR and

Backbone

Router

Backbone/

Internal

Routers

ABR and

Backbone

Router

Backbone Area 0

ABR and

Backbone

Router

Internal

Routers


External


AS

© Wiley Inc. 2006. All Rights Reserved.

Router(config
-
router)#
network
address mask
area

area
-
id

Assigns networks to a specific OSPF area

Router(config)#
router ospf process
-
id

Defines OSPF as the IP routing protocol

Note: The process ID is locally significant and is needed

to identify a unique instance of an OSPF database

Configuring Single Area OSPF

© Wiley Inc. 2006. All Rights Reserved.

OSPF Example

hostname R3


router ospf 10

network 10.1.2.3 0.0.0.0 area 0

network 10.1.3.1 0.0.0.0 area 0

hostname R2


router ospf 20

network 10.0.0.0 0.255.255.255 area 0




hostname R1


router ospf 30

network 10.1.0.0 0.0.255.255 area 0

network 10.5.5.1 0.0.0.0 area 0


R3

R2

R1

10.1.2.0

10.1.1.0

10.5.5.0

Area 0

10.1.3.0

© Wiley Inc. 2006. All Rights Reserved.

Router#
show ip ospf interface

Verifying the OSPF
Configuration


Displays area
-
ID and adjacency information

Router#
show ip protocols


Verifies that OSPF is configured

Router#
show ip route


Displays all the routes learned by the router

Router#
show ip ospf neighbor


Displays OSPF
-
neighbor information on a per
-
interface basis

© Wiley Inc. 2006. All Rights Reserved.

OSFP Neighbors


OSPF uses hello packets to create adjacencies
and maintain connectivity with neighbor
routers


OSPF uses the multicast address 224.0.0.5


Hello?

224.0.0.5


Hello packets provides dynamic neighbor discovery


Hello Packets maintains neighbor relationships


Hello packets and LSA’s from other routers help build and
maintain the topological database

© Wiley Inc. 2006. All Rights Reserved.

OSPF Terminology



Neighbor



Adjacency


Neighbors

Cost=6

ABR

BDR

DR

Non
-
DR

Adjacencies

© Wiley Inc. 2006. All Rights Reserved.

Router ID (RID)

Each router in OSPF needs to be uniquely identified to
properly arrange them in the Neighbor tables.

© Wiley Inc. 2006. All Rights Reserved.

Electing the DR and BDR


OSPF sends Hellos which elect DRs and BDRs



Router form adjacencies with DRs and BDRs in a multi
-
access environment

Multicast Hellos are sent and compared

Router with Highest Priority is Elected as DR

Router with 2
nd

Highest Priority is Elected as BDR

© Wiley Inc. 2006. All Rights Reserved.

Configuring Loopback
Interfaces

Router ID (RID):


Number by which the router is known to OSPF


Default: The highest IP address on an active interface at the moment of
OSPF process startup


Can be overridden by a loopback interface: Highest IP address of any
active loopback interface


also called a logical interface

© Wiley Inc. 2006. All Rights Reserved.

Interface Priorities

What is the default OSPF interface priority?

Router#

show ip ospf interface ethernet0/0

Ethernet0 is up, line protocol is up

Internet Address 192.168.1.137/29, Area 4

Process ID 19, Router ID 192.168.1.137, Network Type BROADCAST,

Cost: 10 Transmit Delay is 1 sec, State DR,
Priority 1

Designated Router (ID) 192.168.1.137, Interface address 192.168.1.137

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:06

Index 2/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)


© Wiley Inc. 2006. All Rights Reserved.

Ensuring your DR


What options can you configure that will ensure that R2
will be the DR of the LAN segment?

© Wiley Inc. 2006. All Rights Reserved.

Configuring Wildcards

If you want to advertise a partial octet
(subnet), you need to use wildcards.


0.0.0.0 means all octets match exactly


0.0.0.255 means that the first three match
exactly, but the last octet can be any value

After that, you must remember your
block sizes….

© Wiley Inc. 2006. All Rights Reserved.

Wildcard

The wildcard address is always one less than
the block size….


192.168.10.8/30 = 0.0.0.3


192.168.10.48/28 = 0.0.0.15


192.168.10.96/27 = 0.0.0.31


192.168.10.128/26 = 0.0.0.63

© Wiley Inc. 2006. All Rights Reserved.

Wildcard Configuration of the
Lab_B Router


Lab_A


E0: 192.168.30.1/24


S0: 172.16.10.5/30


Lab_B


E0: 192.168.40.1/24


S0: 192.168.10.10/30


S1: 192.168.10.6/30


Lab_C


E0: 192.168.50.1/24


S1: 172.16.10.9/30