Introduction to Cisco Routers and Switches

gascitytankΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 3 χρόνια και 8 μήνες)

60 εμφανίσεις

Introduction to Cisco Routers
and Switches

Willis Kim


8 October 2005

Terminology

Routers make decision on the flow of
network traffic

Switch


joins multiple devices from
the same network


Terminology (con’t)


An IP address is the logical address of a
network adapter. The IP address uniquely
identifies computers on a network.


An IP address can be private, for use on a
LAN, or public, for use on the Internet or
other WAN. IP addresses can be determined
statically (assigned to a computer by a
system administrator) or dynamically
(assigned by another device on the network
on demand).

IP Addressing

Class A = 1
-
126 * .
H

.
H

.
H

Class B = 128
-
191 . N .
H

.
H

Class C = 192
-
223 . N . N .
H

* IP addresses beginning with 0 and 127 are reserved.


IP Addresses in the range of 10.H.H.H, 172.16
-
31.H.H, and
192.168.x.H are reserved for private use and are not assigned.

Subnet

Building networks


Topology, interface and configuration
diagrams are essential before starting


Know where you are going so you know
when you get there!

Network diagram

Subnet 1.x



Subnet 100.x

Subnet

200.x

Subnet 15.x

Configuring the router
(Command
-
line)


Use HyperTerminal Private Edition


Settings 9600, 8
-
N
-
1, hardware


Initial configuration using serial terminal
and 180
°

cisco cable into console port


Unprivileged and privileged modes


Router> to Router# (all configurations)


Configuring the router (con’t)


Router#show interfaces

Ethernet0/0 is up, line protocol is up


Hardware is AmdP2, address is 0050.3ee4.1100 (bia 0050.3ee4.1100)


Internet address is 192.168.100.2/24


MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,


reliability 255/255, txload 1/255, rxload 1/255


Encapsulation ARPA, loopback not set


….


5 minute input rate 0 bits/sec, 0 packets/sec


5 minute output rate 0 bits/sec, 0 packets/sec


27399 packets input, 6250892 bytes, 0 no buffer


Received 2650 broadcasts, 0 runts, 0 giants, 0 throttles


0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored


0 input packets with dribble condition detected


30322 packets output, 5415946 bytes, 0 underruns


102 output errors, 25 collisions, 3 interface resets


0 babbles, 0 late collision, 195 deferred


102 lost carrier, 0 no carrier


0 output buffer failures, 0 output buffers swapped out

Configuring the router (con’t)


Router#show ip route

Codes: C
-

connected, S
-

static, I
-

IGRP, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2, E
-

EGP


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is 192.168.100.1 to network 0.0.0.0


C 192.168.200.0/24 is directly connected, Ethernet0/1

C 192.168.100.0/24 is directly connected, Ethernet0/0

S* 0.0.0.0/0 [1/0] via 192.168.100.1



Configuring the router (con’t)


Global configuration


For example
-

Hostname, name
-
server, privilege
password


Configuring interfaces

interface Ethernet0/0


ip address 192.168.100.2 255.255.255.0


half
-
duplex

!

interface Ethernet0/1


ip address 192.168.200.1 255.255.255.0


half
-
duplex

Configuring the router (con’t)


Configuring DHCP

ip dhcp excluded
-
address 192.168.200.1
192.168.200.100

!

ip dhcp pool demonstration


network 192.168.200.0 255.255.255.0


dns
-
server 168.126.63.1 168.126.63.2


default
-
router 192.168.200.1

Configuring the router (con’t)


Routing


Static vs. Dynamic


Stub network
-

static

ip route 0.0.0.0 0.0.0.0 192.168.100.1

ip route 192.168.200.0 255.255.255.0
192.168.200.2

Configuring the router (con’t)


Saving your configuration

ExampleName#show running
-
config


You do want to save your successful running configuration.
Issue the command copy running
-
config startup
-
config.

ExampleName#copy running
-
config startup
-
config


Your configuration is now saved to non
-
volatile RAM
(NVRAM). Issue the command show startup
-
config.

ExampleName#show startup
-
config


Now any time you need to return your router to that
configuration, issue the command copy startup
-
config
running
-
config.

ExampleName#copy startup
-
config running
-
config


Configuring the switch


VLAN1 is associate with all ports


Assign an IP address

interface VLAN1


ip address 192.168.200.2 255.255.255.0


Configuring the Linksys router


Internet IP
-

192.168.1.2


Gateway


192.168.1.1



Local IP
-

192.168.100.1


Gateway


192.168.1.2


What is missing?


Testing connectivity


ping from nearest to farthest


traceroute

What is missing?


Static routes back from the Linksys
router (200.x and 15.x)


Static routes back from the Seoulcc
router (200.x, 100.x and 15.x)

Questions


7dBi Annenta


Ximeta
-

Network Storage


Netdisk 250GB using NDAS


For Local Area Network (Ethernet)