Case Study EIGRP

gascitytankΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 3 χρόνια και 7 μήνες)

91 εμφανίσεις

Case Study EIGRP

Topology Diagram


Instructions

Plan, design, and implement the complex international Travel Agency (ITA) EIGRP network based on the
above diagram and following specifications.

Implement the design in the lab set of routers; verify that
all configurations are operational and
functioning according to the guidelines.


Scenario

The ITA needs its core network set up with EIGRP with the following

specifications. It has also recently
acquired Local Travel Agency, which was

running OSPF. Use the

addressing scheme shown in the
diagram.



The ITA core network is running EIGRP in AS 1.



Summarize the loopback interfaces on R2 with the best possible summary to the

other EIGRP
routers



Loopback 192 on R3 represents a connection to the Internet. Originate
a default

route into
EIGRP from R3.



The Local Travel Agency router, R4, needs to communicate with the ITA core via

OSPF area 0.



Redistribute OSPF into EIGRP.




Originate a default route into the OSPF process from R3.



Configure R2 to act as a DHCP server on
the Ethernet subnet between R2 and

R3.

Solution

1.

The ITA core network is running EIGRP in AS 1.


Router R1 Configuration

To rename router name from router to R1

Router(config)#hostname R1


To configure Loopback address

R1(config)#interface loo

R1(
config)#interface loopback 1

R1(config
-
if)#ip add

R1(config
-
if)#ip address 192.168.1.1 255.255.255.252

R1(config
-
if)#no shut

R1(config
-
if)#no shutdown

R1(config
-
if)#
exit


To configure Interface S0/0


R1(config
-
if)#ip add

R1(config
-
if)#ip address 192.168.1.
129 255.255.255.252

R1(config
-
if)#clock

R1(config
-
if)#clock ra

R1(config
-
if)#clock rate 64000

R1(config
-
if)#no shutdown

R1(config
-
if)#exit


To configure interface s0/1

R1(config
-
if)#interface s0/1

R1(config
-
if)#ip add

R1(config
-
if)#ip address 192.168.1.133

255.255.255.252

R1(config
-
if)#no shutdown

R1(config
-
if)#



To Configure EIGRP on this router

Option 1


R1(config)#router eigrp 1

R1(config
-
router)#network 192.168.1.0

R1(config
-
router)#no auto

R1(config
-
router)#no auto
-
summary

R1(config
-
router)#exit

R1(
config)#



Option 2 by using Wild Card Mask



R1(config)#router eigrp 1

R1(config
-
router)#network 192.168.1.0 0.0.0.3

R1(config
-
router)#network 192.168.1.128 0.0.0.3

R1(config
-
router)#network 192.168.1.130 0.0.0.3

R1(config
-
router)#no auto

R1(config
-
router
)#no auto
-
summary

R1(config
-
router)#exit

Router R2 Configuration

To rename router name from router to R2

Router(config)#hostname R2


To configure Loopback address


R2(config)#interface loopback 101

R2(config
-
if)#ip add 192.168.1.101 255.255.255.252

R2(con
fig
-
if)#no shutdown

R2(config
-
if)#interface loopback 105

R2(config
-
if)#ip add 192.168.1.105 255.255.255.252

R2(config
-
if)#no shutdown

R2(config
-
if)#interface loopback 109

R2(config
-
if)#ip add 192.168.1.109 255.255.255.252

R2(config
-
if)#no shutdown

R2(
config
-
if)#interface loopback 113

R2(config
-
if)#ip add 192.168.1.113 255.255.255.252

R2(config
-
if)#no shutdown

R2(config
-
if)#


To configure Interface S0/0

R2(config
-
if)#interface s0/0

R2(config
-
if)#ip add

R2(config
-
if)#ip address 192.168.1.130 255.255.255.
252

R2(config
-
if)#no shut

R2(config
-
if)#no shutdown

R2(config
-
if)#exit

R2(config)#int


To configure Interface f0/0

R2(config)#interface f0/0

R2(config
-
if)#ip add

R2(config
-
if)#ip address 192.168.1.161 255.255.255.224

R2(config
-
if)#no shut

R2(config
-
if)#


T
o Configure EIGRP on this router

R2(config)#router eigrp 1

R2(config
-
router)#network 192.168.1.101 0.0.0.3

R2(config
-
router)#network 192.168.1.105 0.0.0.3

R2(config
-
router)#network 192.168.1.109 0.0.0.3

R2(config
-
router)#network 192.168.1.113 0.0.0.3

R2(
config
-
router)#network 192.168.1.128 0.0.0.3

R2(config
-
router)#network 192.168.1.160 0.0.0.31

R2(config
-
router)#no auto
-
summary

R2(config
-
router)#


Router R3 Configuration

To rename router name from router to R3

Router(config)#hostname R3


To configure Lo
opback address


R3(config)#interface loopback 5

R3(config
-
if)#ip add

R3(config
-
if)#ip address 192.168.1.5 255.255.255.252

R3(config
-
if)#no sh

R3(config
-
if)#no shutdown

R3(config
-
if)#interface loopback 192

R3(config
-
if)#ip address 192.168.100.1 255.255.255.
252

R3(config
-
if)#no shutdown

R3(config
-
if)#


To configure Interface S0/0

R3(config)#interface s0/0

R3(config
-
if)#ip add

R3(config
-
if)#ip address 192.168.1.134 255.255.255.252

R3(config
-
if)#clo

R3(config
-
if)#clock r

R3(config
-
if)#clock rate 64000

R3(
config
-
if)#no shutdown

R3(config
-
if)#


To configure Interface f0/0

R3(config
-
if)#interface f0/0

R3(config
-
if)#ip add

R3(config
-
if)#ip address 192.168.1.162 255.255.255.224

R3(config
-
if)#no shut

R3(config
-
if)#no shutdown

R3(config
-
if)#


To configure Interfa
ce S0/1

R3(config
-
if)#
interface s0/1

R3(config
-
if)#ip add

R3(config
-
if)#ip address 10.1.1.3 255.255.255.2
48

R3(config
-
if)#no shut

R3(config
-
if)#no shutdown

R3(config
-
if)#

R3(config
-
if)#clock rate 64000

R3(config
-
if)#no shutdown

R3(config
-
if)#


To Configure

EIGRP on this router

R3(config)#router eigrp 1

R3(config
-
router)#network 192.168.1.160 0.0.0.31

R3(config
-
router)#network 192.168.1.132 0.0.0.3

R3(config
-
router)#network 192.168.1.5 0.0.0.3

R3(config
-
router)#exit

R3(config)#exit

R3#w


2.

Summarize the
loopback interfaces on R2 with the best possible
summary to the

other EIGRP routers


Summarize the loopback interfaces on R2

R2(config
-
if)#interface s0/0

R2(config
-
if)#ip summary
-
address eigrp 1 192.168.1.101 255.255.255.240 5

R2(config
-
if)#

*Mar 1 00:14
:21.691: %DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 1: Neighbor 192.168.1.129
(Serial0/0) is down: summary configured

R2(config
-
if)#

*Mar 1 00:14:24.399: %DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 1: Neighbor 192.168.1.129
(Serial0/0) is up: new adjacency

R2(config
-
if)#exit

R2(c
onfig)#interface f0/0

R2(config
-
if)#ip summary
-
address eigrp 1 192.168.1.101 255.255.255.240 5

R2(config
-
if)#exit


Show IP route on router R1

Before Summarize the loopback interfaces on R2

R1#sh ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobi
le, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su

-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is not set



192.168.1.0/24 is variably

subnetted, 7 subnets, 2 masks

D 192.168.1.104/30 [90/2297856] via 192.168.1.130, 00:01:13, Serial0/0

D 192.168.1.108/30 [90/2297856] via 192.168.1.130, 00:01:13, Serial0/0

D 192.168.1.100/30 [90/2297856] via 192.168.1.130, 00:01:13, Seri
al0/0

D 192.168.1.112/30 [90/2297856] via 192.168.1.130, 00:01:13, Serial0/0

C 192.168.1.0/30 is directly connected, Loopback1

D 192.168.1.160/27 [90/2172416] via 192.168.1.130, 00:01:13, Serial0/0

C 192.168.1.128/30 is directly con
nected, Serial0/0

R1#


After Summarize the loopback interfaces on R2

R1#sh ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1,

N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static route


o

-

ODR, P
-

periodic downloaded static route


Gateway of last resort is not set



192.168.1.0/24 is variably subnetted, 5 subnets, 3 masks

D 192.168.1.96/28 [90/2297856] via 192.168.1.130, 00:01:05, Serial0/0

D 192.168.1.112/30 [90/2297856]

via 192.168.1.130, 00:01:05, Serial0/0

C 192.168.1.0/30 is directly connected, Loopback1

D 192.168.1.160/27 [90/2172416] via 192.168.1.130, 00:01:05, Serial0/0

C 192.168.1.128/30 is directly connected, Serial0/0

R1#



3.

Loopback 192 on R3
represents a connection to the Internet. Originate a
default

route into EIGRP from R3.


Injecting a Default Route into EIGRP: IP Default Network

Specifies which network to advertise in EIGRP.

R3(config)#router eigrp 1

R3(config
-
router)#netwo

R3(config
-
rout
er)#network 192.168.100.0

R3(config
-
router)#exit


Creates a static default route to send all traffic with a destination network not in the routing
table to the exit interface

R3(config)#ip route 0.0.0.0 0.0.0.0 loopback 192

Defines a route to the 192.168.1
00.0 network as a candidate default route.

R3(config)#ip default
-
network 192.168.100.0

R3(config)#exit


R1#sh ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate defau
lt, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is 192.168.1.134 to network 192.168.100.0



192.168.1.0/24 is variably subnetted, 7 subnets, 3 masks

D 192.168.1.96/28 [90/2297856] via 192
.168.1.130, 00:11:10, Serial0/0

D 192.168.1.112/30 [90/2297856] via 192.168.1.130, 00:11:10, Serial0/0

C 192.168.1.0/30 is directly connected, Loopback1

D 192.168.1.4/30 [90/2297856] via 192.168.1.134, 00:10:54, Serial0/1

D 192.168.
1.160/27 [90/2172416] via 192.168.1.130, 00:11:10, Serial0/0


[90/2172416] via 192.168.1.134, 00:11:10, Serial0/1

C 192.168.1.128/30 is directly connected, Serial0/0

C 192.168.1.132/30 is directly connected, Serial0/1

D*

192.168.100.0/24 [90/2297856] via 192.168.1.134, 00:02:47, Serial0/1

R1#


R2#sh ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external
type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is 192.168.1.162 to network 192.168.100.0



192.168.1.0/24 is variably subnetted, 10 subnets, 3 masks

C 192.168.1.104/30 is directly connected, Loopback105

C 192.1
68.1.108/30 is directly connected, Loopback109

D 192.168.1.96/28 is a summary, 00:28:54, Null0

C 192.168.1.100/30 is directly connected, Loopback101

C 192.168.1.112/30 is directly connected, Loopback113

D 192.168.1.0/30 [90/2297856]

via 192.168.1.129, 00:12:03, Serial0/0

D 192.168.1.4/30


[90/156160] via 192.168.1.162, 00:11:48, FastEthernet0/0

C 192.168.1.160/27 is directly connected, FastEthernet0/0

C 192.168.1.128/30 is directly connected, Serial0/0

D

192.168.1.132/30


[90/2172416] via 192.168.1.162, 00:12:05, FastEthernet0/0

D* 192.168.100.0/24 [90/156160] via 192.168.1.162, 00:03:53, FastEthernet0/0

R2#

R3#sh ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP



D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2

-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is 0.0.0.0 to network 0.0.0.0



192.168.1.0/24 is variably subnetted, 8
subnets, 4 masks

D 192.168.1.96/28


[90/156160] via 192.168.1.161, 00:12:33, FastEthernet0/0

D 192.168.1.112/30


[90/156160] via 192.168.1.161, 00:12:33, FastEthernet0/0

D 192.168.1.0/30 [90/2297856] via 192.168.1.133,

00:12:33, Serial0/0

D 192.168.1.0/24 is a summary, 00:05:38, Null0

C 192.168.1.4/30 is directly connected, Loopback5

C 192.168.1.160/27 is directly connected, FastEthernet0/0

D 192.168.1.128/30


[90/2172416] via 192.168.1
.161, 00:12:33, FastEthernet0/0

C 192.168.1.132/30 is directly connected, Serial0/0


* 192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.100.0/30 is directly connected, Loopback192

D* 192.168.100.0/24 is a summary, 00:
05:43, Null0

S* 0.0.0.0/0 is directly connected, Loopback192

R3#

R3#

NOTE: For EIGRP to propagate the route, the network specified by the ip default
-
network
command must be known to EIGRP. This means the network must be an EIGRP
-
derived
network in the ro
uting table, or the static route used to generate the route to the network
must be redistributed into EIGRP, or advertised into these protocols using the network
command.


TIP: In a complex topology, many networks can be identified as candidate defaults. W
ithout
any dynamic protocols running, you can configure your router to choose from a number of
candidate default routes based on whether the routing table has routes to networks other
than 0.0.0.0/0. The ip default
-
network command enables you to configure
robustness into
the selection of a gateway of last resort. Rather than configuring static routes to specific
next hops, you can have the router choose a default route to a particular network by
checking in the

Routing table.



4.

Redistribute OSPF into EIGRP.



R3(config
-
router)#red

R3(config
-
router)#redistribute ?


bgp Border Gateway Protocol (BGP)


connected Connected


eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)


isis ISO IS
-
IS


iso
-
igrp IG
RP for OSI networks


metric Metric for redistributed routes


mobile Mobile routes


odr On Demand stub Routes


ospf Open Shortest Path First (OSPF)


rip Routing Information Protocol (RIP)


route
-
map Route map reference


s
tatic Static routes


<cr>


R3(config
-
router)#redistribute ospf

R3(config
-
router)#redistribute ospf ?


<1
-
65535> Process ID


R3(config
-
router)#redistribute ospf 1 ?


match Redistribution of OSPF routes


metric Metric

for redistributed routes


route
-
map Route map reference


vrf VPN Routing/Forwarding Instance


<cr>


R3(config
-
router)#redistribute ospf 1 m

R3(config
-
router)#redistribute ospf 1 me

R3(config
-
router)#redistribute ospf 1 metric ?


<1
-
4294967295>

Bandwidth metric in Kbits per second


R3(config
-
router)#redistribute ospf 1 metric 1544 ?


<0
-
4294967295> EIGRP delay metric, in 10 microsecond units


R3(config
-
router)#redistribute ospf 1 metric 1544

% Incomplete command.


R3(config
-
router)#redistribu
te ospf 1 metric 1544 100 ?


<0
-
255> EIGRP reliability metric where 255 is 100% reliable


R3(config
-
router)#redistribute ospf 1 metric 1544 100 255 ?


<1
-
255> EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded


R3(config
-
router)#redist
ribute ospf 1 metric 1544 100 255 255 ?


<1
-
65535> EIGRP MTU of the path


R3(config
-
router)#redistribute ospf 1 metric 1544 100 255 255 1448 ?


match Redistribution of OSPF routes


route
-
map Route map reference


<cr>


R3(config
-
router)#redistribute ospf 1 metric 1544 100 255 255 1448

R3(config
-
router)#exit

R3(config)#rou

R3(config)#router osp

R3(config)#router ospf 1

R3(config
-
router)#red

R3(config
-
router)#redistribute ?


bgp Border Gateway Protocol (BGP)


connected

Connected


eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)


isis ISO IS
-
IS


iso
-
igrp IGRP for OSI networks


metric Metric for redistributed routes


metric
-
type OSPF/IS
-
IS exterior metric type for redistributed rout
es


mobile Mobile routes


odr On Demand stub Routes


ospf Open Shortest Path First (OSPF)


rip Routing Information Protocol (RIP)


route
-
map Route map reference


static Static routes


subnets Consider su
bnets for redistribution into OSPF


tag Set tag for routes redistributed into OSPF


<cr>


R3(config
-
router)#redistribute ei

R3(config
-
router)#redistribute eigrp ?


<1
-
65535> Autonomous system number


R3(config
-
router)#redistribute eigrp 1 ?


metric Metric for redistributed routes


metric
-
type OSPF/IS
-
IS exterior metric type for redistributed routes


route
-
map Route map reference


subnets Consider subnets for redistribution into OSPF


tag Set tag for routes redistrib
uted into OSPF


<cr>


R3(config
-
router)#redistribute eigrp 1 met

R3(config
-
router)#redistribute eigrp 1 metric ?


<0
-
16777214> OSPF default metric


R3(config
-
router)#redistribute eigrp 1 metric

% Incomplete command.


R3(config
-
router)#redistribute eigrp

1 metric 5 ?


metric
-
type OSPF/IS
-
IS exterior metric type for redistributed routes


route
-
map Route map reference


subnets Consider subnets for redistribution into OSPF


tag Set tag for routes redistributed into OSPF


<cr>


R3(confi
g
-
router)#redistribute eigrp 1 metric 5

% Only classful networks will be redistributed

R3(config
-
router)#redistribute eigrp 1 metric 5 ?


metric
-
type OSPF/IS
-
IS exterior metric type for redistributed routes


route
-
map Route map reference


subnets

Consider subnets for redistribution into OSPF


tag Set tag for routes redistributed into OSPF


<cr>


R3(config
-
router)#redistribute eigrp 1 metric 5 su

R3(config
-
router)#redistribute eigrp 1 metric 5 subnets ?


metric
-
type OSPF/IS
-
IS ext
erior metric type for redistributed routes


route
-
map Route map reference


tag Set tag for routes redistributed into OSPF


<cr>


R3(config
-
router)#redistribute eigrp 1 metric 5 subnets

R3(config
-
router)#exit

R3(config)#




5.

Originate a defaul
t route into the OSPF process from R3.


R3(config)#router ospf 1

R3(config
-
router)#default
-
information originate always

R3(config
-
router)#exit



6.

Configure R2 to act as a DHCP server on the Ethernet subnet between R2
and R3.


R2(config)#ip dh

R2(config)#ip
dhcp ex

R2(config)#ip dhcp excluded
-
address 192.168.1.161 192.168.1.165

R2(config)#ip dh

R2(config)#ip dhcp p

R2(config)#ip dhcp pool Data

R2(dhcp
-
config)#netw

R2(dhcp
-
config)#network 192.168.1.160 255.255.255.224

R2(dhcp
-
config)#def

R2(dhcp
-
config)#defaul
t
-
router 192.168.100.1

R2(dhcp
-
config)#dns

R2(dhcp
-
config)#dns
-
server 4.2.2.2

R2(dhcp
-
config)#

R2(dhcp
-
config)#exit

R2(config)#do wr

Warning: Attempting to overwrite an NVRAM configuration previously written

by a different version of the system image.

Over
write the previous NVRAM configuration?[confirm]

Building configuration...

[OK]

R2(config)#