OSPF chapter 11

flutteringevergreenΔίκτυα και Επικοινωνίες

29 Οκτ 2013 (πριν από 3 χρόνια και 7 μήνες)

93 εμφανίσεις

1

30
-
Oct
-
13

OSPF

CCNA Exploration Semester 2

Chapter 11

2

30
-
Oct
-
13

Topics


Background and features of OSPF


Configure basic OSPF


OSPF metric


Designated router/backup designated router
elections


Default information originate

3

30
-
Oct
-
13

RIP v1

RIP v2

IGRP

EIGRP

Routing protocols

Interior

Exterior

Distance vector

Link state

OSPF

IS
-
IS

EGP

BGP

4

30
-
Oct
-
13

OSPF background


Developed by IETF to replace RIP


Better metric


Fast convergence


Scales to large networks by using areas

5

30
-
Oct
-
13

OSPF packets


0x01 Hello establishes and maintains
adjacency


0x02 Database Description (DBD) summary
of database for other routers to check


0x03 Link State Request (LSR) use to
request more detailed information


0x04 Link State Update (LSU) reply to LSR
and send new information


0x05 Link State Acknowledgement (LSAck)

6

30
-
Oct
-
13

OSPF encapsulation

Data link
frame header

IP packet
header

OSPF packet
header

Data


MAC destination address

Multicast 01
-
00
-
5E
-
00
-
00
-
05
or 01
-
00
-
5E
-
00
-
00
-
06

7

30
-
Oct
-
13

OSPF encapsulation

Data link
frame header

IP packet
header

OSPF packet
header

Data


IP destination address

Multicast 224.0.0.5 or 224.0.0.6

Protocol field 89

8

30
-
Oct
-
13

OSPF encapsulation

Data link
frame header

IP packet
header

OSPF packet
header

Data


Type code for packet type (0x01 etc)

Router ID and Area ID

9

30
-
Oct
-
13

Hello, OSPF packet type 1


Discover OSPF neighbours and establish
adjacencies.


Advertise parameters on which two routers
must agree to become neighbors.


Elect the Designated Router (DR) and
Backup Designated Router (BDR) on
multiaccess networks like Ethernet and
Frame Relay.


10

30
-
Oct
-
13

Fields in Hello packet


Type (=1), Router ID, Area ID


Subnet mask of sending interface


Hello Interval, Dead Interval


Router Priority: Used in DR/BDR election


Designated Router (DR): Router ID of the DR, if any


Backup Designated Router (BDR): Router ID of the
BDR, if any


List of Neighbors: lists the OSPF Router ID of the
neighboring router(s)

11

30
-
Oct
-
13

Sending Hellos


By default, OSPF Hello packets are sent
every 10 seconds on multiaccess and point
-
to
-
point segments and every 30 seconds on
non
-
broadcast multiaccess (NBMA)
segments (Frame Relay, X.25, ATM).


In most cases, OSPF Hello packets are sent
as multicast to 224.0.0.5.


Router waits for Dead interval before
declaring the neighbor "down." Default is four
times the Hello interval.

12

30
-
Oct
-
13

Matching


Before two routers can form an OSPF
neighbour adjacency, they must agree on
three values:


Hello interval,


Dead interval,


Network type (e.g. point to point, Ethernet,
NBMA.)

13

Introduction to OSPF

Hello protocol packets have information
that is used in the OSPF election of:



Designated Router (DR)



DR is responsible for updating all other OSPF
routers



Backup Designated Router (BDR)



This router takes over DR’s responsibilities if
DR fails

30
-
Oct
-
13

14

30
-
Oct
-
13

Election


On multi
-
access networks (Ethernet, NBMA)
the routers elect a designated router and a
backup designated router


This saves on overhead


Each router becomes adjacent to the
designated router and swaps updates with it


If the designated router fails, the backup
designated router takes over

15

30
-
Oct
-
13

Finding best routes

16

30
-
Oct
-
13

Administrative Distance


Preferred to IS
-
IS or RIP but not to EIGRP

17

30
-
Oct
-
13

Configuring OSPF


R1(config)#
router ospf 1


R1(config
-
router)#


The process
-
id is between 1 and 65535


It does not have to match the process
-
id on
neighbour routers (unlike EIGRP)

18

30
-
Oct
-
13

Configuring OSPF


Router(config
-
router)#
network

192.168.1.0
0.0.0.255 area

0


Address as usual


Wildcard mask is required (optional for
EIGRP), some routers accept subnet mask


We always use a single area 0 for CCNA, this
would be the backbone if there are multiple
areas.

19

30
-
Oct
-
13

Choosing the Router ID

1.
Use the IP address configured with the
OSPF router
-
id command.

2.
If the router
-
id is not configured, use the
highest IP address of any of the loopback
interfaces.

3.
If no loopback interfaces are configured, use
the highest active IP address of any physical
interface. The interface must be up. It need
not be in a network command.

20

30
-
Oct
-
13

Show the router ID


show ip protocols (on most routers).


show ip ospf


show ip ospf interface

21

Basic OSPF Configuration

OSPF network command



Includes:
network address ; wildcard mask; area
-
id



Network Address
=
ONLY

directly connected networks



Wildcard Mask
= inverse of the subnet mask (subtract from quad 255)



OSPF Area

=
a group of routers that share link state information

Example:

Router(config
-
router)#
network

network
-
address wildcard
-
ask

area
area
-
id

What is the range of
addresses
advertised?

30
-
Oct
-
13

22

30
-
Oct
-
13

Loopback address


Highest loopback address is used in
preference to a real interface address


A loopback address is a virtual interface and
is automatically up, so it cannot fail


this
makes it more stable.


Router(config)#
interface loopback 0


Router(config
-
if)#
ip address 10.0.0.1
255.255.255.255

23

Basic OSPF Configuration

Router ID



An IP address used to identify a router in an OSPF Area



Three steps for identifying the router ID:

1.
Use IP address configured with OSPF
router
-
id

command which takes
precedence over loopback and physical interface addresses. To assign a
Router ID of 192.168.2.5:


R1(config
-
router)#
router
-
id 192.168.2.5

2.
If the
router
-
id

command has not been used, then choose the
highest
IP address of any
loopback interfaces



Why use Loopback addresses?



The Loopback interface cannot fail


OSPF stability

3.
If no loopback interfaces configured, then the
highest
IP address on any
active interface
is used

30
-
Oct
-
13

24

30
-
Oct
-
13

OSPF router
-
id command


Introduced in IOS 12.0(T) and is the first
choice for determining router ID.



Router(config)#
router ospf 1


Router(config
-
router)#
router
-
id 172.16.0.1



Many networks still use the loopback address
method of assigning router IDs.

25

30
-
Oct
-
13

Changing router ID


The router ID is fixed when OSPF is
configured and given its first network
command.


Any loopback addresses or router
-
id
commands should be given
before

configuring OSPF.


Router#
clear

ip ospf process

can be used,
set the ID, then configure OSPF again.


The router may need to be reloaded

26

OSPF in Multiaccess Networks

Manipulating the OSPF Election Process



If you want to influence the election of DR
& BDR then do one of the following:



Boot up the DR first, followed by the BDR, and
then boot all other routers



OR



Shut down the interface on all routers, followed
by a
no shutdown

on the DR, then the BDR,
and then all other routers

30
-
Oct
-
13

27

OSPF in Multiaccess Networks

Manipulating the OSPF Election Process, continued



Use the
ip
ospf priority
interface

command:



Router(
config
-
if)#
ip ospf priority

(0


255)



Priority number range 0 to 255



0 means the router cannot become the DR or BDR



1 is the default priority value


30
-
Oct
-
13

28

30
-
Oct
-
13

Show ip ospf neighbor

Neighbor
ID

Pri

state

Dead
Time

Address

Interface

10.3.3.3

1

FULL/

00:00:30

192.168.10.6

Serial0/1

10.2.2.2

1

FULL/

00:00:33

192.168.10.2

Serial0/0

OSPF
priority

Fully
adjacent

Of
neighbour

On this
router

29

30
-
Oct
-
13

Other show commands


show ip protocols


show ip ospf


show ip ospf interface


Show ip route

30

30
-
Oct
-
13

Summary?


OSPF does not summarise to class
boundaries by default.

31

30
-
Oct
-
13

OSPF metric


The OSPF specification says that cost is the
metric, does not say how cost is found.


Cisco uses bandwidth


Cost = 10
8



= 100,000,000


bandwidth bandwidth


Then finds cumulative cost for all links on a
path.

32

30
-
Oct
-
13

Standard costs

Interface type

10
8
/bps = Cost

Fast Ethernet and faster

10
8
/100,000,000bps = 1

Ethernet

10
8
/10,000,000bps = 10

E1

10
8
/2,048,000bps = 48

T1

10
8
/1,544,000bps = 64

128 Kbps

10
8
/128,000bps = 781

64 Kbps

10
8
/64,000bps = 1562

56 Kbps

10
8
/56,000bps = 1785

33

30
-
Oct
-
13

Faster than 100 Mbps


By default, the cost metric for all interfaces
operating at 100Mbps or more is 1.


This uses the reference bandwidth of 100Mbps.


To distinguish between links of higher
bandwidths, configure all routers in the area e.g.


auto
-
cost reference
-
bandwidth

1000


This would multiply costs by 10 and allow for
faster bandwidths to have costs below 10.

34

30
-
Oct
-
13

Serial link bandwidths


Serial links often have a default bandwidth of
T1 (1.544 Mbps), but it could be 128 kbps.


This may not be the actual bandwidth.


show interface

will give the default value.


show ip ospf interface

gives the calculated
cost.


Give it the right bandwidth.


Router(config
-
if)#
bandwidth 64

35

30
-
Oct
-
13

Configure the cost directly


Alternative to configuring the bandwidth:


Configure the cost directly.


R1(config)#
interface serial 0/0


R1(config
-
if)#
ip ospf cost 1562


Configure cost if there are non
-
Cisco routers
in the area that calculate costs in different
ways.

36

30
-
Oct
-
13

Point to point network


Only two routers on network


They become fully adjacent with each other

37

30
-
Oct
-
13

Multiaccess networks


Networks where there could possibly be more
than 2 routers, e.g. Ethernet, Frame Relay.


These have a method of cutting down on
adjacencies and the number of updates
exchanged.


5 routers:

10 adjacencies?

38

30
-
Oct
-
13

Multiaccess network


Not efficient if they every router becomes fully
adjacent to every other router


Designated router (DR) becomes fully
adjacent to all other routers


Backup designated router (BDR) does too


in case designated router fails

39

30
-
Oct
-
13

Multiaccess


All routers send LSUs to DR and BDR but not to
other routers


Use multicast address 224.0.0.6

DROther

DROther

DROther

40

30
-
Oct
-
13

Multiaccess


DR then sends LSUs to all routers


Use multicast address 224.0.0.5

41

30
-
Oct
-
13

Router detects change


A router knows that a link is down if it does not
receive a timed Hello from a partner

42

30
-
Oct
-
13

Send update


The router sends a LSU (link state update) on
multicast 224.0.0.6 to DR/BDR


43

30
-
Oct
-
13

Update all routers


DR sends to 224.0.0.5, all OSPF routers


BDR does not send unless DR fails

44

30
-
Oct
-
13

Recalculate routing table


Each router sends LSAck acknowledgement


Waits for hold time in case link comes
straight back up


Runs SPF algorithm using new data


Updates routing table with new routes

45

30
-
Oct
-
13

OSPF network types

Network type

Characteristics

DR election?

Broadcast
multiaccess

Ethernet, token
ring, FDDI

Yes

Nonbroadcast
multiaccess

Frame relay,
X.25, ATM

Yes

Point to point

PPP, HDLC

No

Point to
multipoint

Configured by
administrator

No

Virtual link

Configured by
administrator

No

46

30
-
Oct
-
13

DR/BDR election


Happens when routers first discover each
other using Hellos.


Router with highest priority becomes DR,
next highest becomes BDR.


If they have the same priority then the highest
router ID becomes DR, next highest becomes
BDR.


By default all routers have priority 1

47

30
-
Oct
-
13

Election where same priority

48

30
-
Oct
-
13

Add a router


An election has taken place and a DR and
BDR have been chosen.


Now add another router with a higher priority.
It will not become DR if there is already a DR.


To make sure that a certain router becomes
DR:


Give it the highest priority


Switch it on first

49

30
-
Oct
-
13

OSPF states


Down


Init (after receiving hello)


Two
-
way (election here)


ExStart (decide who initiates exchange)


Exchange (swap summary database)


Loading (link state requests and updates)


Full adjacency (know the same topology)

50

30
-
Oct
-
13

DROther routers


Routers that are not elected as DR or BDR
are called DROther.


They become fully adjacent with DR and
BDR.


They stay in 2
-
way state with each other.

51

30
-
Oct
-
13

Priority


Router(config
-
if)#
ip ospf priority {0
-

255}


To force an election:


Shut down the interfaces


Bring them up again, chosen DR first, chosen
BDR second.


The DR should be a router with plenty of
processing power.

52

30
-
Oct
-
13

Propagate static route


R1(config
-
router)#
default
-
information originate



In routing table


O*E2 0.0.0.0/0 [110/1] via 192.168.10.10, 00:05:34,
Serial0/0/1


E2 means this is an OSPF External Type 2 route.


The cost will stay the same as it is propagated.


Type 1 would increase its cost at each router.

53

30
-
Oct
-
13

Changing intervals


Router(config
-
if)#
ip ospf hello
-
interval

seconds


Router(config
-
if)#
ip ospf dead
-
interval

seconds


This needs to be done on both partners in an
adjacency.


The adjacency is broken when one router is
changed.

54

30
-
Oct
-
13

Databases

55

Summary



RFC 2328 describes OSPF link state
concepts and operations



OSPF Characteristics:



A commonly deployed link state routing protocol



Employs
Designated Router
s
and
Backup Designated Router
s

on multi
-
access networks



DRs & BDRs are elected using Router IDs (
higher = better
)



DR & BDRs are used to transmit (224.0.0.5) and receive LSAs
(224.0.0.6)



Uses
5 packet types
:

1.
HELLO

2.
D
ATA
B
ASE

D
ESCRIPTION

3.
L
INK

S
TATE

R
EQUEST

4.
L
INK
S
TATE

U
PDATE

5.
L
INK

S
TATE

A
CKNOWLEDGEMENT




30
-
Oct
-
13

56

Summary



OSPF Characteristics:



Metric = cost


Based on interface bandwidth



Lowest accumulated cost = best path



Configuration



Enable OSPF on a router using the following
command



R1(
config
)#
router ospf
process
-
id



Use the
network

command to define which
interfaces will participate in a given OSPF process

R1(
config
-
router)#
network

network
-
address wildcard
-
mask

area

area
-
id

30
-
Oct
-
13

57

Summary


Verifying OSPF configuration



show ip protocol



show ip route



show ip ospf interface



show ip ospf neighbor

30
-
Oct
-
13

58

Summary

30
-
Oct
-
13

59

30
-
Oct
-
13

Comparing routing protocols

Link state


Sends LSA updates


low bandwidth use after
initial flooding


Complex algorithm


powerful processor


Three databases


large memory


No loops

Distance vector


Broadcasts whole
routing tables


high
bandwidth use


Simple algorithms


little processing


One table


little
memory


Can have loops

60

30
-
Oct
-
13

The End