Updating WebSphere and IBM HTTP Server with required Fixes

flashyfarctateInternet και Εφαρμογές Web

30 Ιουλ 2012 (πριν από 5 χρόνια και 22 μέρες)

272 εμφανίσεις


Updating WebSphere and IBM HTTP Server with
required Fixes



1. Check system for these prerequisites:

• Both IBM WebSphere and IBM HTTP Server, if using, should be stopped.

• An unzip utility should be available on UNIX platforms. Use the command
which

un
zip
to verify the availability.

• Fixes should be applied to both WebSphere Base and Network Deployment.

• For AIX only: Run the
slibclean
utility before proceeding with the update

of WebSphere and/or IBM HTTP server.

2.Navigate to the ‘UpdateWAS<os>’ dire
ctory, and invoke the scripts
applyBaseFixes.sh

(bat)
to apply fixes to WebSphere Base, or
applyNDFixes.sh (bat)
to apply fixes

to WebSphere Network Deployment. Here are three examples:

• Apply necessary fixes for WebSphere Base on Windows:
C:
\
WebSphere51

\
U
pdateWASwin
\
applyBaseFixes.bat

• Apply necessary fixes forWebSphere Base on
Linux:
/opt/UpdateWASlnx/applyBaseFixes.sh

• Apply necessary fixes for WebSphere Network Deployment on Linux:
/opt

/UpdateWASlnx/applyNDFixes.sh

3. The scripts prompt you to enter th
e locations for the WebSphere and IBM Http Server home
directories.

4.
For Linux only


Apply ifix PQ81108 from ‘UpdateWAS<os>/PQ81108. Refer to the
README.txt

file in this directory for instructions on how to apply the fix.

5. Run the command
java

versio
n
to validate IBM WebSphere JDK version level on AIX,

Windows, and Linux platforms. The java version should be of the build 20040301.

6. Check the IBM WebSphere JDK and gskit version level after running the program.


Updating IBM HTTP Server with required
Fixes


If IBM Http Server is on a remote machine without WebSphere installed in it, then follow
the steps below to apply fixes to IBM Http Server only.


Run gskit.sh (UNIX) or gskit.bat (Windows) to update IBM HTTP Server with the
required gskit version fi
x. The gskit.sh (.bat) file is found in the sub
-
directory
UpdateWAS<os>.

For example, on Linux, run the command:

/opt/UpdateWASlnx/gskit.sh