Section 8 Configuring Enhanced Interior Gateway Routing Protocol (EIGRP)

droppercauseΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 3 χρόνια και 7 μήνες)

148 εμφανίσεις

Section 8


Configuring Enhanced Interior Gateway Routing Protocol
(EIGRP)

Lab 8
-
1
Configuring Basic EIGRP

Lab 8
-
2
Configuring EIGRP Static Neighbors

Lab 8
-
3
Configuring EIGRP Split Horizon

Lab 8
-
4
Configuring EIGRP Stub Area Networks

Lab 8
-
5
Configuring EIGRP Timers

Lab 8
-
6
Configuring EIGRP Maximum Paths

Lab 8
-
7
Configuring EIGRP Passive Interface

Lab 8
-
8
Configuring EIGRP Route Summarization

Lab 8
-
9
Confi
guring EIGRP Default Route Propagation


Real World Application & Core Knowledge

If you’ve completed the previous section discussing the Routing Information Protocol (RIP)
then now its time to indulge further into the wonderful world of Cisco with the intr
oduction
of the EIGRP (Enhanced Interior Gateway Routing Protocol).

EIGRP is a Cisco proprietary routing protocol which means its only found on Cisco
equipment. You cannot run EIGRP on Juniper or Adtran or any other router for that matter
since EIGRP is sp
ecial (only to Cisco). EIGRP is commonly the routing protocol of choice
when using an ALL Cisco network with no requirement for cross
-
vendor operation. EIGRP
supports the use of multiple routed protocols such as IP, IPX, AppleTalk.

EIGRP evolved from its p
redecessor; Interior Gateway Routing Protocol (IGRP) which is
classful routing protocol just like RIPv1; IGRP does not advertise the subnet mask with the
updates whereas EIGRP is classless and supports VLSM (Variable Length Subnet Masking)
IGRP uses a 24bi
t metric whereas EIGRP uses a 32bit metric. When running EIGRP and
IGRP on the same router using the same Autonomous System number (AS#), EIGRP and
IGRP will automatically redistribute between protocols and the EIGRP will adjust the metric
accordingly.

REA
DME

IGRP support was removed from IOS versions 12.2(13)T and later. The CCNA Exam does not test you on the configuration
of IGRP but you’re required to know the history of EIGRP.

EIGRP in and of its self is a Hybrid routing protocol which has characterist
ics of both a
distance vector and link state protocol. Much like RIP using the triggered feature, EIGRP
updates are only sent when a change in the network is determined. At first EIGRP routers
will form a neighbor relationship and exchange the topological
information. After which the
routing protocol will send periodic hello’s to ensure that the neighbor is still there. However
when a link goes down or a route changes, updates are then sent to neighboring routers via
multicast 224.0.0.10 using its own IP pr
otocol number 88.

EIGRP uses the Diffusing Update ALgorithm (DUAL) which ensures a loop free routing
domain by maintaining two separate routes in the eigrp topology table called Successor and
Feasible Successor routes. The Successor route is the route that

is injected into the routers
routing table as the “best route” whereas the Feasible Successor route is effectively the
backup route which is required to adhere to the successor feasibility condition. The rule states
that in order to be considered a Feasib
le Successor route, the advertised distance (AD) of the
Feasible Successor should be less than the feasible distance (FD) of the Successor”

The Advertised Distance is the distance advertised by an upstream neighboring router to a
particular route destinati
on.

The Feasible Distance is the distance to a particular route destination from a specific router.
The sum of the administrative distance and the distance towards the advertising router
towards that specific route. For example; From R1′s perspective, R3 i
s advertising a distance
of 10000 to the destination 10.22.55.0/24 however your distance to R3 from R1 is 500, so
your feasible distance would be 10500.

EIGRP maintains three separate tables, the neighbor table, topology table and the routing
table;

The ne
ighbor table establishes a list of all adjacent routers which a particular router has
formed a neighbor relationship with. Neighbors exchange routing information and hello’s to
ensure a neighbor is still up.

The topology table is basically the route databa
se in which all destination routes learned via
the neighbors are stored. Routes in the topology table can be marked with a “P” for passive
which means the routes are stable. Routes marked as “A” Active are routes that no longer
satisfy the feasibility cond
ition and are actively searching for a replacement Successor route
by querying neighboring routers. If a successor route has a feasible successor, the route will
never be marked active as the router will have a backup route to fail back to in case the
prim
ary (Successor route) fails. The convergence time is very low.

If a route goes down and no Feasible Successor exist for the route, EIGRP will query
neighboring routers to see if there is an alternate route to the failed route. In a poorly
designed network,

EIGRP queries can be the downfall of the network as an EIGRP route can
become SIA (Stuck in Active). If a query response is not received back from a router within
the allotted time (SIA Timer: 180 seconds by default) the neighbor relationship is dropped
a
nd any routes associated with that neighbor relationship are purged resulting in dropped
packets while the network is re
-
converging.

The EIGRP metric is calculated by a formula using five separate values known as K Values.
By default only K Values 1 and 3
are used (Bandwidth & Delay), K2, K4 and K5 are set to 0.
The EIGRP metric formula and K Values are defined below;

EIGRP Metric = 256*((K1*Bw) + (K2*Bw)/(256
-
Load) + K3*Delay)*(K5/(Reliability +
K4)))



K1 = Bandwidth



K2 = Load



K3 = Delay



K4 = Reliability



K5

= Maximum Transmission Unit (MTU)

So if you use the order of operations you can deduce the equation down to

EIGRP Metric = 256(Bandwidth + Delay)

Now keep in mind the Bandwidth and Delay have formulas in and of themselves to derive
those variables. To det
ermine the bandwidth you’ll divide the interface bandwidth from the
max bandwidth. To determine delay you’ll divide the interface delay by 10 as the EIGRP
metric uses ten’s of microseconds in its calculation. View the formulas below;

Bandwidth = (10^7/Band
width in Kbps)

Delay = 10/uSec

So if you want to determine the composite metric of a T1 link at 1.544Mbs (1544Kbps)
you’ll need to get the bandwidth and delay variables first then plug those into the EIGRP
metric calculation formula as shown below; Keep in

mind the delay on a T1 serial interface is
20000uSec (20,000 Microseconds)

Bandwidth = (10^7/1544) = 6476.68 ==
6476

(rounded down)

Delay = (10/20000) =
2000

EIGRP Metric = 256*(6476 + 2000) =
2169856

As shown below is the EIGRP topology table for an EIGR
P T1 point
-
to
-
point link with the
metric underlined;

R1#
show ip eigrp topology

IP
-
EIGRP Topology Table for AS(10)/ID(10.80.12.1)


Codes: P
-

Passive, A
-

Active, U
-

Update, Q
-

Query, R
-

Reply,


r
-

reply Status, s
-

sia Status


P 10.80.12.0/30, 1

successors, FD is
2169856


via Connected, Serial0/1

R1#

Now that you have a basic understanding of the operation of EIGRP, lets get into the
configurational portion of the lab. Many of the commands used to configure EIGRP are
similar to configuring

RIP. You enter the EIGRP router process using the
router eigrp as#

The AS# (Autonomous System #) is however a new concept. An autonomous system is by
definition a collection of multiple networking devices under the control of a single or
multiple entity w
hich share a common routing policy for the network. However you can have
multiple autonomous systems under the control of the same organization for example;
multiple facilities or sites nation or world wide interconnected but segregated for
management purp
oses.

Like RIPv2, auto
-
summary is also enabled by default on EIGRP. Unless you disable auto
-
summary within the eigrp routing process a router will summarize at the boundary to the
classful network.

When specifying networks which participate in the routing
process you must use a wildcard
mask. This is the inverse bit notation of a subnet mask. So if a subnet mask is 255.255.255.0
(11111111.11111111.11111111.00000000), then you invert the bits, 1 to 0 and 0 to 1 and the
wildcard mask becomes 0.0.0.255 (000000
00.00000000.00000000.11111111)

Keep in mind when specifying the network statement under the EIGRP routing process, the
network you specify does
NOT

specify the network that will be advertised in the EIGRP
autonomous system but specifies the network range i
n which interfaces with IP address
which fall into that specified network participates in EIGRP. With that being said, if you have
10.80.0.0 0.255.255.255 this means that any interface that has an IP address in the
10.80.0.0/8 network will participate in t
he EIGRP routing process. The subnet mask are
derived from the interfaces for example if you have 10.20.30.1/24 on Serial0/0 and you
specify the 10.80.0.0 0.255.255.255 network in the EIGRP routing process. EIGRP will
advertise 10.20.30.0/24 and not 10.80.
0.0/8 because the network statement does not specify
the advertised network, only which interfaces participate in the routing process.

It is best practice to specify interface IP address which participate in the routing process
down to the host IP address
to prevent future unwanted interface participation when a new
interface is added. In this case under router configuration mode you’d specify the
network
10.20.30.1 0.0.0.0

statement. This would prevent an interface with the IP address of
10.30.22.1/24 from

participating in the routing process if you used the
network 10.80.0.0
0.255.255.255

statement.

Like RIPv2, you can statically specify neighbors using the
neighbor x.x.x.x

command in
router configuration mode to configure EIGRP to operate over a NBMA netw
ork such as
Frame Relay. By default EIGRP uses multicast to send hello packets to 224.0.0.10 using IP
protocol 88 and a TTL of 1

By using the
show ip eigrp neighbors

command you can view which neighbors a specific
router has formed adjacencies with. Also t
his command will display other important
information such as the interface in which the neighbor was learned on, the SRTT is the time
it takes for an update to be sent to a neighbor and an acknowledgment to be received back.
The Retransmission timeout is t
he interval at which EIGRP will retransmit hello packets if an
acknowledgment is not received back. The “Q” (Queue Count) is the number of updates
EIGRP has queued to send to that specific neighbor and neighbor uptime.

Another command similar to
show ip ei
grp neighbors

is
show ip eigrp interface

which
displays more information about EIGRP pertaining to the interfaces such as how many
neighbors were learned via a specific interface, the transmit queue, average SRTT per
interface and pending routes.

Labs in S
ection 8 will use the following diagram shown below;


Familiarize yourself with the following new command(s);

Command

Description

router eigrp as#

This command is executed in global configuration mode to start an EIGRP
routing process with the specified
autonomous system number.

no auto
-
summary

This command is executed in EIGRP router configuration mode to disable
auto
-
summarization which summarizes network subnets to the classful
subnet at the boundary.

network n.n.n.n
wc.wc.wc.wc

This command is execu
ted in EIGRP router configuration mode to specify
which interfaces participate in the EIGRP routing process. This command
uses the network id of the subnet and a wildcard mask to identify the
network range.

neighbor x.x.x.x

This command is executed in EIG
RP configuration mode to statically specify
an EIGRP neighbor.

show ip eigrp neighbor

This command when executed from privileged mode will display all current
neighbor adjacencies on that specific router as well as information
pertaining to that neighbor.

You can specify a specific neighbor by listing
the IP address following this command. i.e;
show ip eigrp neighbor
10.80.1.2

show ip eigrp interface

This command when executed from privileged mode will display
information relating to EIGRP on a per
-
interf
ace basis such as number of
peers learnt via an interface, average SRTT and pending routes.

clear ip eigrp x.x.x.x

This command is executed from privileged mode and forces the acquittal
of a neighbor relationship. You can force all neighbor relationships
to drop
by not specifying a neighbors IP address. Keep in mind when you purge a
neighbor all routes learned via that neighbor will be purged from the
routing table.

Lab Prerequisites



If you are using GNS3 than load the Free CCNA Workbook GNS3 topology tha
n start devices;
R1, R2, R3 and R4.



Establish a console session with devices R1, R2, R3 and R4 than load the initial configurations
provided below by copying the config from the textbox and pasting it into the respected
routers console.


Lab Objectives



Configure EIGRP Autonomous System 10 on all Routers and disable
auto summary; then
configure the network statements to match only the host ip address of locally connected
interfaces.



Verify neighbor relationships and the routes being learned via EIGRP using the
show ip eigrp
neighbor

and
show ip route

commands.

Lab Ins
truction

Objective 1.


Configure EIGRP Autonomous System 10 on all Routers and disable auto
summary; then configure the network statements to match only the host ip address of locally
connected interfaces.

R1>
enable

R1#
configure terminal


Enter configurat
ion commands, one per line. End with CNTL/Z.

R1(config)#
router eigrp 10

R1(config
-
router)#
no auto
-
summary

R1(config
-
router)#
network 10.80.10.1 0.0.0.0

R1(config
-
router)#
network 10.80.234.1 0.0.0.0

R1(config
-
router)#
end

R1#

R2>
enable

R2#
configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#
router eigrp 10

R2(config
-
router)#
no auto
-
summary

R2(config
-
router)#
network 10.80.20.1 0.0.0.0

R2(config
-
router)#
network 10.80.234.2 0.0.0.0

R3(config
-
router)#
network 10.80.23.1 0.0.0
.0

R2(config
-
router)#
end

R2#

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.1 (Serial0/0.221) is
up: new adjacency

R2#

R3>
enable

R3#
configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#
router eigrp 10

R3(config
-
router)#
no auto
-
summary

R3(config
-
router)#
network 10.80.30.1 0.0.0.0

R3(config
-
router)#
network 10.80.234.3 0.0.0.0

R3(config
-
router)#
network 10.80.23.2 0.0.0.0

R3(config
-
router)#
end

R3#

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.1 (Serial0/0.32
1) is
up: new adjacency

R3#

R4>
enable

R4#
configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R4(config)#
router eigrp 10

R4(config
-
router)#
no auto
-
summary

R4(config
-
router)#
network 10.80.40.1 0.0.0.0

R4(config
-
router)#
network 10
.80.234.4 0.0.0.0

R4(config
-
router)#
network 10.80.45.1 0.0.0.0

R4(config
-
router)#
end

R4#

R5>
enable

R5#
configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R5(config)#
router eigrp 10

R5(config
-
router)#
no auto
-
summary

R5(config
-
r
outer)#
network 10.80.45.2 0.0.0.0

R5(config
-
router)#
network 10.80.50.1 0.0.0.0

R5(config
-
router)#
end

R5#

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.45.1 (Serial0/1) is up:
new adjacency

R5#

As you’ll notice when you’re configure the EIGRP routing pr
ocess new neighbors will form
between R1 and R2, R1 and R3, R4 and R5 but not between R1 and R4; why is this?

Objective 2


Verify neighbor relationships and the routes being learned via EIGRP using the
show ip eigrp neighbor

and
show ip route

commands.

R
1#
show ip eigrp neighbors

IP
-
EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q
Seq


(sec) (ms) Cnt
Num

1 10.80.234.3 Se0/0

13 00:14:13 444 3996 0 3

0 10.80.234.2 Se0/0 10 00:17:09 205 1230 0 3

R1#

From R1 you can see from above that R1 has established neighbor relationships with R2 and
R3 but not R4. This is due to broadcast not being en
abled on the frame map from R1 to R4
and vice versa. The ISP does not permit broadcast on the specific PVC however you will
learn how to fix this issue in the next Lab 8
-
2 by configuring Static Neighbors.

As shown below you can see that routes from R2 and
R3 are properly being propagated to R1
via EIGRP as denoted by the “D” letter next to the routes in the ip routing table.

R1#
show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


*
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is not set



10.80.0.0/8 is variably subnetted, 7 subnets, 4 masks

D 10.80.23.1/32 [90/2681856] via 10.80.234.3, 00:00:33, Serial0/0

D 10.80.23.0/30 [90/2681856] via 10.80.234.3, 00:00:33, Serial0/0



[90/2681856] via 10.80.234.2, 00:00:33, Serial0/0

D 10.80.23.2/32 [90/2681856] via 10.80.234.2, 00:03:55, Serial0/0

D 10.80.30.0/24 [90/2297856] via 10.80.234.3, 00:00:30, Serial0/0

D 10.80.20.0/24 [90/2297856] via 10.80.234.2, 00:00:
29, Serial0/0

C 10.80.10.0/24 is directly connected, Loopback0

C 10.80.234.0/29 is directly connected, Serial0/0

R1#

As an additional measure of verification you can also ping the EIGRP learnt networks
sourced from the local network to verify t
hat you have IP connectivity between subnets;

R1#
ping 10.80.30.1 source lo0


Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 10.80.30.1, timeout is 2 seconds:

Packet sent with a source address of 10.80.10.1

!!!!!

Success rate is 100 perce
nt (5/5), round
-
trip min/avg/max = 76/100/152 ms

R1#


Real World Application & Core Knowledge

If you’ve completed the previous Lab 8
-
1


Configuring Basic EIGRP, you’ll notice that
EIGRP did not form a neighbor relationship between R1 and R4. This is due t
o broadcast
now being permitted on the frame
-
map between the two devices. As a restriction the ISP
prohibits broadcast on that specific PVC. With that being said, keep in mind that multicast is
treated like broadcast on frame relay networks.

As a fix to th
is issue you can define a static neighbor in the EIGRP routing process which
will force EIGRP to communicate to that neighbor via unicast similar to RIP; even the
commands are the same which is neighbor x.x.x.x interface#/# where x.x.x.x equals the IP
addr
ess of the interface and the interface#/# is the interface of which the neighboring
relationship will peer over.

When configuring an EIGRP static neighbor, the neighbor statement is required on both ends
of the neighbor relationship in the EIGRP routing pr
ocess that operate in the same
autonomous system. Also keep in mind when you specify a static neighbor relationship over
a particular interface, EIGRP will disable the processing of multicast EIGRP packets on the
specified interface so with that being said

EIGRP will not send nor process received multicast
EIGRP traffic on an interface which has a static neighbor defined under the EIGRP routing
process.

In this lab you will configure a static neighbor relationships on the hub and spokes of the
frame
-
relay n
etwork. (R1 to R2, R1 to R3 and R1 to R4)

This lab will continue to build upon the topology used in Lab 8
-
1 and other labs that are in
Section 8.


Familiarize yourself with the following new command(s);

Command

Description

neighbor x.x.x.x
interface#/#

T
his command is executed in router configuration mode to specify a
static neighbor in EIGRP, commonly used in NBMA networks where
multicast is not permitted. This command will disable the
transmission or processing of received eigrp multicast traffic.

show

ip eigrp neighbor

This command is executed in privileged mode to show all current
neighbor relationships on a particular EIGRP enabled device.

Lab Prerequisites



If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start
devices; R1,
R2, R3 R4 and R5.



Establish a console session with devices R1, R2, R3 R4 and R5 than load the initial
configurations provided below by copying the config from the textbox and pasting it
into the respected routers console.


Lab Objectives



Configure static neighbor relationships on the frame
-
relay hub and spoke networ
k
between R1 and R4, R1 and R3, R1 and R2.



Verify on R1 that the neighbor relationships have been established.



Verify that the routes are being propagated between the spokes to the hub and
between spoke to spoke.

Lab Instruction

Objective 1.


Configure st
atic neighbor relationships on the frame
-
relay hub and spoke
network between R1 and R4, R1 and R3, R1 and R2.

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#router eigrp 10

R1(config
-
router)#neighbo
r 10.80.234.2 Serial0/0

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.2 (Serial0/0) is
down: Static peer configured

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.3 (Serial0/0) is
down: Static peer configured

R1(config
-
router)#neighbor 10.80
.234.3 Serial0/0

R1(config
-
router)#neighbor 10.80.234.4 Serial0/0

R1(config
-
router)#end

R1#

R2>enable

R2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#router eigrp 10

R2(config
-
router)#neighbor 10.80.234.1 Seri
al0/0.221

R2(config
-
router)#end

R2#

%SYS
-
5
-
CONFIG_I: Configured from console by console

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.1 (Serial0/0.221) is
up: new adjacency

R2#

R3>enable

R3#configure terminal

Enter configuration commands, one per l
ine. End with CNTL/Z.

R3(config)#router eigrp 10

R3(config
-
router)#neighbor 10.80.234.1 Serial0/0.321

R3(config
-
router)#end

R3#

%SYS
-
5
-
CONFIG_I: Configured from console by console

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.1 (Serial0/0.321) is
up: new adjacency

R3#

R4>enable

R4#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R4(config)#router eigrp 10

R4(config
-
router)#neighbor 10.80.234.1 Serial0/0

R4(config
-
router)#end

R4#

%SYS
-
5
-
CONFIG_I: Configured from conso
le by console

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.1 (Serial0/0) is up:
new adjacency

R4#

Objective 2.


Verify on R1 that the neighbor relationships have been established.

To view the current neighbor relationships you’ll use the show ip
eigrp neighbors command
in privileged mode as shown below;

R1#show ip eigrp neighbors

IP
-
EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q
Seq


(sec) (
ms) Cnt
Num

2 10.80.234.4 Se0/0 154 00:02:16 83 498 0
24

1 10.80.234.3 Se0/0 13 00:12:12 788 4728 0
33

0 10.80.234.2 Se0/0 14 00:14:13 88 528 0
29

R1#

Obj
ective 3.


Verify that the routes are being propagated between the spokes to the hub and
between spoke to spoke.

As shown below all routes are being advertised to the hub router in the frame
-
relay network
(R1);

R1#show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS,
su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static
route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is not set



10.80.0.0/8 is variably
subnetted, 11 subnets, 4 masks

D 10.80.50.0/24 [90/2809856] via 10.80.234.4, 00:01:35, Serial0/0

D 10.80.40.0/24 [90/2297856] via 10.80.234.4, 00:01:35, Serial0/0

D 10.80.23.1/32 [90/2681856] via 10.80.234.3, 00:11:32, Serial0/0

D 1
0.80.23.0/30 [90/2681856] via 10.80.234.3, 00:11:32, Serial0/0


[90/2681856] via 10.80.234.2, 00:11:32, Serial0/0

D 10.80.23.2/32 [90/2681856] via 10.80.234.2, 00:13:33, Serial0/0

D 10.80.30.0/24 [90/2297856] via 10.80.234.3
, 00:07:36, Serial0/0

D 10.80.45.2/32 [90/2681856] via 10.80.234.4, 00:01:36, Serial0/0

D 10.80.45.0/30 [90/2681856] via 10.80.234.4, 00:01:36, Serial0/0

D 10.80.20.0/24 [90/2297856] via 10.80.234.2, 00:07:36, Serial0/0

C 10.80.10.0
/24 is directly connected, Loopback0

C 10.80.234.0/29 is directly connected, Serial0/0

R1#

Now verify that the routes from the spoke routers R2 and R3 are in the R4′s routing table as
shown below;

R4#show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS

summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static
route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is not set



10.80.0.0/8 is variably subnetted,

6 subnets, 4 masks

D 10.80.50.0/24 [90/2297856] via 10.80.45.2, 00:10:07, Serial0/1

C 10.80.40.0/24 is directly connected, Loopback0

C 10.80.45.2/32 is directly connected, Serial0/1

C 10.80.45.0/30 is directly connected, Serial0/1

D 10.80.10.0/24 [90/2297856] via 10.80.234.1, 00:04:42, Serial0/0

C 10.80.234.0/29 is directly connected, Serial0/0

R4#

As you can see from above you can tell that routes on R2 and R3 are not getting to R4 thus
not being advertised to R5 as wel
l. What causes this problem and how do you fix it?

This type of behavior is caused by EIGRP ip split
-
horizon which states that routes will not be
advertised back out an interface which they were received on. This is a loop
-
prevention
method and in some cas
es must be disabled such as the hub
-
and
-
spoke topology. You will
learn more about split
-
horizon in Lab 8
-
3


Configuring EIGRP No Split
-
Horizon


Real World Application & Core Knowledge

In the previous lab you configured static neighbors on a frame relay hu
b
-
and
-
spoke between
R1 and R2, R1 and R3, R1 and R4. After verification you should have noticed that routes
from R2 did not get propagated to R4 through the hub. This is by default the normal
operation of EIGRP and this is caused by a loop prevention mecha
nism called split
-
horizon.

The split horizon rule simply states that routes will not be advertised back out an interface in
which they were received on. After all; if a router sends route updates to a neighbor why
would that router need to have the neighbo
ring router re
-
advertise those routes back to the
originating router? The simple answer is that its not needed.

However in some scenarios EIGRP IP split horizon is required to be disabled to ensure
intended operation; for example a hub and spoke topology w
here the physical interface has
multiple IP’s mapped to specific PVC’s out a single physical interface. In this case the
normal behavior is that routes learned via an interface will not be re
-
advertised back out that
interface so in that case, with the pre
vious lab R2′s routes being advertised to R1′s Serial0/0
interface would not be re
-
advertised back out R1′s Serial0/0 interface to R3 and R4.

In a case like this you’d need to disable EIGRP split
-
horizon using the no ip split
-
horizon
eigrp as# command in i
nterface configuration mode. This disables split
-
horizon on a per
interface basis for the specified EIGRP autonomous system.

This lab will continue to build upon the topology used in Lab 8
-
2 and other labs that are
found in Section 8.


Familiarize yoursel
f with the following new command(s);

Command

Description

no ip split
-
horizon
This command is executed in interface configuration mode to disable
eigrp as#

ip split
-
horizon for the specified EIGRP autonomous system.

Lab Prerequisites



If you just completed

Lab 8
-
2 you may start where you left off, if not you can load the
Free CCNA Workbook GNS3 topology; start and establish a console session with R1,
R2, R3, R4 and R5 then load their initial configurations included below by copying
the config from the textb
ox and pasting it into the routers console.


Lab Objectives



D
isable IP Split
-
Horizon for EIGRP Autonomous System 10 on R1′s Frame
-
Relay
Hub interface.



Verify that routes from R2 and R3 are now being propagated through the hub to R4
and R5. Ping R2′s Lo0 interface from R5′s Lo0 interface to ensure IP reachability.

La
b Instruction

Objective 1.


Disable IP Split
-
Horizon for EIGRP Autonomous System 10 on R1′s Frame
-
Relay Hub interface.

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#interface Serial0/0

R1(config
-
i
f)#no ip split
-
horizon eigrp 10

R1(config
-
if)#end

R1#

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.4 (Serial0/0)

is resync: split horizon changed

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.3 (Serial0/0)

is resync: split horizon changed

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.2 (Serial0/0)

is resync: split horizon changed

%SYS
-
5
-
CONFIG_I: Configured from console by console

R1#

Objective 2.


Verify that routes from R2 and R3 are now being propagated through the hub
to R4 and

R5. Ping R2′s Lo0 interface from R5′s Lo0 interface to ensure IP reachability.

R5#show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA ex
ternal type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static
route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is not set



10.80.0.0/8 is variably subnetted, 11 subnets, 4 masks

C 10.80.50.0/24 is directly connected, Loopback0

D 10.80.40.0/24 [90/2297856] via 10.80.4
5.1, 01:13:18, Serial0/1

D 10.80.23.1/32 [90/3705856] via 10.80.45.1, 00:01:44, Serial0/1

D 10.80.23.0/30 [90/3705856] via 10.80.45.1, 00:01:44, Serial0/1

D 10.80.23.2/32 [90/3705856] via 10.80.45.1, 00:01:44, Serial0/1

D 10.80.30.0
/24 [90/3321856] via 10.80.45.1, 00:01:44, Serial0/1

C 10.80.45.1/32 is directly connected, Serial0/1

C 10.80.45.0/30 is directly connected, Serial0/1

D 10.80.20.0/24 [90/3321856] via 10.80.45.1, 00:01:45, Serial0/1

D 10.80.10.0/24
[90/2809856] via 10.80.45.1, 01:07:51, Serial0/1

D 10.80.234.0/29 [90/2681856] via 10.80.45.1, 01:13:18, Serial0/1

R5#

As shown above you can see that R5 now has routes to R2′s Lo0 interface and the next hop to
that destination is R4 so with that in
mind, R4 also knows how to get there otherwise it would
not advertise that specific route.

To verify that R5 has ip reachability to R2′s Lo0 interface you can pink R2′s Lo0 interface
from R5′s Lo0 interface as shown below;

R5#ping 10.80.20.1 source lo0


Ty
pe escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 10.80.20.1, timeout is 2 seconds:

Packet sent with a source address of 10.80.50.1

!!!!!

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 164/274/380 ms

R5#


Real World Application &

Core Knowledge

The more routers you have the more queries you have and the more queries and latency you
have the greater the chance routers in your network will become SIA (Stuck in Active), in
which case any neighboring EIGRP nodes that does not return a

query reply in the specified
thread hold will be dropped and any routes learned via that neighbor will be also removed
from the routing table even if the routes were up. So in a worst case scenario, such problems
can result in your routing table automagic
ally disappearing…

With all of this information brought to the table; does R5 really need to be queried regarding
networks upstream when it only has one point of entry into the network? That’s a definite no.
So R5 becomes a prime candidate to become a stub

eigrp router in which case will receive all
routes but only advertise connected and summary routes upstream.

When a router has formed a stub neighbor adjacency with another router, the stub eigrp
neighbor will not be sent any queries so this effectively s
peeds up network convergence as
now there’s one less router to query in case of a route failure.

There are seven different types of EIGRP stubs but the CCNA scope only coves the basic
stub which is will receive all EIGRP routes but send only connected and
summary routes.
The list compiled below shows the different types of stub networks that eigrp can be
configured as;

Command

Description

EIGRP Stub

This is the default stub configuration if additional syntax is not
specified such as the following listed be
low; the default stub will send
both connected and summary routes and receive all routes from
upstream neighbors.

EIGRP Stub
Connected

Configures a router as a stub router that advertises only directly
connected routes. This type of stub can be used in co
njecture with the
other stub types excluding receive
-
only.

EIGRP Stub Leak
-
Map

Configures a router as a stub router that advertises only route prefixes
that match a specific ip prefix
-
list.

EIGRP Stub Receive
-
Only

Configures an EIGRP router as a stub rou
ter that will ONLY receive
routes from upstream and not advertise any routes to its neighboring
routers. When using this stub type; static routes must be configured
upstream to reach networks within this stub area.

EIGRP Stub
Redistribute

Configures an EI
GRP router as a stub router that will only advertise
redistributed routes. This type of stub can be used in conjecture with
the other stub types excluding receive
-
only.

EIGRP Stub Static

Configures an EIGRP router as a stub router that will only advertise

static routes. This type of stub can be used in conjecture with the
other stub types excluding receive
-
only.

EIGRP Stub Summary

Configures an EIGRP router as a stub router that will only advertise
summary routes. This type of stub can be used in conjectu
re with the
other stub types excluding receive
-
only.

The CCNA exam objectives only requires you to be familiar with the basic EIGRP stub
operation however if you wish to further your knowledge you may experiment with the other
EIGRP stub types.

To configu
re the EIGRP stub type navigate to the EIGRP router process configuration mode
then use the eigrp stub command.

You can verify which neighbors are stub neighbors by using the show ip eigrp neighbors
detail command in privileged mode.

In this lab R5 is a br
anch office and R4 is a regional office. R5 only has a single network it
routes for which is 10.80.50.0/24. You will configure R5 as an EIGRP stub router and verify
your configuration.

Familiarize yourself with the following new command(s);

Command

Descrip
tion

eigrp stub {receive
-
only |
connected | static | summary |
redistribute | leak
-
map}

This command is executed in the EIGRP routing process
configuration mode to specify a router as a stub router. The
default configuration will send directly connected r
outes and
summary routes and receive all routes via an upstream
neighbor. You can however specify additional stub
configuration following the command such as static or
redistribute.

show ip eigrp neighbors detail

This command is executed in privileged mod
e to display
which eigrp neighbors are stub routers. EIGRP stub
neighbors will not be queried during EIGRP re
-
convergence.

This lab will continue to build upon the topology previously used in Lab 8
-
3 as shown below
and other labs found through out Section

8.


Lab Prerequisites



If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start
devices; R1, R2, R3, R4 and R5.



Establish a console session with devices R1, R2, R3, R4 and R5 than load the initial
configurations provided below by co
pying the config from the textbox and pasting it
into the respected routers console.


Lab Objectives



Configure R5 as an EIGRP stub network to send connected and summary routes only
to its neighboring router(s)



Verify R5′s EIGRP stub router configuration using only R4.

Lab Instruction

Objective 1.


Configure R5 as a
n EIGRP stub network to send connected and summary
routes only to its neighboring router(s).

There are two different commands you can use to accomplish this objective which do the
exact same thing. The first one being eigrp stub which is the default eigrp
stub type and will
send connected and summary routes or you can use eigrp stub connected summary which will
give you the same result. This lab will demonstrate the default eigrp stub type as shown
below;

R5>enable

R5#configure terminal

Enter configuration
commands, one per line. End with CNTL/Z.

R5(config)#router eigrp 10

R5(config
-
router)#eigrp stub

R5(config
-
router)#end

R5#

%SYS
-
5
-
CONFIG_I: Configured from console by console

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.45.1 (Serial0/1)

is down: peer
info changed

R5#

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.45.1 (Serial0/1)

is up: new adjacency

R5#

Objective 2.


Verify R5′s EIGRP stub router configuration using only R4.

To view rather or not a neighbor is an EIGRP stub router use the show ip eigrp neighbor
detail command in privileged mode as shown below.

R4>show ip eigrp neighbors detail

IP
-
EIGRP neighbors for p
rocess 10

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.80.45.2 Se0/1 13 00:05:04 1046 5000 0 55

Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 2

Stub Peer Advertising ( CONNECTED SUMMARY ) Routes

Suppressing queries

1 10.80.2
34.1 Se0/0 155 00:50:43 126 756 0 71

Static neighbor

Version 12.4/1.2, Retrans: 3, Retries: 0, Prefixes: 11

R4>

As you can see from the output of R4 (10.80.45.2) shown above it is Stub Peer Advertising
(CONNECTED SUMMARY ) Routes and below that shows “Supp
ressing Queries” This
verifies that R5 is indeed an EIGRP stub router and that it is advertising only connected and
summary routes and will not be queried upon EIGRP network re
-
convergence.


Real World Application & Core Knowledge

So up until now you’ve le
arned how to configure EIGRP neighbor relationships and how to
configure which interfaces participate in the EIGRP routing process. Now its time to get
further in depth with the operation of EIGRP.

EIGRP uses two separate timers to ensure neighbor relation
ships remain established. These
timers are called the “Hello timer” and the “Hold Down Timer”. If you’re familiar with the
operation of RIP then you should be able to make a very good guess as to what these timers
are responsible for.

The hello timer is th
e interval at which a router will send “hello” messages to neighboring
routers to let them know that the originating router is still online and the hold
-
down timer is
the interval at which to consider a neighbor dead if a hello message is not received duri
ng
that time window.

The default hello timer for a high
-
speed broadcast network link is 5 seconds and the hold
-
down timer is 15 seconds whereas the default timers for slow
-
speed NBMA link are 60
seconds hello and 180 seconds dead. A slow
-
speed NBMA link is

classified as any NBMA
link with speeds equal to or less than 1544Kbps (A single T1)

There is a common misconception that the Hello and Hold
-
down timers must match between
routers to form an adjacency but in fact they do not need to match at all. When a r
outer sends
a hello packet to a neighboring router the hello packet includes the hold down timer which
essentially tells the receiving router “If you do not hear from me in this amount of time
consider me dead and get on with your router life.”

However……
There is one exception to this rule. If you have multiple routers on a network
that form adjacencies then all of those routers must have matching hello/dead timers or the
adjacencies will flap. This is a common problem with EIGRP in a frame
-
relay hub and s
poke
topology where a single T1 NBMA PVC does not support broadcast. In this case the
broadcast PVC’s will use the hello/dead timers of 5/15 whereas the non
-
broadcast PVC will
use 60/180. This will cause the hub to have adjacencies with neighbors with diff
erent timers
on the same physical network thus causing flapping adjacencies.

If you completed the previous lab you should have noticed on all routers in the frame
-
relay
hub
-
and
-
spoke topology that the adjacencies were flapping with the hub router. This is
due to
a multiple timer mismatch on the hub with one or more spokes. This lab teach you how to
resolve that problem.

The next big reason as to why you may want to manually change the timers on an EIGRP
routed network is to increase network outage detection

and re
-
convergence time. By default
on high speed links the hello/dead timer is 5/15 so with that in mind if a router goes down it
will take up to 15 seconds before the neighboring routers know about this outage and then
begin to reconverge on the outage.

In some networks its idea to have the ability to detect
router outages as quick as possible and in this case you can configure the hello timer to 1
second and dead timer to 3 seconds.

The EIGRP Hello and Hold
-
Down timers are configured on a per
-
interface
basis using the ip
hello
-
interval eigrp AS# timeinseconds# and ip hold
-
time eigrp as# timeinseconds#
commands in interface configuration mode.

Familiarize yourself with the following new command(s);

Command

Description

ip hello
-
interval eigrp AS#
timeinse
conds#

This command is executed in interface configuration mode
to manually configure an EIGRP hello interval on a per
-
interface per autonomous system basis. Time is specified in
seconds.

ip hold
-
time eigrp as#
timeinseconds#

This command is executed in i
nterface configuration mode
to manually configure an EIGRP dead interval on a per
-
interface per autonomous system basis. Time is specified in
seconds.

This lab will continue to build upon the topology previously used in Lab 8
-
4 and other labs
found throug
h out Section 8.


Lab Prerequisites



If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start
devices; R1, R2, R3, R4 and R5.



Establish a console session with devices R1, R2, R3, R4 and R5 than load the initial
configurations provide
d below by copying the config from the textbox and pasting it
into the respected routers console.


Lab Objectives



Configure EIGRP on R4 to send Hello’s to R1 at 5 seconds and a dead timer of 15
seconds.



Verify your configuration on R1 by using the show ip eigrp neighbor command.

Lab Instruction

Objective 1.


Config
ure EIGRP on R4 to send Hello’s to R1 at 5 seconds and a dead timer of
15 seconds.

To complete this objective you’ll use the two commands discussed in the core knowledge
section of this lab as shown below;

R4>enable

R4#configure terminal

Enter configuratio
n commands, one per line. End with CNTL/Z.

R4(config)#interface Serial0/0

R4(config
-
if)#ip hello
-
interval eigrp 10 5

R4(config
-
if)#ip hold
-
time eigrp 10 15

R4(config
-
if)#end

R4#

Objective 2.


Verify your configuration on R1 by using the show ip eigrp nei
ghbor
command.

You can easily determine the hello/dead timers of an EIGRP neighbor by viewing the
neighbor adjacencies. If the hold timer is less then 15 seconds then its safe to assume that the
neighbor is using a 5 second hello interval and a 15 second d
ead timer. You can view the
neighbor table multiple times to see that the hold timer is reset back to 15 seconds upon each
receipt of a hello packet as shown below;

R1#show ip eigrp neighbors

IP
-
EIGRP neighbors for process 10

H Address In
terface Hold Uptime SRTT RTO Q
Seq


(sec) (ms) Cnt
Num

2 10.80.234.4 Se0/0 11 00:18:25 510 3060 0
12

1 10.80.234.3 Se0/0 11 00:18
:53 509 3054 0
17

0 10.80.234.2 Se0/0 12 00:20:02 529 3174 0
17

R1#show ip eigrp neighbors

IP
-
EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q
Seq



(sec) (ms) Cnt
Num

2 10.80.234.4 Se0/0 11 00:18:25 510 3060 0
12

1 10.80.234.3 Se0/0 10 00:18:54 509 3054 0
17

0 10.80.234.2 Se0/0

12 00:20:03 529 3174 0
17

R1#show ip eigrp neighbors

IP
-
EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q
Seq


(sec) (ms) Cnt
Num

2 10.8
0.234.4 Se0/0 10 00:18:26 510 3060 0
12

1 10.80.234.3 Se0/0 10 00:18:54 509 3054 0
17

0 10.80.234.2 Se0/0 12 00:20:03 529 3174 0
17

R1#show ip eigrp neighbors

IP
-
EIG
RP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q
Seq


(sec) (ms) Cnt
Num

2 10.80.234.4 Se0/0 10 00:18:26 510 3060 0
12

1 10.80.234.3 Se0/0 10 00:18:54 509 3054 0
17

0 10.80.234.2 Se0/0 11 00:20:03 529 3174 0
17

R1#show ip eigrp neighbors

IP
-
EIGRP neighbors for process 10

H Address Interface

Hold Uptime SRTT RTO Q
Seq


(sec) (ms) Cnt
Num

2 10.80.234.4 Se0/0 10 00:18:26 510 3060 0
12

1 10.80.234.3 Se0/0 14 00:18:54 509

3054 0
17

0 10.80.234.2 Se0/0 11 00:20:03 529 3174 0
17

R1#show ip eigrp neighbors

IP
-
EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q
Seq



(sec) (ms) Cnt
Num

2 10.80.234.4 Se0/0 14 00:18:26 510 3060 0
12

1 10.80.234.3 Se0/0 14 00:18:54 509 3054 0
17

0 10.80.234.2 Se0/0 11 00
:20:03 529 3174 0
17

R1#


Real World Application & Core Knowledge

Now that your understanding of EIGRP has evolved lets touch on a few of the more advanced
features of the routing protocol. EIGRP by default will load sharing over a maximum of 4
routes
if they all have the same metric as shown by the show ip protocols command under
“Maximum Paths”.

This number can be an integer value between 1 and 32. While load sharing over 32 routes is
unheard of, there are some scenarios out there that would require s
uch network configuration.

It is common practice to load share over multiple WAN links to some degree rather it be
using load balanced routes in the routing table or some other technology such as ether
-
channel or ppp multi
-
link.

When the router load balanc
es over multiple paths using the routing table, the default load
balancing behavior is per
-
destination load sharing. Some platforms support different
algorithms such as per
-
packet and per source port/per destination port or both layer4 ports.

In this lab y
ou will learn how to statically set the maximum paths that EIGRP can use for ip
route based load sharing.

If you’ve completed Lab 8
-
5


Configuring EIGRP Timers, then you’ll notice on R1 if you
view the routing table that the router is load sharing to the
10.80.23.0/30 network via R2 and
R3. This is because R1 has two routes to that destination network with the same metric.

To statically configure EIGRP’s maximum path’s value, you’ll need to use the maximum
-
paths command in EIGRP router configuration mode f
ollowed by the the number value of
paths.

Familiarize yourself with the following new command(s);

Command

Description

maximum
-
paths #

This command is executed in EIGRP router configuration mode to
statically configure the maximum paths value on a per rout
er basis.

This lab will continue to build upon the topology previously used in Lab 8
-
5 and other labs
found through out Section 8.


Lab Prerequisites



If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start
devices; R1, R2, R3, R4
and R5.



Establish a console session with devices R1, R2, R3, R4 and R5 than load the initial
configurations provided below by copying the config from the textbox and pasting it
into the respected routers console.


Lab Objectives



On R1, view the routing table and verify that R1 is load
-
balancing to 10.80.23.0/30;
aft
erward, specify the maximum paths for EIGRP Autonomous System 10 to use only
1 path.



Verify your configuration by using the show ip route command.

Lab Instruction

Objective 1.


On R1, view the routing table and verify that R1 is load
-
balancing to
10.80.23
.0/30; afterward, specify the maximum paths for EIGRP Autonomous System 10 to
use only 1 path.

R1>show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


*
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is
not set



10.80.0.0/8 is variably subnetted, 11 subnets, 4 masks

D 10.80.50.0/24 [90/2809856] via 10.80.234.4, 01:13:17, Serial00

D 10.80.40.0/24 [90/640256] via 10.80.234.4, 01:13:17, Serial00

D 10.80.23.1/32 [90/2681856] via 10.80.2
34.3, 01:13:17, Serial00

D 10.80.23.0/30 [90/2681856] via 10.80.234.3, 01:13:17, Serial00


[90/2681856] via 10.80.234.2, 01:13:17, Serial00

D 10.80.23.2/32 [90/2681856] via 10.80.234.2, 01:13:17, Serial00

D 10.80.30.0/
24 [90/640256] via 10.80.234.3, 01:13:17, Serial00

D 10.80.45.2/32 [90/2681856] via 10.80.234.4, 01:13:17, Serial00

D 10.80.45.0/30 [90/2681856] via 10.80.234.4, 01:13:17, Serial00

D 10.80.20.0/24 [90/512512] via 10.80.234.2, 01:13:17, Se
rial00

C 10.80.10.0/24 is directly connected, Loopback0

C 10.80.234.0/29 is directly connected, Serial00

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#router eigrp 10

R1(config
-
router)#
maximum
-
paths 1

R1(config
-
router)#end

R1#

Objective 2.


Verify your configuration by using the show ip route command.

R1#show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSP
F inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


*
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Ga
teway of last resort is not set



10.80.0.0/8 is variably subnetted, 11 subnets, 4 masks

D 10.80.50.0/24 [90/2809856] via 10.80.234.4, 00:01:23, Serial00

D 10.80.40.0/24 [90/640256] via 10.80.234.4, 00:01:23, Serial00

D 10.80.23.1/32
[90/2681856] via 10.80.234.3, 00:01:23, Serial00

D 10.80.23.0/30 [90/2681856] via 10.80.234.2, 00:01:23, Serial00

D 10.80.23.2/32 [90/2681856] via 10.80.234.2, 00:01:23, Serial00

D 10.80.30.0/24 [90/640256] via 10.80.234.3, 00:01:23, Seri
al00

D 10.80.45.2/32 [90/2681856] via 10.80.234.4, 00:01:23, Serial00

D 10.80.45.0/30 [90/2681856] via 10.80.234.4, 00:01:23, Serial00

D 10.80.20.0/24 [90/512512] via 10.80.234.2, 00:01:23, Serial00

C 10.80.10.0/24 is directly conne
cted, Loopback0

C 10.80.234.0/29 is directly connected, Serial00

R1#

As you can see from the routing table on R1 shown above that R1 is no longer load balancing
traffic to 10.80.23.0/30 via R2 and R3 but using only R3 as the next hop.

You can view th
e EIGRP topology and the route to 10.80.23.0/30 via R2 will become the
feasible successor (backup route) as shown below;

R1#show ip eigrp topology

IP
-
EIGRP Topology Table for AS(10)/ID(10.80.10.1)


Codes: P
-

Passive, A
-

Active, U
-

Update, Q
-

Query, R
-

Reply,


r
-

reply Status, s
-

sia Status


P 10.80.50.0/24, 1 successors, FD is 2298112


via 10.80.234.4 (2809856/2297856), Serial00

P 10.80.40.0/24, 1 successors, FD is 128512


via 10.80.234.4 (640256/128256), Serial00

P 10.80.23.1/32
, 1 successors, FD is 2170112


via 10.80.234.3 (2681856/2169856), Serial00

P 10.80.23.0/30, 1 successors, FD is 2170112


via 10.80.234.2 (2681856/2169856), Serial00


via 10.80.234.3 (2681856/2169856), Serial00

P 10.80.23.2/32, 1 succes
sors, FD is 2170112


via 10.80.234.2 (2681856/2169856), Serial00

P 10.80.30.0/24, 1 successors, FD is 128512


via 10.80.234.3 (640256/128256), Serial00

P 10.80.45.2/32, 1 successors, FD is 2170112


via 10.80.234.4 (2681856/2169856), Se
rial00

P 10.80.45.0/30, 1 successors, FD is 2170112


via 10.80.234.4 (2681856/2169856), Serial00

P 10.80.20.0/24, 1 successors, FD is 768


via 10.80.234.2 (512512/512), Serial00

P 10.80.10.0/24, 1 successors, FD is 128256


via Connecte
d, Loopback0

P 10.80.234.0/29, 1 successors, FD is 512256


via Connected, Serial00

R1#


Real World Application & Core Knowledge

When you configure EIGRP using a broad network statement such as network 10.80.0.0
0.0.255.255; any interface you bring o
nline with an ip address that falls in that range will start
advertising and processing received hello’s on that interface.

In some scenarios you may want to disable EIGRP from sending and receiving Hello’s on a
particular interface however you may still n
eed that network which the interface is connected
to be advertised throughout the routed domain.

A great example of this would be disabling EIGRP hello’s on a link that goes from a
distribution switch to a layer 2 access switch; another great example would

a network hand
off link to a 3rd party organization which you have no control over, in this case you would
need to advertise that particular link through out your own routed domain but not allow the
3rd party to receive hello’s or send hellos to your devi
ce.

To configure an interface as a passive interface in EIGRP, you’ll use the passive
-
interface
interface#/# command in EIGRP router configuration mode.

To verify rather or not an interface is in passive
-
mode you can use the show ip protocols
command in pr
ivileged mode.

For arguments sake, when attempting this lab vision that a NEW link has been brought up on
R5 which connects to an access switch, one which you have no control over. In this case you
need configure the routers interface as a passive interfac
e to prevent the router from sending
hello’s to this new access switch or process any hello’s received by the access switch.

Familiarize yourself with the following new command(s);

Command

Description

passive
-
interface
interface#/#

This command is execute
d in EIGRP router configuration mode to
configure an interface as an EIGRP passive interface. This command
will disable EIGRP from sending and processing received hello’s on
the s灥cifie搠 interface.

qhis la戠will c潮tinue t漠扵il搠u灯p the t潰潬潧y 灲evio
usly use搠in ia戠U
-
㘠Sn搠潴her la扳
f潵n搠thr潵gh 潵t pecti潮 㠮


Lab Prerequisites



If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start
devices; R1, R2, R3, R4 and R5.



Establish a console session with devices R1, R2, R3, R4 and

R5 than load the initial
configurations provided below by copying the config from the textbox and pasting it
into the respected routers console.


Lab Objectives



On R5 create the new loopback interface using the IP address of 10.50.0.1/24 then
add the respective network statement into EIGRP AS 10.



Configure R5′s newly created loopback interface as a passive
-
interface.



Verify your configuration by using the show ip protocols command.

Lab Instruction

Objective 1.


On R5 create the new loopback interface using the IP address of 10.50.0.1/24
then add t
he respective network statement into EIGRP AS 10.

R5>enable

R5#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R5(config)#interface loopback5

*Jul 3 19:00:19.631: %LINEPROTO
-
5
-
UPDOWN: Line protocol on Interface
Loopback5,

changed state to up

R5(config
-
if)#ip add 10.50.0.1 255.255.255.0

R5(config
-
if)#exit

R5(config)#router eigrp 10

R5(config
-
router)#network 10.50.0.1 0.0.0.0

R5(config
-
router)#

Objecti
ve 2.


Configure R5′s newly created loopback interface as a passive
-
interface.

R5(config
-
router)#passive
-
interface Lo5

R5(config
-
router)#end

R5#

Objective 3.


Verify your configuration by using the show ip protocols command.

R5#show ip protocols

Routing
Protocol is "eigrp 10"


Outgoing update filter list for all interfaces is not set


Incoming update filter list for all interfaces is not set


Default networks flagged in outgoing updates


Default networks accepted from incoming updates


EIGRP metric w
eight K1=1, K2=0, K3=1, K4=0, K5=0


EIGRP maximum hopcount 100


EIGRP maximum metric variance 1


EIGRP stub, connected, summary


Redistributing: eigrp 10


EIGRP NSF
-
aware route hold timer is 240s


Automatic network summarization is not in effect


Ma
ximum path: 4


Routing for Networks:


10.80.45.2/32


10.50.0.1/32


10.80.50.1/32


Passive Interface(s):


Loopback5


Routing Information Sources:


Gateway Distance Last Update


10.80.45.1 90 00:08:41


Dist
ance: internal 90 external 170



R5#


Real World Application & Core Knowledge

If you completed Lab 7
-
8


Configuring RIP Route Summarization then you should have a
basic understanding of how route summarization works. If you did not then to sum it

all up;
its basically the operation at which you subnet different subnets into a single larger subnet
which gets advertised to neighboring routers to conserve router resources. For example, if
you advertise a /22 subnet which encompasses four single /24 n
etworks then you’re
effectively cutting the resource requirements of neighboring routers by 75%; in which case an
upstream router will have a single /22 route instead of four /24 routes to the same geographic
location.

Configuring a summary address for EIG
RP is done on a per interface basis uses practically
the same command as configuring a summary address for RIP however there is a slight
difference. When configuring a summary address on an interface for EIGRP you’ll use the ip
summary
-
address eigrp AS# n.
n.n.n s.s.s.s.s command whereas RIP uses the ip summary
-
address rip n.n.n.n s.s.s.s

Another benefit of using summary routes (aka: route aggregation) is if a single route goes
down that is contained within a summary route, updates are not sent throughout th
e entire
routed domain. Only the router advertising the summary route will know that the more
specific route has went down. For EIGRP, this will prevent unwanted queries and potentially
SIA in the EIGRP autonomous system.

In this lab you will configure fou
r new loopback interfaces on R1 and configure a summary
route on R1 advertised out the Frame
-
relay hub
-
and
-
spoke interface as well as the point
-
to
-
point interface towards R2.

Familiarize yourself with the following new command(s);

Command

Description

ip s
ummary
-
address eigrp AS#
n.n.n.n s.s.s.s.s

This command is executed in interface configuration mode
to configure an EIGRP summary route to be advertised out a
specific interface.

This lab will continue to build upon the topology previously used in Lab 8
-
7

and other labs
found through out Section 8.


Lab Prerequisites



If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start
devices; R1, R2, R3, R4 and R5.



Establish a console session with devices R1, R2, R3, R4 and R5 than load the in
itial
configurations provided below by copying the config from the textbox and pasting it
into the respected routers console.


Lab Objectives



Configure four new loopback interfaces on R1 using the numbers 4
-
7, configure these
interfaces with the ip address range 10.122.4.0/22. Tip: The 3rd octet as the interface
num
ber.



Configure a single network statement to encompass the four newly created loopback
interfaces.



On R1 configure a summary address of 10.122.4.0/22 to be advertised out both the
frame
-
relay hub
-
and
-
spoke interface.



Verify the summary address is being pro
pagated correctly by viewing he routing table
on R5.

Lab Instruction

Objective 1.


Configure four new loopback interfaces on R1 using the numbers 4
-
7,
configure these interfaces with the ip address range 10.122.4.0/22. Tip: The 3rd octet as the
interface
number.

R1>enable

R1#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#interface loopback4

%LINEPROTO
-
5
-
UPDOWN: Line protocol on Interface Loopback4, changed state

to up

R1(config
-
if)#ip add 10.122.4.1 255.255.255.
0

R1(config
-
if)#interface loopback5

%LINEPROTO
-
5
-
UPDOWN: Line protocol on Interface Loopback5, changed state to
up

R1(config
-
if)#ip address 10.122.5.1 255.255.255.0

R1(config
-
if)#interface loopback6

%LINEPROTO
-
5
-
UPDOWN: Line protocol on Interface Loopback6
, changed state to
up

R1(config
-
if)#ip add 10.122.6.1 255.255.255.0

R1(config
-
if)#interface loopback 7

%LINEPROTO
-
5
-
UPDOWN: Line protocol on Interface Loopback7, changed state to
up

R1(config
-
if)#ip add 10.122.7.1 255.255.255.0

R1(config
-
if)#exit

R1(config
)#

Objective 2.


Configure a single network statement to encompass the four newly created
loopback interfaces.

R1(config)#router eigrp 10

R1(config
-
router)#network 10.122.4.0 0.0.3.255

R1(config
-
router)#exit

R1(config)#

Objective 3.


On R1 configure a su
mmary address of 10.122.4.0/22 to be advertised out both
the frame
-
relay hub
-
and
-
spoke interface.

R1(config)#interface Serial0/0

R1(config
-
if)#ip summary
-
address eigrp 10 10.122.4.0 255.255.252.0

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.4 (Ser
ial0/0) is
resync: summary configured

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.3 (Serial0/0) is
resync: summary configured

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.2 (Serial0/0) is
resync: summary configured

R1(config
-
if)#end

R1#

%SYS
-
5
-
CONFIG_I: Configured from console by console

R1#

Objective 4.


Verify the summary address is being propagated correctly by viewing he
routing table on R5.

R5>show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

E
IGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
I
S level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static
route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is not set



10.80.0.0/8 is variably subnetted, 13 subnets, 5 masks

C 10.80.50.0
/24 is directly connected, Loopback0

D 10.80.40.0/24 [90/2297856] via 10.80.45.1, 01:43:54, Serial0/1

D 10.80.23.1/32 [90/3705856] via 10.80.45.1, 01:43:54, Serial0/1

D 10.80.23.0/30 [90/3705856] via 10.80.45.1, 01:43:54, Serial0/1

D

10.80.23.2/32 [90/3705856] via 10.80.45.1, 01:43:54, Serial0/1

D 10.80.30.0/24 [90/3321856] via 10.80.45.1, 01:43:54, Serial0/1

C 10.80.45.1/32 is directly connected, Serial0/1

C 10.80.45.0/30 is directly connected, Serial0/1

D 10
.80.20.0/24 [90/3321856] via 10.80.45.1, 01:43:54, Serial0/1

D 10.80.10.0/24 [90/2809856] via 10.80.45.1, 01:43:54, Serial0/1

C 10.50.0.0/24 is directly connected, Loopback5

D

10.122.4.0/22 [90/2809856] via 10.80.45.1, 00:05:37, Serial0/1

D 10.80.234.0/29 [90/2681856] via 10.80.45.1, 01:43:55, Serial0/1

R5>


Real World Application & Core Knowledge

If you’ve completed all the previous labs found in Section 8, then you have knowledgeable
understanding of how to configure the Enhanced I
nterior Gateway Routing Protocol (EIGRP)
however there is one more topic left to touch upon before moving onto OSPF which is the
ability to advertise a default route using EIGRP.

If you’ve completed
Lab 7
-
7


Configuring RIP Default Information Originate

then you’ll
have a good understanding of the benefits and operational concept of dynamically advertising
a default route within the routed domain however; un
like RIP, EIGRP uses a two different
methods commonly used to inject a default route into the EIGRP Topology table.

The first method being to advertising a 0.0.0.0/0 summary route via an interface to
neighboring routers which will flag the route as the def
ault and install it into the routing table
as the gateway of last resort and the second way being to create a static route and redistribute
that static route into the EIGRP autonomous system. This method will be discussed in
Section 10.

In this lab you wil
l learn to configure EIGRP to propagate the
default route using a summary
address on R1′s hub
-
and
-
spoke frame
-
relay interface. (Serial0/0). When configuring a default
summary route for EIGRP, the router advertising the EIGRP default summary route will
suppress any upstream routes learned and only se
nd the default summary route to down
stream neighbors. For an example; vision three routers connected via serial links in a a linear
bus topology. R1 is connected to R2, then R2 is connected to R3. If you configure a default
summary route on the two interf
aces of R2 facing R1 and R3, when R3 advertises directly
connected networks to R2, R2 will install those networks in its own routing table and only
advertise a default route to R1.

However if a single edge router connecting to the internet is advertising a

default route via a
summary
-
address into EIGRP network then the default router will not be in the transit path of
internal traffic thus all internal routers will have the full internal routing table.

You will use the same command as discussed in the previ
ous lab; ip summary
-
address eigrp
as# n.n.n.n s.s.s.s to advertise a default route from R1 to the spoke routers in the hub
-
and
-
spoke topology which include R1, R2, R3 and R4.

This lab will continue to build upon the topology previously used in Lab 8
-
8 and
other labs
found through out Section 8.


Lab Prerequisites



If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start
devices; R1, R2, R3, R4 and R5.



Establish a console session with devices R1, R2, R3, R4 and R5 than load the initial

configurations provided below by copying the config from the textbox and pasting it
into the respected routers console.


Lab Objectives



Create a summary route to advertise the address of the 0.0.0.0/0 network on R1′s hub
-
and
-
spoke serial interface.



Examine the routing tables on R3 and R4 to ensure the default route

is being learned
from R1 as well as other routes.

Lab Instruction

Objective 1.


Create a summary route to advertise the address of the 0.0.0.0/0 network on
R1′s hub
-
and
-
spoke serial interface.

R1>enable

R1#configure terminal

Enter configuration commands,

one per line. End with CNTL/Z.

R1(config)#interface Serial0/0

R1(config
-
if)#ip summary
-
address eigrp 10 0.0.0.0 0.0.0.0

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.4 (Serial0/0) is
resync: summary configured

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: N
eighbor 10.80.234.3 (Serial0/0) is
resync: summary configured

%DUAL
-
5
-
NBRCHANGE: IP
-
EIGRP(0) 10: Neighbor 10.80.234.2 (Serial0/0) is
resync: summary configured

R1(config
-
if)#end

R1#

%SYS
-
5
-
CONFIG_I: Configured from console by console

R1#

Objective 2.


Exa
mine the routing tables on R3 and R4 to ensure the default route is being
learned from R1 as well as other routes.

R3#show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF in
ter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candi
date default, U
-

per
-
user static
route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is 10.80.234.1 to network 0.0.0.0



10.80.0.0/8 is variably subnetted, 6 subnets, 5 masks

C 10.80.23.1/32 is directly connected,
Serial0/1

C 10.80.23.0/30 is directly connected, Serial0/1

C 10.80.30.0/24 is directly connected, Loopback0

D 10.80.20.0/24 [90/2297856] via 10.80.23.1, 00:43:57, Serial0/1

D 10.122.4.0/22 [90/2297856] via 10.80.234.1, 00:41:16, Serial0/0.321

C 10.80.234.0/29 is directly connected, Serial0/0.321

D* 0.0.0.0/0 [90/2297856] via 10.80.234.1, 00:01:39, Serial0/0.321

R3#

If you examine the routing table of R3 as shown

above you’ll notice that the default route
0.0.0.0/0 is being learned via 10.80.234.1 on interface Serial0/0.321 however you’ll also
notice that routes that are advertised by R4 and R5 are no longer in the routing table as but
you can still ping those des
tinations. This is due to R1 only advertising the default route to
neighboring routers.

In this case, R4 advertises all its connected networks such as 10.80.40.0/24 to R1 then R1
places this route in its routing table but only advertises a default route to

R2 and R3 however
R2 and R3 are still able to get to R4′s networks using only the default route.

You can see from examining the routing table of R4 shown below that the same thing is
occurring to R4 as it only has a default route which points to R1 and th
e previous more
specific routes pointing towards R1 originally advertised by R2 and R3 have disappeared.

R4#show ip route

Codes: C
-

connected, S
-

static, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP external, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate defau
lt, U
-

per
-
user static
route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is 10.80.234.1 to network 0.0.0.0



10.80.0.0/8 is variably subnetted, 7 subnets, 5 masks

D 10.80.50.0/24 [90/2297856] via 10.80.45.2, 00:5
1:28, Serial0/1

C 10.80.40.0/24 is directly connected, Loopback0

C 10.80.45.2/32 is directly connected, Serial0/1

C 10.80.45.0/30 is directly connected, Serial0/1

D 10.50.0.0/24 [90/2297856] via 10.80.45.2, 00:51:28, Serial0/1

D

10.122.4.0/22 [90/2297856] via 10.80.234.1, 00:48:47, Serial0/0

C 10.80.234.0/29 is directly connected, Serial0/0

D* 0.0.0.0/0 [90/2297856] via 10.80.234.1, 00:09:10, Serial0/0

R4#

If you view the EIGRP topology table on R4 you’ll notice that ro
utes from R3 are not being
advertised to R4 via R1 but instead only a default route is advertised as shown below;

R4#show ip eigrp topology

IP
-
EIGRP Topology Table for AS(10)/ID(10.80.40.1)


Codes: P
-

Passive, A
-

Active, U
-

Update, Q
-

Query, R
-

Reply,


r
-

reply Status, s
-

sia Status


P 0.0.0.0/0, 1 successors, FD is 2297856


via 10.80.234.1 (2297856/128256), Serial0/0

P 10.80.50.0/24, 1 successors, FD is 2297856


via 10.80.45.2 (2297856/128256), Serial0/1

P 10.80.40.0/24, 1 succe
ssors, FD is 128256


via Connected, Loopback0

P 10.80.45.2/32, 1 successors, FD is 2169856


via Rconnected (2169856/0)

P 10.80.45.1/32, 0 successors, FD is Inaccessible


via 10.80.45.2 (2681856/2169856), Serial0/1

P 10.80.45.0/30, 1 su
ccessors, FD is 2169856


via Connected, Serial0/1

P 10.50.0.0/24, 1 successors, FD is 2297856


via 10.80.45.2 (2297856/128256), Serial0/1

P 10.122.4.0/22, 1 successors, FD is 2297856


via 10.80.234.1 (2297856/128256), Serial0/0

P 10.80
.234.0/29, 1 successors, FD is 2169856


via Connected, Serial0/0

R4#

As shown above in R4′s EIGRP topology routes to 10.80.20.
0/24, 10.80.30.0/24 and
10.80.23.0/30 do not exist however a route to 0.0.0.0/0 does which points to R1 which in turn
has the missing routes from R4′s routing table thus the giving full ip reachability as shown
below with the ping command;

R4#ping 10.80.30
.1 source lo0


Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 10.80.30.1, timeout is 2 seconds:

Packet sent with a source address of 10.80.40.1

!!!!!

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 160/200/236 ms

R4#

The more

preferred way of injecting a default route into the EIGRP topology is by
redistributing a static route into EIGRP which will show up as an External EIGRP Route in
the routing table as denoted by “D*EX” next to the route and having an administrative
distan
ce of 170. This method will be discussed in Section 10


Redistribution.