1.40 Fix: PPP Connect on Demand fixed. Change /proc/sys/net/ipv4/ip_conntrack_max value to 4096 Fix Protocol and Port Binding Web UI error. 1.39 Fix: FTP Trigger port problem. Problem of ISP uses loop back address for Peer address. 1.38 Fix: Fix some script error on Web Page

blackstartΔίκτυα και Επικοινωνίες

26 Οκτ 2013 (πριν από 3 χρόνια και 11 μήνες)

110 εμφανίσεις

1.40

Fix:

PPP Connect on Demand fixed.



Change /proc/sys/net/ipv4/ip_conntrack_max value to 4096



Fix Protocol and Port Binding Web UI error.


1.39

Fix:

FTP Trigger port problem.



Problem of ISP uses loop back address for Peer address.


1.38

Fix:

Fix so
me script error on Web Page


1.37

Fix:

Web page shows wrong model name for BR6541K



Change iptables for QoS from PREROUTING to FORWARD


1.36

Fix:

Change "General Menu"'s file name from test.asp to genmenu.asp



PPPoE Connect error on WAN2 of 6524


1.35

Fi
x:

status information showing problem



Time error at status page and tool page



DNS status shows error when setting Manual DNS Address


1.34

Fix:

pppoe connect on demand.



add tcp connection check to check WAN
-
Connection



modify web configure procedure


1.33

Fix:

Status Page unstable.


1.32

Fix:

WAN2 abnormally disconnect problem



Add DNS refresh when any WAN drops


1.31

Fix:

Wan disconnect when heavy traffic load.


1.30

Fix:

Urlblocking problem.



Downstream QoS fixed.



Help Web Page removed.


1.29

C
hange QoS UI. now, add QoS can choose Upstream "OR" Downstream only.


1.28

Fix:

Comments can't input space char.



1.27

Fix:

PPPoE Manual Disconnect failed.



AccessControl Web Page error.



Wireless Encrypt Web Page error.


1.26

Fix:

PPPoE doesn't work wh
en no Service Name setted.



Setting QoS causes WEB stop response


1.25

Fix:

QoS failed when user specified port number



test case 64 byte 100M will cause reboot problem



PPTP pass
-
through problem



Url Blocking Problem



PPPoE service name problem


1.
24

Fix:

Web page title error (planet version)


1.23

Fix:

Fix packet return path of WAN port.



Add deny and allow state on AccessCTL



Enable "Discard Ping From WAN" causes WAN disconnect.



Printer Server crash problem


1.22

Fix:

AccessCTL webpage error (
planet version)


1.21

Fix:

expand "Pre
-
shared Key" field to showing 64 char on screen



security Log page shows wrong WAN4 IP (6541)



set IP_ADDR to 192.168.0.1 for Planet



set IP Address Pool for DHCP to 192.168.0.100 ~ 192.168.0.200



fix boot code for

6541K


1.20

Fix:

WAN3, WAN4 backup function fail (6541)



subnet mask error, when dhcp client didn't get gateway from server



Access Control: access control for MSN fixed



web page: Access Control submit ASP error



web page: some javascript error



web

page: 6524K, 6524WG didn't show current time (Hawking version)



web page: DMZ shows unrecognize char when WAN port didn't get IP



System Log: remove "Bogus PPPoE length field" message



System Log: remove "
--

MARK
--
" message


1.19

Fix:

disconnect WAN2
PPP session causes WAN1 PPP connection be
terminated


1.18

Fix:

Status Page: DNS shows wrong



Change default load balancing ratio to 25% (6541)



Web Page: don't run scripts when delete item or delete all



Web Page: settings don't write to flash unless A
pply buttom is pressed



L2TP PPTP: connect problem



PPP: reconnect to wrong interface( ex: ppp1
-
> ppp2)



Status: Change WAN Mode sometimes lock status page



Can't ping wan port from LAN PC



Add New Model: 6541K


1.17

Fix:

QoS: FTP upload rate didn't
limited



Remote Management: Sometimes route out to wrong interface



Virtual server and port forwarding sometimes didn't work



Wireless: WEP setup page error (fixed by Erwin)



IPP: can't add and print under windows2000 (fixed by JerryChou)



ALG: connec
tion from WAN port return from wrong WAN port.



backup function: all backup ports will start connect when all enabled
wan ports were failed.


1.16

Add:

Session
-
Based Load Balancing



Fix:

Status Page shows same gateway IP at all wan port



status page: sh
ows wrong wan3 and wan4 type (6541)



status page: sometimes shows blank gateway



status page: shows (Backup) at backup line



status and tools page shows wrong date



downstream QoS only work at one wan



QoS doesn't work when protocol and port binding i
s enabled.



protocol and port binding : destination IP range does not work



protocol and port binding doesn't work (session based load balancing)



amanda ALG conflicts with trigger port



dns sometimes doesn't work



ez
-
ipupdate connect time out


1.15

don't create flash files if it is already create by previous script


Fix:

UPnP shows wrong IP address



web server of DMZ host can't access from WAN



broadcast address error



change model cause web page error



upnp active only when wan port got ip



d
isable syslog message of UPnP



dnsproxy didn't work after one wan port failed



QoS doesn't work. ( miss MARK target of iptables )


1.14

fix :

backup function does not work correct when user enabled more
than one backup lines



ipp print protocol does not

work



exchange USB led


Add default time server: 192.43.244.18


1.13

fix :

backup line do not show on the status page



ip
-
up script runs twice at pppd



change killall signal from SIGTERM to SIGKILL



remove unused modules from /lib/modules/2.4.18
-
MIPS
-
01.00


flush routing cache after wan
-
status changes


set rp_filter and arp_filter in all model


speed up wan setting


Change Signature of BR6524K


fix boot code for BR6524K


1.12

modify model Type in diagd.c


1.11

block the connections from WAN direct to
LAN IP


1.10

change L W4 W3 W2 W1 to W4 W3 W2 W1 L for 6541


fix 6541KP 6541WP wan3 and wan4 not work problem


fix MODEL TYPE error in /etc/MODEL


fix "remote management", iptables mport extension;


1.09

modify model Type in diagd.c


1.08

remove QoS from 6
524K and 6524WG for Hawking


1.07

fix some UI bug


1.06

fix load balance weight


add downstream QoS support


remove edit buttom from PortFW UI and fix some bugs in UI


fixed: when Fixed IP, always show connected in Status page


change the polling period o
f wan status check


1.05

combine and fix web pages


fix DoIT.sh in Diagd (always make clean)


1.04

fix PrintServer MIBTBL


fix Status Page model name error


1.03

Print Server script and code by Rex


Ragent.sh wait time to 90 seconds


wanX_ena.sh force eth
X up for PPP connections


Change Download speed to ratio


1.02

print server UI page, savelog.sh, debug.asp


default setting of PrintServer


PrintServer Agent


tftp signature checking fix


clean wan
-
status before init.sh


1.01

ramdisk 6400
-
> 6600


diagd.c


1.00

initial version