Cisco IOS IPv6 Provider Edge Router (6PE) over MPLS

bashfulflowersΛογισμικό & κατασκευή λογ/κού

30 Ιουν 2012 (πριν από 5 χρόνια και 4 μήνες)

1.063 εμφανίσεις

1
© 2001, Cisco Systems, Inc. All rights reserved.
© 2001, Cisco Systems, Inc. All rights reserved.© 2001, Cisco Systems, Inc. All rights reserved.
Cisco IOS IPv6 Provider Edge
Router (6PE) over MPLS
Patrick Grossetete
Cisco Systems
Cisco IOS IPv6 Product Manager
pgrosset@cisco.com
Presentation_ID 2
2
© 2001, Cisco Systems, Inc. All rights reserved.
2
Agenda


IPv6 migration approaches enabled by
IPv6 migration approaches enabled by
MPLS
MPLS
• 6PE approach: IPv6 Provider Edge Router
over MPLS/IPv4
• Cisco IOS 6PE configuration
• Conclusions
Presentation_ID 3
3
© 2001, Cisco Systems, Inc. All rights reserved.
3
Key Markets where MPLS
will facilitate IPv6 Migration
• Wireless
2.5G/3G mobile phone, PDAs, Car’s
networks…
• Service Providers
Mobile ISPs, Greenfield ISPs, Regional ISPs
and Carriers
• Academic and Research Networks
Presentation_ID 4
4
© 2001, Cisco Systems, Inc. All rights reserved.
4
ApplicationsApplications
& Services*)& Services*)
3GPP/UMTS Example
Gf
Gi
Iu
Gi
Mr
Ms
Gi
Gc
Gr
GGSN
EIR
MGCF
R-SGW
MRF
Mm
Mw
Mc
Cx
R
Um
TE
MT
BSS/GRAN
Mh
CSCF
CSCF
Mg
T-SGW *)
HSS *)
SCP
CAP
Gi
R
Uu
MGW
Gn
Signalling and Data Transfer Interface
Signalling Interface
TE
MT
UTRAN
T-SGW *)
HSS *)
GMSC server
*)
those elements are duplicated for figure
layout purpose only, they belong to the same
logical element in the reference model
Mc
Mc
D
C
MGW
Nb
Nc
Iu
1
Iu
2
R-SGW *)
Mh
MSC server
SGSN
MS Circuit
Switch
Access
Network
GPRS
Access
Network
IM Domain
CS Domain
PS Domain
Iu
A
CAP
CAP
Gb
IM Domain is now a sub-set of the PS Domain
IPv6 Mandated
MPLS offers
MPLS offers
ATM + IP + IPv6
ATM + IP + IPv6
switching
switching
Alternative
Access
Network
MultimediaMultimedia
IP NetworksIP Networks
Legacy mobile Legacy mobile
signaling signaling
networknetwork
PSTN/PSTN/
Legacy/ExternalLegacy/External
ApplicationsApplications
& Services*)& Services*)
Presentation_ID 5
5
© 2001, Cisco Systems, Inc. All rights reserved.
5
IPv6 over MPLS
Deployment Scenarios
• Many ways to deliver IPv6 services to End Users
Most important is End to End IPv6 traffic forwarding
• Many Service Providers have already deployed
MPLS in their IPv4 backbone for various reasons
MPLS/VPN, MPLS/QoS, MPLS/TE, ATM + IP switching
• MPLS can be used to facilitate IPv6 integration
• Multiple approaches for IPv6 over MPLS:
IPv6 CE-to-CE IPv6 over IPv4 Tunnels
IPv6 over “Circuit_over_MPLS”
Native IPv6 MPLS
IPv6 Provider Edge Router (6PE) over MPLS
Presentation_ID 6
6
© 2001, Cisco Systems, Inc. All rights reserved.
6
OC48/192
P
P
P
P
PE
PE
PE
PE
IPv4
IPv4
IPv6
IPv6
v6
IPv4
v4
v6
v4
v4
v6
v6
IPv6 over IPv4 Tunnels
Dual Stack
IPv4-IPv6
CE routers
Dual Stack
IPv4-IPv6
CE routers
Dual Stack
IPv4-IPv6
CE routers
Dual Stack
IPv4-IPv6
CE routers
IPv6 Tunnels configured on CE
• No impact on existing IPv4 or MPLS Core (IPv6 unaware)
• Only CEs have to be IPv6-aware (Dual stack)
• Mesh of IPv6 over IPv4 Tunnels CE-to-CE
• Overhead: IPv4 header + MPLS header
• MPLS/VPN support IPv4-native and IPv6 tunnels
• Service Provider can’t delegate his IPv6 prefix to the CE routers
Presentation_ID 7
7
© 2001, Cisco Systems, Inc. All rights reserved.
7
Circuit_over_MPLS
(eg. ATM VC, FR PVC, Ethernet,…)
IPv6
routers
IPv6
routers
P
P
P
P
“Circuit”
IPv6
IPv6
IPv6
v6
v6
v6
v6
IPv6
IPv6
• No impact on existing IPv4 or MPLS Core (IPv6 unaware)
• Edge MPLS Routers need to support “Circuit_over_MPLS”
• Mesh of “Circuit_Over_MPLS” PE-to-PE
• PE routers can also be regular IPv6 Routers (IPv6 over ATM, IPv6
over FR, IPv6 over Ethernet,…) to aggregate Customer’s IPv6 routers
IPv6 over “Circuit_over_MPLS”
Presentation_ID 8
8
© 2001, Cisco Systems, Inc. All rights reserved.
8
P
P
P
P
IPv6
IPv6
IPv6
v6
v6
v6
v6
IPv6
IPv6
All routers are IPv6-aware
All routers are IPv6-aware
IPv6 MPLS
MPLS Label Switch Paths for IPv6
• Core Infrastructure requires full Control Plane upgrade to
IPv6
• IPv6 Routing in core
• IPv6 Label Distribution Protocol in core
• Dual Control Plane management if IPv4 and IPv6 services
Native MPLS Support of IPv6
Presentation_ID 9
9
© 2001, Cisco Systems, Inc. All rights reserved.
9
Agenda
• IPv6 migration approaches enabled by
MPLS


6PE approach: IPv6 Provider Edge Router
6PE approach: IPv6 Provider Edge Router
over MPLS/IPv4
over MPLS/IPv4
• Cisco IOS 6PE configuration
• Conclusions
Presentation_ID 10
10
© 2001, Cisco Systems, Inc. All rights reserved.
10
P
P
P
P
v6
IPv4
MPLS
v4
v6
v4
v4
v6
v6
MP-iBGP sessions
CE
CE
6PE
6PE
6PE
6PE
192.254.10.0
2001:0421::
2001:0420::
192.76.10.0
145.95.0.0
2001:0621::
2001:0620::
Dual Stack IPv4-IPv6 routers
Dual Stack IPv4-IPv6 routers
Dual Stack IPv4-IPv6 routers
Dual Stack IPv4-IPv6 routers
CE
• IPv4 or MPLS Core Infrastructure is IPv6-unaware
• PEs are updated to support Dual Stack/6PE
• IPv6 reachability exchanged among 6PEs via iBGP (MP-BGP)
• IPv6 packets transported from 6PE to 6PE inside MPLS
IPv6 Provider Edge Router (6PE)
over MPLS
Presentation_ID 11
11
© 2001, Cisco Systems, Inc. All rights reserved.
11
P
P
P
P
v6
v4
v6
v4
v4
v6
v6
MP-BGP sessions
6PE
6PE
6PE
6PE
192.254.10.0
2001:0421::
2001:0420::
192.76.10.0
145.95.0.0
2001:0621::
2001:0620::
IGPv4
MPLS V4:
- LDPv4
- (TE v4)
Dual Stack
Dual Stack
IPv4
IPv4
IPv6
IPv6
IPv6
IPv6
IPv4
V6:
IGP/BGP
V6:
IGP/BGP
IPv6 unaware
No core upgrade
IPv6 unaware
No core upgrade
6PE Overview
Presentation_ID 12
12
© 2001, Cisco Systems, Inc. All rights reserved.
12
6PE Routing
6PE-2
6PE-1
P1 P2
2001:0421::
2001:0420::
192.254.10.17
192.72.170.13
• Translation of v6 BGP
Next_Hop into v4address
• Recursion of this address
via IGPv4
IGPv4 advertises IGPv4 advertises
reachabilityreachability of of
192.254.10.17192.254.10.17
LDPv4 binds label LDPv4 binds label
to 192.254.10.17to 192.254.10.17
MPMP--BGP advertises 2001:0421::::BGP advertises 2001:0421::::
and binds a (2nd level) labeland binds a (2nd level) label
IPv6 Next Hop is an IPv4 compatible IPv6 address IPv6 Next Hop is an IPv4 compatible IPv6 address
built from 192.254.10.17built from 192.254.10.17
Presentation_ID 13
13
© 2001, Cisco Systems, Inc. All rights reserved.
13
6PE Routing/Label Distribution
6PE-2
6PE-1
P1
P2
2001:0421::
2001:0420::
192.254.10.17
192.72.170.13
IGPv4 advertises IGPv4 advertises reachabilityreachability
of 192.254.10.17of 192.254.10.17
IGPv6 or MP-BGP
advertising
2001:0421::
(*) The 2
nd
label allows operations with Penultimate Hop Popping (PHP)
(which is typically used in current MPLS networks)- it is an Aggregate label
IGPv6 or MP-BGP
advertising
2001:0421::
LDPv4 binds label
to 192.254.10.17
6PE-2 sends MP-iBGP advertisement to 6PE-1 which says:
2001:0421:: is reachable
via BGP Next Hop = 192.254.10.17 (6PE-2)
bind BGP label to 2001:0421:: (*)
Presentation_ID 14
14
© 2001, Cisco Systems, Inc. All rights reserved.
14
6PE Forwarding
6PE-2
6PE-1
2001:0421::
2001:0420::
IPv6 packet
to 2001:0421::
192.254.10.17
192.72.170.13
P1 P2
Presentation_ID 15
15
© 2001, Cisco Systems, Inc. All rights reserved.
15
6PE-2
6PE-1
2001:0421::
2001:0420::
192.72.170.13
IPv6 packet
to 2001:0421::
6PE Forwarding (6PE-1)
IPv6 Forwarding and Label Imposition:IPv6 Forwarding and Label Imposition:
•• 6P6PEE--1 receives an IP1 receives an IPv6v6 packetpacket
•• Lookup is done on Lookup is done on IPv6 prefixIPv6 prefix
•• Result is:Result is:
Labelz bindedLabelz binded by MPby MP--BGP to BGP to
2001:0421::2001:0421::
Label1 Label1 bindedbinded by LDP/IGPv4 to the by LDP/IGPv4 to the
IPv4 address of BGP Next Hop IPv4 address of BGP Next Hop
(6PE(6PE--2)2)
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
LDP/IGPv4LDP/IGPv4
label1 to 6PElabel1 to 6PE--22
192.254.10.17
P1 P2
Presentation_ID 16
16
© 2001, Cisco Systems, Inc. All rights reserved.
16
6PE Forwarding (P1)
6PE-2
6PE-1
P1
P2
2001:0421::
2001:0420::
192.72.170.13
IPv6 packet
to 2001:0421::
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
LDP/IGPv4LDP/IGPv4
label1 to 6PElabel1 to 6PE--22
LDP/IGPv4LDP/IGPv4
label2 to 6PElabel2 to 6PE--22
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
IPv6-UNaware MPLS Label
Switching:
•P1 receives an MPLS packet
•Lookup is done on Label1
•Result is Label2
192.254.10.17
Presentation_ID 17
17
© 2001, Cisco Systems, Inc. All rights reserved.
17
6PE Forwarding (P2)
6PE-2
6PE-1
P1
P2
2001:0421::
2001:0420::
192.72.170.13
IPv6 packet
to 2001:0421::
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
LDP/IGPv4LDP/IGPv4
label1 to 6PElabel1 to 6PE--22
IPv6-UNaware MPLS Label
Switching:
•P2 receives an MPLS packet
•Lookup is done on Label2
•Result includes Pop label (PHP)
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
LDP/IGPv4LDP/IGPv4
label2 to 6PElabel2 to 6PE--22
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
192.254.10.17
Presentation_ID 18
18
© 2001, Cisco Systems, Inc. All rights reserved.
18
6PE-2
6PE-1
P1
P2
2001:0421::
2001:0420::
192.72.170.13
IPv6 packet
to 2001:0421::
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
LDP/IGPv4LDP/IGPv4
label1 to 6PElabel1 to 6PE--22
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
LDP/IGPv4LDP/IGPv4
label2 to 6PElabel2 to 6PE--22
MPMP--BGP labelBGP label
To 2001:421::To 2001:421::
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
6PE Forwarding (6PE-2)
192.254.10.17
MPLS Label Pop and IPv6
MPLS Label Pop and IPv6
Forwarding :
Forwarding :


6P
6P
E
E
-
-
2 receives an MPLS packet
2 receives an MPLS packet


Lookup is done on
Lookup is done on
Label
Label


Result is:
Result is:
Pop the label & do IPv6 lookup
Pop the label & do IPv6 lookup
on IPv6 destination
on IPv6 destination
IPv6 packetIPv6 packet
To 2001:421::To 2001:421::
Presentation_ID 19
19
© 2001, Cisco Systems, Inc. All rights reserved.
19
Cisco IOS releases for 6PE
• 12.0(22)S on Cisco 12000 series
• 12.2(11)S on Cisco 7200/7400/7500 series
Next release on Cisco 7600
• 12.2(6
th
)T on Cisco 3600/3700/7200/7500
• Contact your Cisco Local team for latest
update
Presentation_ID 20
20
© 2001, Cisco Systems, Inc. All rights reserved.
20
6PE Standardization
• See <draft-ietf-ngtrans-bgp-tunnel-04.txt> :
“BGP Tunnelling”
• Co-authored by Cisco
• Generic solution for transport of IPv6 over
any tunnelling technique (including MPLS)
using MP-BGP
• IETF Working Group document
• 6PE is Cisco IOS implementation of “BGP
Tunnelling” over MPLS
Presentation_ID 21
21
© 2001, Cisco Systems, Inc. All rights reserved.
21
6PE Benefits
For SPs already running MPLS, 6PE approach
has many benefits:
• Core Infrastructure needs no upgrade and no
configuration change
• Upgrade only on the required edge routers (ie
upgrade of existing PEs to 6PE, or add separate 6PEs)
• IPv6 supported simultaneously with existing MPLS
services (MPLS v4_VPNs, QoS, ATM, v4 Internet, …)
6PE allows IPv6 to be deployed over existing
MPLS Multiservice infrastructure with marginal
operational impact/cost/risk

Presentation_ID 22
22
© 2001, Cisco Systems, Inc. All rights reserved.
22
P
P
P
P
v6
v6
v4
v6
v6
MP-BGP sessions
6PE
6PE
6PE
6PE
192.254.10.0
2001:0421::
2001:0420::
v4
192.76.10.0
145.95.0.0
2001:0621::
2001:0620::
IPv4
MPLS
v6IGP
MP-BGP
v4
IPv6 CE only has a single Routing Peer (PE) regardless of how many
remote IPv6 CEs it communicates with
No change on an IPv6 CE when remote CEs are added/removed
(reachability automatically learnt)
No tunnel/”circuit” to be configured


6PE offers scalable and flexible solution (benefits are analogou
6PE offers scalable and flexible solution (benefits are analogou
s to
s to
RFC2547bis layer 3 VPN solution for IPv4)
RFC2547bis layer 3 VPN solution for IPv4)
6PE Benefits
Presentation_ID 23
23
© 2001, Cisco Systems, Inc. All rights reserved.
23
P
P
P
P
v6
v6
v4
v6
v6
MP-BGP sessions
6PE
6PE
6PE
6PE
192.254.10.0
2001:0421::
2001:0420::
v6
192.76.10.0
145.95.0.0
2001:0621::
2001:0620::
IPv4
MPLS
v6
CE
CE
CE
CE
6PE solution can be easily extended to support same
VPN services for IPv6 as currently supported for IPv4
with RFC2457bis (isolation, Internet access, QoS…)
6PE Benefits
Presentation_ID 24
24
© 2001, Cisco Systems, Inc. All rights reserved.
24
P
P
P
P
v6
v6
v4
v6
v6
MP-BGP sessions
6PE
6PE
6PE
6PE
192.254.10.0
2001:0421::
2001:0420::
v4
192.76.10.0
145.95.0.0
2001:0621::
2001:0620::
IPv4
MPLS
CE
CE
CE
v4
CE
6PE Cons
• Only makes sense where network already runs MPLS
• Requires knowledge of MPLS and BGP technologies
• Requires dual-stack and software upgrade on
existing PE or deployment of dedicated 6PE routers
Presentation_ID 25
25
© 2001, Cisco Systems, Inc. All rights reserved.
25
Agenda
• IPv6 migration approaches enabled by
MPLS
• 6PE approach: IPv6 Provider Edge Router
over MPLS/IPv4


Cisco IOS 6PE configuration
Cisco IOS 6PE configuration
• Conclusions
Presentation_ID 26
26
© 2001, Cisco Systems, Inc. All rights reserved.
26
6PE Configuration Commands
• Two new Commands:
router(config-router-af)#neighbor <ip-address> send-label
Enables binding and advertisement of aggregate labels when
advertising ipv6 prefixes in BGP
router(config)#mpls ipv6 source-interface <interface>
Specifies the interface from which to inherit ipv6 addresses for
locally generated packets
Presentation_ID 27
27
© 2001, Cisco Systems, Inc. All rights reserved.
27
6PE Show Commands
• Three show commands extended
show bgp ipv6 <ipv6-prefix>
displays the mpls label value advertized for the IPv6 prefix
show bgp ipv6 neighbor
displays the mpls label capability negotiated with the BGP peer
show mpls forwarding-table
6PE labels are displayed with outgoing tag as “Aggregate” and
prefix as “6PE imposition”
Presentation_ID 28
28
© 2001, Cisco Systems, Inc. All rights reserved.
28
6PE configuration
ip cef
mpls label protocol ldp
tag-switching tdp router-id
loopback0
!
interface Serial2/0
ip address 10.10.10.2
255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
!
ipv6 cef
mpls label protocol ldp
mpls ipv6 source-interface Loopback0
mpls ldp router-id loopback0
!
interface Loopback0
ip address 10.10.20.2 255.255.255.255
ipv6 address 2003::/64 eui-64
!
router bgp 100
no synchronization
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.10.20.1 remote-as 100
neighbor 10.10.20.1 update-source Loopback0
!
address-family ipv6
neighbor 10.10.20.1 activate
neighbor 10.10.20.1 send-label
redistribute connected
redistribute rip ripv6CE1
exit-address-family
!
6PE
6PE
P
P
6CE
6CE
Staticv6
RIPv6
ISISv6
eBGPv6
Presentation_ID 29
29
© 2001, Cisco Systems, Inc. All rights reserved.
29
Show bgp ipv6 <ipv6-prefix>
Router> show bgp ipv6 2003:1:1:30::/64
BGP routing table entry for 2003:1:1:30::/64, version 2
Paths: (1 available, best #1, table Global-IPv6-Table)
Not advertised to any peer
Local
::FFFF:10.10.20.1 (metric 10) from 10.10.20.1 (192.168.254.1)
Origin incomplete, metric 0, localpref 100, valid,
internal, best
Presentation_ID 30
30
© 2001, Cisco Systems, Inc. All rights reserved.
30
Show bgp ipv6 neighbor
Router> show bgp ipv6 neighbors 10.10.20.1
BGP neighbor is 10.10.20.1, remote AS 100, internal link
BGP version 4, remote router ID 192.168.254.1
BGP state = Established, up for 00:04:07
Last read 00:00:07, hold time is 180,
Neighbor capabilities:
Route refresh: advertised and received(old & new)
Address family IPv6 Unicast: advertised and received
ipv6 MPLS Label capability: advertised and received
For address family: IPv6 Unicast
BGP table version 2, neighbor version 2
Index 1, Offset 0, Mask 0x2
Route refresh request: received 0, sent 0
Sending Prefix & Label
2 accepted prefixes consume 144 bytes
Prefix advertised 1, suppressed 0, withdrawn 0
Number of NLRIs in the update sent: max 1, min 0
Presentation_ID 31
31
© 2001, Cisco Systems, Inc. All rights reserved.
31
Show mpls forwarding-table
Router> show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 16 10.10.20.4/32 0 Se0/0 point2point
17 Pop tag 10.10.10.0/30 0 Se0/0 point2point
18 Pop tag 10.10.20.3/32 0 Se0/0 point2point
19 18 10.10.40.0/30 0 Se0/0 point2point
20 19 10.10.20.2/32 0 Se0/0 point2point
21 Aggregate IPv6 2080
Presentation_ID 32
32
© 2001, Cisco Systems, Inc. All rights reserved.
32
Show ipv6 route
Router> show ipv6 route
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
B 2003:1:1:30::/64 [200/0]
via ::FFFF:10.10.20.1, IPv6-mpls
L 2003::205:32FF:FEC3:40E1/128 [0/0]
via ::, Loopback0
C 2003::/64 [0/0]
via ::, Loopback0
L FE80::/64 [0/0]
via ::, Null0
Presentation_ID 33
33
© 2001, Cisco Systems, Inc. All rights reserved.
33
Agenda
• IPv6 migration approaches enabled by
MPLS
• 6PE approach: IPv6 Provider Edge Router
over MPLS/IPv4
• Cisco IOS 6PE configuration


Conclusions
Conclusions
Presentation_ID 34
34
© 2001, Cisco Systems, Inc. All rights reserved.
34
Conclusions
• IPv6 migration does not “need” MPLS … but,
where MPLS is deployed, it enables attractive
approaches for IPv6 migration
• Cisco IPv6 and MPLS solutions provides the
broadest deployment scenario feature set
• Cisco’s 6PE is one such IPv6 migration approach
over IPv4 MPLS, which offers IPv6 deployment at
marginal cost/risk:
no upgrade/reconfig in IPv4/MPLS core
IPv6 simultaneously with IPv4, IPv4 VPNs, ATM,

35Presentation_ID
© 1999, Cisco Systems, Inc.
www.cisco.com
36
© 2001, Cisco Systems, Inc.