ROUTING IN CISCO ROUTERS

aliveboonevilleΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 3 χρόνια και 5 μήνες)

67 εμφανίσεις

By: ASIF RAZA

1

of 4

CCNA

ROUTING IN CISCO ROUTERS


Manual Routing


Static Routing


Syntax


Router(config)#ip route destination_NID mask
next_hop_address/exitinterface admin_distance permanent


Example # 1

Router(config)#ip route 10.0.0.0 255.0.0.0 192.168.1.2


Example # 2

Router(config)#ip route 10.0.0.0 255.0.0.0 192.168.1.2 10
permanent


Where, 10 is administrative distance, and permanent means
that never flush the path from the routing table even the
link is down.


Default Routing


Router(config)#ip route 0.0.0.0 0.0
.0.0 192.168.1.2

Or

Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2 10

Or

Router(config)#ip route 0.0.0.0 0.0.0.0 serial 0


Where, the first command will add a default routing path
with admin distance of 1 or second will add path with
admin d
istance of 10 or third will add default wouting path
with admin distance of 0 by default.


Options

Router(config)#ip classless


To enable classless routing support.


Dynamic Routing


Configuring RIP


Syntax:

Router(config)#Router Rip

By: ASIF RAZA

2

of 4

Router(config
-
router)#
NID of serial interface towards the
destination

Router(config
-
router)#NID of ethernet interface directly
connected



Example:

Router(config)# router rip

Router(config
-
router)# 192.168.1.0

Router(config
-
router)# 10.0.0.0


Options


Router(config
-
router)# ver
sion 2

Router(config
-
router)# distance 10

Router(config
-
router)# passive
-
interface serial 0



Configuring IGRP


Router(config)#Router IGRP 10

Router(config
-
router)#NID of serial interface towards the
destination

Router(config
-
router)#NID of ethernet interf
ace directly
connected


Examples


Router(config)# router IGRP 10

Router(config
-
router)# 192.168.1.0

Router(config
-
router)# 10.0.0.0


Options


Router(config
-
router)# distance 10

Router(config
-
router)# passive
-
interface serial 0


Debugging RIP


Router#debug
ip rip

To enable debugging


Router#undebug all

Or

Router#no debug ip rip

To disable debugging


By: ASIF RAZA

3

of 4


Debugging IGRP

Router# debug ip igrp events

Router#debug ip igrp transactions




Configuring EIGRP


Router(config)#router eigrp autonomas_system_number

Router(
config
-
router)#network directly_connected_network

Router(config
-
router)#network serial network


Example:

Router(config
-
router)#router eigrp 10

Router(config
-
router)#network 10.0.0.0

Router(config
-
router)#network 100.0.0.0

Router(config
-
router)#network 101.
0.0.0


Options:

Router(config
-
router)#auto
-
summary

Router(config
-
router)#distance mention_AD

Router(config
-
router)#passive
-
interface interface number


Verify EIGRP

Command

Function

Show ip route

To display the routing table

Show ip route eigrp

To displa
y only the eigrp
entries in the routing table

Show ip eigrp neighbours

To show all eigrp neighbours

Show ip eigrp topology

To display the eigrp topology
table



Configuring OSPF


Syntax


Router(config)#router ospf process_ID

Router(config
-
router)#networ
k dir_connected_network
wildcard_mask area number

Router(config
-
router)#network serial_network
wildcard_mask area number


Example:

Router(config)#router ospf 10

By: ASIF RAZA

4

of 4

Router(config
-
router)#network 10.0.0.0 0.255.255.255 area
0

Router(config
-
router)
#network 100.0.0.0 0.255.255.255
area 0


Options

Router(config
-
router)#distance AD_no

Router(config
-
router)#passive
-
interface interface number

Router(config
-
router)#summary
-
adress network_Summary_ID



Verify OSPF

Commands

Function

Show ip route

To
show the routing table

Show ip ospf

To show ospf processes
running

Show ip ospf database

To display the topology
database and neighbour router
Ids

Show ip ospf interface

To display the all ospf
interfaces information

Show ip ospf neighbour

To display t
he summaries
information regarding
neighbour routers

Show ip ospf protocols

To display the information of
all runing routing protocols
along with th ospf







Configuring Loopback Interface


Router(config)#interface loopback 0

Router(config
-
if)#ip addr
ess 150.150.0.0 255.255.255.255

Router(config)#no shutdown