MetroEthernet & MPLS VPN Service CAT GigabitWAN Project Draft

aliveboonevilleΔίκτυα και Επικοινωνίες

28 Οκτ 2013 (πριν από 4 χρόνια και 16 μέρες)

82 εμφανίσεις

















MetroEthernet & MPLS VPN Service

CAT GigabitWAN Project

Draft



























Advanced Information Technology PCL.


2

Ethernet Wire Service
(
EWS
)

ISP VLAN

1111







Configuration


hostname
brk
-
core7600

!

interface Vlan1111


description

ews
-
be
-
inter from sp vlan 1111 to 1111



mtu 9216


no ip address


xconnect 61.19.141.2 1111 encapsulation mpls


hostname
nbi
-
core7600

!

interface Vlan1111


description

ews
-
be
-
inter
from sp vlan 1111 to 1111



mtu 9216


no ip address


xconnect 61.19.141.1 1111 encapsulation mpls


hostname
brk
-
acce3550
-
01

!

interface FastEthernet0/1


description

Link to Customer1



switchport access vlan 1111


switchport mode dynamic desirable


load
-
i
nterval 30


l2protocol
-
tunnel cdp


no cdp enable


spanning
-
tree portfast


hostname
nbi
-
acce3550
-
01

!

interface FastEthernet0/1


3


description "link to Customer2"


switchport access vlan 1111


switchport mode dynamic desirable


load
-
interval 30


l2protocol
-
tunnel cdp


no cdp enable


spanning
-
tree portfast


Verify


brk
-
core7600#
show mpls l2transport vc


Local intf Local circuit Dest address VC ID Status

-------------

--------------------

---------------

----------

----------

Vl1111 Eth VLAN 1111 61.19.141.2 1111 UP


Customer1#
ping 101.101.101.2


Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 101.101.101.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5
), round
-
trip min/avg/max = 1/1/4 ms
































4

Ethernet Relay Service ( ERS )

ISP VLAN 121
2







Configuration


hostname
brk
-
core7600

!

interface Vlan1212


description "ERS
-
BE Inter from SP VLAN 1212 to 1212"


mtu 9216


no ip address


xconnect 61.19.141.2 1212 encapsulation mpls


hostname
nbi
-
core7600

!

interface Vlan1212


description "ERS
-
BE Inter from SP VLAN 1212 to 1212"


mtu 9216


no ip address


xconnec
t 61.19.141.1 1212 encapsulation mpls


hostname
brk
-
acce3550
-
01

!

mls qos aggregate
-
policer aggr
-
vlan1212 5000000 250000 exceed
-
action drop

!

class
-
map match
-
all vlan1212
-
data


match vlan 1212


match class
-
map ip
-
traffic

class
-
map match
-
all vlan1212
-
L2


match vlan 1212


match class
-
map L2
-
traffic

!

policy
-
map pol
-
fa2


description Input policy
-
map for ERS
-
BE Inter


class vlan1212
-
data


5


police aggregate aggr
-
vlan1212


trust dscp


set cos 0


class vlan1212
-
L2


police aggregate aggr
-
vlan121
2


trust dscp


set cos 0

!

interface FastEthernet0/2


description "UNI to Customer1"


switchport trunk encapsulation dot1q


switchport trunk allowed vlan 1212


switchport mode trunk


load
-
interval 30


no cdp enable


spanning
-
tree portfast trunk


span
ning
-
tree bpdufilter enable


service
-
policy input pol
-
fa2


hostname
nbi
-
acce3550
-
01

!

mls qos aggregate
-
policer aggr
-
vlan1212 5000000 250000 exceed
-
action drop

!

class
-
map match
-
all vlan1212
-
data


match vlan 1212


match class
-
map ip
-
traffic

class
-
map
match
-
all vlan1212
-
L2


match vlan 1212


match class
-
map L2
-
traffic

!

policy
-
map pol
-
fa2


description Input policy
-
map for ERS
-
BE Inter


class vlan1212
-
data


police aggregate aggr
-
vlan1212


trust dscp


set cos 0


class vlan1212
-
L2


police
aggregate aggr
-
vlan1212


trust dscp


set cos 0

!

interface FastEthernet0/2


description "UNI to Customer1"


switchport trunk encapsulation dot1q


switchport trunk allowed vlan 1212


switchport mode trunk


load
-
interval 30


no cdp enable


spanning
-
tree portfast trunk


spanning
-
tree bpdufilter enable


service
-
policy input pol
-
fa2






6

verify


brk
-
core7600#
show mpls l2transport vc


Local intf Local circuit Dest address VC ID Status

-------------

--------------------

---------------

----------

----------

Vl1212 Eth VLAN 1212 61.19.141.2 1212 UP


Customer1
#show interfaces fastEthernet 0/1.1212

FastEthernet0/1.1212 is up, line protocol is up


Hardware is Gt96k FE, address is 0012.4355.a
2a1 (bia 0012.4355.a2a1)


Description: "ers curcuit"


Internet address is
102.102.102.1/24


MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,


reliability 255/255, txload 1/255, rxload 1/255


Encapsulation 802.1Q Virtual LAN,
Vlan ID 1212
.


ARP type
: ARPA, ARP Timeout 04:00:00


Last clearing of "show interface" counters never


Customer1#
ping 102.102.102.2


Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 102.102.102.2, timeout is 2 seconds:

!!!!!

Success rate is
100

percent (5/5), round
-
trip min/avg/max = 1/2/4 ms



























7

Ethernet Multipoint Service ( E
MS )
ISP VLAN

1117






Configuration


hostname
brk
-
core7600

!

l2 vfi vfi1117 manual


vpn id 1117


neighbor 61.19.141.2 encapsulation mpls

!

interface Vlan1117


description EMS Inter from SP VLAN 1117 to 1117 and 1117


mtu 9216


no ip address


no ip igmp snooping


xconnect vfi vfi1117


hostname
nbi
-
core7600

!

l2 vfi vfi1117 manual


vpn id
1117


neighbor 61.19.141.1 encapsulation mpls

!

interface Vlan1117


description EMS Inter from SP VLAN 1117 to 1117 and 1117


mtu 9216


no ip address


no ip igmp snooping


xconnect vfi vfi1117


hostname
brk
-
acce3550
-
01

!

interface FastEthernet0/3


description "UNI to Customer1"


switchport access vlan 1117


8


switchport mode dynamic desirable


l2protocol
-
tunnel cdp


no cdp enable


spanning
-
tree portfast


hostname
nbi
-
acce3550
-
01

!

interface FastEthernet0/3


description "UNI to Customer1"


switchport
access vlan 1117


switchport mode dynamic desirable


l2protocol
-
tunnel cdp


no cdp enable


spanning
-
tree portfast


Verify


brk
-
core7600#
show mpls l2transport vc


Local intf Local circuit Dest address VC ID Status

-------------

--------------------

---------------

----------

----------

VFI vfi1117 VFI 61.19.141.2 1117
UP



Customer1#
ping 101.101.101.2


Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 101.101.101.2, timeout is 2

seconds:

!!!!!

Success rate is
100

percent (5/5), round
-
trip min/avg/max = 1/2/4 ms
























9

ERS access to MPLS VPN
ISP VLAN

1319






Configuration


hostname
brk
-
core7600

!

ip vrf
VPN1319


rd 100:1319


route
-
target export 100:1319


route
-
target import 100:1319

!

interface GE
-
WAN7/4.1319


description " VPN1319 to customer1 "


encapsulation dot1Q 1319


ip vrf forwarding VPN1319


ip address 107.107.107.1 255.255.255.252


mls qos tr
ust dscp

!

router bgp 18252


no synchronization


bgp log
-
neighbor
-
changes


neighbor 61.19.141.4 remote
-
as 18252


neighbor 61.19.141.4 description mnb
-
core7600


neighbor 61.19.141.4 update
-
source Loopback0


no auto
-
summary


!


address
-
family vpnv4


neighbor 61.19.141.4 activate


neighbor 61.19.141.4 send
-
community both


exit
-
address
-
family


!


address
-
family ipv4 vrf VPN1319


redistribute connected


no auto
-
summary


no synchronization


10


exit
-
address
-
family


hostname
mnb
-
core7600

!

ip vrf VPN1
319


rd 100:1319


route
-
target export 100:1319


route
-
target import 100:1319

!

interface FastEthernet0/1.319


encapsulation dot1Q 319


ip vrf forwarding VPN1319


ip address 108.108.108.1 255.255.255.0


no cdp enable

!

router bgp 18252


no synchronization


bgp log
-
neighbor
-
changes


neighbor 61.19.141.1 remote
-
as 18252


neighbor 61.19.141.1 description brk
-
core7600


neighbor 61.19.141.1 update
-
source Loopback0


no auto
-
summary


!


address
-
family vpnv4


neighbor 61.19.141.1 activate


neighbor 61.19.141.1 send
-
community both


exit
-
address
-
family


!


address
-
family ipv4 vrf VPN1319


redistribute connected


no auto
-
summary


no synchronization


exit
-
address
-
family


hostname
brk
-
acce3550
-
01

!

interface FastEthernet0/4


description "MPLS VPN UNI to Customer1"


switc
hport access vlan 1319


switchport mode dynamic desirable


no ip address


load
-
interval 30


l2protocol
-
tunnel cdp


no cdp enable


spanning
-
tree portfast


hostname
mnb
-
acce3550
-
01

!

interface FastEthernet0/4


description "MPLS VPN UNI to Customer3"


switchport access vlan 319


switchport mode dynamic desirable


no ip address


load
-
interval 30


l2protocol
-
tunnel cdp


no cdp enable


11


spanning
-
tree portfast


Verify


brk
-
core7600#
show ip vrf interfaces

Interface IP
-
Address VRF

Protocol

GE
-
WAN7/4.1319 107.107.107.1
VPN1319

up



brk
-
core7600#
show ip route vrf VPN1319

Codes: C
-

connected, S
-

static, I
-

IGRP, R
-

RIP, M
-

mobile, B
-

BGP


D
-

EIGRP, EX
-

EIGRP exte
rnal, O
-

OSPF, IA
-

OSPF inter area


N1
-

OSPF NSSA external type 1, N2
-

OSPF NSSA external type 2


E1
-

OSPF external type 1, E2
-

OSPF external type 2, E
-

EGP


i
-

IS
-
IS, su
-

IS
-
IS summary, L1
-

IS
-
IS level
-
1, L2
-

IS
-
IS level
-
2


ia
-

IS
-
IS inter area, *
-

candidate default, U
-

per
-
user static route


o
-

ODR, P
-

periodic downloaded static route


Gateway of last resort is not set



108.0.0.0/24 is subnetted, 1 subnets

B

108.108.108.0 [200/0] via 61.19.141.4,

00:12:28


107.0.0.0/30 is subnetted, 1 subnets

C

107.107.107.0 is directly connected, GE
-
WAN7/4.1319


brk
-
core7600#
ping vrf VPN1319 107.107.107.2


Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 107.107.107.2, timeout is 2
seconds:

!!!!!

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 1/1/4 ms


Customer1#
ping 107.107.107.1


Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 107.107.107.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5)
, round
-
trip min/avg/max = 1/1/1 ms


Customer1#
ping 108.108.108.2


Type escape sequence to abort.

Sending 5, 100
-
byte ICMP Echos to 108.108.108.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round
-
trip min/avg/max = 1/1/4 ms